DDC Suite 2.5

Version: V2.8.112

Version 2.8.036

- Help EN finished

DDC 2.5 Initialisation

DDC 2.5 BACnet

DDC 2.5 Alarming

DDC 2.5 Set points

DDC 2.5 Analogue values

DDC 2.5 Controls

DDC 2.5 Controller

DDC 2.5 Systems


DDC 2.5 Initialisation

Version: 2.5.000

PCS define

PCS modify

Alarm Header

Initialisation

Anti-block protection

Fire dampers

Binary connect 1.5

Register connect 1.5

Manual operation 2.0

Media access 1.5

Offline trending

Documentation


PCS define

Family: | DDC 2.5 Initialisation
Name: | PCS define
Macro: | _DDC_INAKS250
Version: | 2.5.001

Description

This FBox is used to define an PCS (= Plant Coding System) of up to 10 levels for a specific use (e.g. "Alarming").

Adjust |
[ --- System functions --- ] |
Use for | Selects usage for PCS. At the moment only option "BACnet - ON", "BACnet - D" and "Alarmng" is used..
[--- PCS ---] |
Level 1 | Text level 1 of PCS
Level 2 | Text level 2 of PCS
Level 3 | Text level 3 of PCS
Level 4 | Text level 4 of PCS
Level 5 | Text level 5 of PCS
Level 6 | Text level 6 of PCS
Level 7 | Text level 7 of PCS
Level 8 | Text level 8 of PCS
Level 9 | Text level 9 of PCS
Level 10 | Text level 10 of PCS
[ --- DDC Suite V 2.5 --- ] |

Functional

The PCS comprises a building key that is defined by the planner/operator. The PCS provides up to 10 levels. Text fields for the individual levels can be filled with any choice of text; however quotation marks (") are not allowed.

Texts in the individual levels merge seamlessly with each other. If a character space must stand between the individual levels, this should also be added either before or after each separate text.

The PCS can be used for a variety of purposes. It may be utilized as

- General currently not in use. Reserved for future use.

- Alarming to generate alarm texts for S-Web Alarming

- SCADA currently not in use. Reserved for future use with SCADA connections

- BACnet - ON to generate BACnet objects (ON = Object Name), will be reflected in the object name.

- BACnet - D to generate BACnet objects (D = Description), will be reflected in the Property Description.

- USer1..5 free for use as desired

It is therefore possible to use a different AKS for S-Web Alarming (e.g. more in plain text) than for BACnet (e.g. more technically orientated).

During compiling, the FBox generates symbols than can be further used in the code or in "Advanced Files", but which are not visible in the SymbolEditor. No PCD texts are stored, so the FBox does not take up any PCD resources.

The FBox can be placed as often as required and will always overlay the preceding FBox (as long as the same use has been selected).

Predefined


PCS modify

Family: | DDC 2.5 Initialisation
Name: | PCS modify
Macro: | _DDC_INAKSMOD250
Version: | 2.5.000

Description

This FBox can be used to adjust one individual level of an PCS (= Plant Coding System).

Adjust |
[ --- System functions --- ] |
Use for | Selects usage for PCS. At the moment only option "BACnet - ON", "BACnet - D" and "Alarmng" is used..
Level | Level to be modified. All other leves stay unchanged.
Text | Selected level text
[ --- DDC Suite V 2.5 --- ] |

Functional

It is often necessary to adjust one individual level of an AKS. This can be achieved with this FBox. The "PCS define" FBox, with its corresponding use, must already have been placed in front of this FBox in the Fupla.

As with the "PCS define" FBox, the use (e.g. "Alarming") must be defined here, together with the level to be adjusted and the new text for the selected level.

All other levels for the selected use (e.g. "Alarming") remain unchanged. Only this element is modified.

During compiling, the FBox changes the symbols (or their content) to ones for further use in the code or in "Advanced Files", but which are not visible in the SymbolEditor. No PCD texts are stored, so the FBox does not take up any PCD resources.

The FBox can be placed as often as required and will always overlay the preceding FBox of the chosen level (as long as the same use has been selected).

Predefined


Alarm Header

Family: | DDC 2.5 Initialisation
Name: | Alarm Header
Macro: | _DDC_INALMHDR250
Version: | 2.5.000

Description

With the aid of this FBox, alarms from the following FBoxes which are parameterised for the "PCD Alarmverwaltung" are instructed to integrate them in the alarm list referenced here.

Moreover, a start index is specified for all the following alarms. Then this start index is added to the parameterised alarm number in the following FBoxes.

Adjust |
[ --- System functions --- ] |
Base alarm index | Base index for following alarms. Resultand alarm number = BaseIdx PCD Alarm administration (Index) from FBox -1
Description | Prefix for all alarms. The alarmtext is generated with tihs text + alarming level 1-10 + description + alarmtext
[ --- DDC Suite V 2.5 --- ] |

Functional

This FBox expects that the FBox "Alarm SWeb Init" from the FBox family "Alarming" is available at least once.

As several alarm lists can be defined per PCD, the following FBoxes should be informed of the alarm list in which the alarms will be integrated. For the FBox family "Alarming", this is implemented over the name/reference mechanism.

In the FBoxes of the DDC Suite, the reference is already engaged in another function. The FBoxes that prepare alarms therefore require another mechanism.

The "Alarm Hdr" FBox is linked to the alarm list via reference, which should accept the following alarms from the FBoxes. This FBox then prepares the information for the applicable alarm list, which is then used by the following FBoxes.

This FBox can be placed several times, then each time all alarms are implemented in this referenced alarm list.

The first alarm number of the following alarms is defined by the parameter [base alarm index]. For instance, if 101 is entered here and the first alarm number in an FBox is defined with 11, actually the alarm is specified with alarm number 111 (base alarm index alarm number -1).

In this way, it is very simple to move all alarms in templates just by adjusting the base alarm index].

When building the programme, a CSV file (DDC_Alarming.csv) is generated, which contains all alarm numbers and alarm texts. In addition, variables required to connect the list number in the CSV file with the actual alarm list in the PCD are also created in the symbol editor in "System Tab" under "A.Alarm". These variables always begin with the prefix "DDC_" and subsequently bear the name of the referenced alarm list. The value (column Address/Value) mirrors the list number in the CSV file.

In the following graphic representation, one can see how a symbol is generated in the "System Tab" of the symbol editor with the name of the FBox and the list number assigned internally in the process. In the CSV it can be identified that the alarms of the "List_2" are assigned to the "AlarmList_Heating".

The automatically generated file "DDC_Alarming.csv" contains all alarms that were parameterised by means of the DDC Suite FBoxes. The CSV file lightens the parameterisation of the alarms in an SWeb project (SWeb Editor). The CSV file can be opened with Excel and sorted for instance in ascending order in column "A" and descending order in "B":

After the sorting, one can easily cut the continuously parameterised text in column "D" and paste in the CSV file of the SWeb application.

The automatically generated alarm texts consist of the "FBox Property", "Name" and a detailed description. The detailed description is included in the external files and can be adapted if need be.

The additional programme "DDC SWeb Alarming AddOn" undertakes all the individual steps which are to be executed as described before in the Excel:

For this purpose, the file to be used "DDC_Alarming.csv" has to be specified. In the SWeb project, the CSV file which contains the alarm entries among other things should be named SWebText."csv". The add-on then transfers all alarms from the file "DDC_Alarming.csv" to the file "SWebTexte.csv". Non-defined alarms are sort of "deleted" with a "-" as alarm text.

Attention! Manual modifications in alarm texts in the file "SWebText.csv" are overwritten by this tool.

Predefined


Initialisation

Family: | DDC 2.5 Initialisation
Name: | Initialisation
Macro: | _DDC_INLIBRARY250
Version: | 2.5.000

Description

Provides basic functions and variables for the FBoxes of the DDC families and must be mandatorily set, like the initialisation of the HLK library, before the first DDC Suite FBox

Input |
AckAla | Reset all stored alarms
AckMt | Reset maintenance messages
WD | Activate WatchDog
OutTemp | Outdoor air temperature

Output |
ResAla | Reset hardware or user programed stored alarms
ResMt | Reset user programed maintenance messages
Err | Error in PCD (any XOB)
Bat | Battery weak
Pulse | Seconds impulse for a program cycle

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Alarm administration (Idx) | Controls if alarms are registered in a SWeb alarm list. 0 = No, -1 = Alarm number assigned automatically, >0 = fix (start)alarm number. (FBox Alarm SWeb/AlarmHdr)
BACnet | Select if and what kind of BACnet objects should be generated automatically
Working hours | Selects if after program download FBoxes with working hours stay unchanged or will be initialized with offline-value
[ --- Alarm messages --- ] |
SCADA acknowledgement | Acknowledgement of alarm messages in all FBox with stored alarms
Impulse duration (sec) | Duration of activation of the acknowledgement output
Digital input reset (QitAla) | Input address acknowledgement button
Digital output reset (ResAla) | Output address hardware reset
[ --- Maintenance messages --- ] |
SCADA acknowledgement | Reset the maintenance messages and counters in all control FBoxes
[ --- WatchDog --- ] |
Slot 16 occupied | Defines in what way the WatchDog is generated by the software
[ --- Batterie --- ] |
Battery | Battery weak
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Überwachung --- ] |
Fault status PCD | Fault in PCD controller
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Diagnostics PCD --- ] |
Diagnostics history | Delete history
Current message | Cause of the error message
Program line | Program line in which the error has occurred
Index register | Content of the Index register on the occurrence of the error
COB Program line | Line number in the COB
Call number 1 | Line number in the call level 1
Call number 2 | Line number in the call level 2
Call number 3 | Line number in the call level 3
Call number 4 | Line number in the call level 4
Call number 5 | Line number in the call level 5
Call number 6 | Line number in the call level 6
Call number 7 | Line number in the call level 7
Reserve | Provision for later amendments
[ --- DDC Suite V 2.5 --- ] |

Functional

This FBox provides internal variables and functions for the FBoxes of the DDC Suite. It should be placed as the first and used before other FBoxes from this library (similar to the FBox initialisation HLK). The FBox initialisation HLK should be placed before this FBox.

All internal causes of failure (e.g. "Division by zero") are monitored in this FBox. Thereby the activation of the "Error LED" on the controller is prevented. Where applicable, a determined error (the last occurring failure) is displayed in the FBox. The potential failures can be:

XOB01 Power down in extension rack

XOB02 Low battery, output is also displayed

XOB05 No response from I/O module

XOB06 External error

XOB07 System overload

XOB08 Invalid opcode

XOB09 Too many active tasks (Graftec)

XOB10 PB / FB nesting depth overflow

XOB11 COB supervision time exceeded

XOB12 Index register overflow

XOB13 Error flag set

Central acknowledgement of failures

In addition, a central acknowledgement of the saved alarms is possible (via FBox input or the button in the Adjust Window). For this reason, all already saved alarms are reset in the normal status. A digital input for an acknowledgement button in the control cabinet can be directly parameterised in the Adjust Window, just as a digital output is activated for the then set time span during acknowledgement.

Central acknowledgement of maintenance messages

Moreover all maintenance messages (from the FBox with hours of operation) can also be reset (via FBox input or button in the Adjust Window). So all internal maintenance counters are also re-initialised. If this is not required, each of the pending maintenance messages can be reset in the individual FBoxes.

WatchDog

The WatchDog (relay) can be activated via the FBox input "WD". This relay responds via address 255 and/or 511, and for this reason no analogue input/output card can be inserted in the slots with the base address 240 and 496 respectively. However, digital cards are possible, but the last input/output should not be used. In this case, the parameter "Steckplatz 16 belegt" must be set with "Ja", as internally another algorithm should be used for the activation of the WatchDog relay.

The WatchDog relay stays switched on until an internal error (see list above) is detected. The WD relay is turned off and stays deactivated until the error has been reset via FBox parameter "history" reset and if any error does not occur immediately again. An error detected once will be still active after power down/up -means the WD stays off until a reset will be done.

This mechanism of switching off/on the WD relay is recently used to e.g. turn off an alarm signal (horn, lamp) or to signalize e.g. another PCD (a kind of redundancy) to take over some functionality in case of error.

If the WatchDog relay should only signalize a bad cycle time (switched of if 250 ms the program does not access the WD) the FBox "Hardware WatchDog" from family "Special functions" has to beused. In that case the "WD" input of DDC Suite FBox "Init" should not be activated.

Outside air temperature

The outdoor temperature associated with the output OutTemp is automatically transmitted to FBoxes which do not possess an input for the outside air temperature but need it. A representative outside air temperature should be connected.

Options

The outside air temperature and the acknowledgement are applicable for the entire programme. Still, to implement an acknowledgement for various systems or to use different outdoor temperatures, the FBox provides the following symbols. This can be read and also actively written on by the programme:

Symbol | Function
A.DDCSuite.Init.AckAlarm | Acknowledgement of the already saved error messages
A.DDCSuite.Init.ClrMaint | Acknowledgement of the pending maintenance messages
A.DDCSuite.Init.OutdoorTemp | Outside air temperature

Systemfunktion BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Specification
Battery | BI | Low battery message
XOB | BI | Internal error has occurred in the controller

Predefined

SCADA acknowledgement | AlaAck | F | 0 = running..
 |  |  | 1 = Trigger
Impulse duration (sec) | AlaAckHwImp | R | 0..600
Digital input reset (QitAla) | QuitDI | R | -1..1023
Digital output reset (ResAla) | QuitDO | R | -1..1023
SCADA acknowledgement | MaintAck | F | 0 = running..
 |  |  | 1 = Trigger
Battery | SmBatterie | F | 0 = OK
 |  |  | 1 = Fault !
Fault status PCD | PcdError | F | 0 = OK
 |  |  | 1 = ERROR
Diagnostics history | HistAck | F | 0 = running..
 |  |  | 1 = Delete
Current message | HistMsg | R | 0 = Everything OK
 |  |  | 1 = 1 PowerDownExt.
 |  |  | 2 = Battery
 |  |  | 5 = 5 I/O fault
 |  |  | 6 = 6 Extern.Err
 |  |  | 7 = 7 SysOverload
 |  |  | 8 = 8 InvOpcode
 |  |  | 9 = 9 too many Graftec
 |  |  | 10 = 10 PB/FB depth
 |  |  | 11 = 11 COB timeout
 |  |  | 12 = 12 Index overflow
 |  |  | 13 = 13 Error-Flag
 |  |  | 16 = 16 Restart
Program line | HistProgLine | R |
Index register | HistIndex | R |
COB Program line | HistCobLine | R |
Call number 1 | HistCall1 | R |
Call number 2 | HistCall2 | R |
Call number 3 | HistCall3 | R |
Call number 4 | HistCall4 | R |
Call number 5 | HistCall5 | R |
Call number 6 | HistCall6 | R |
Call number 7 | HistCall7 | R |
Reserve | HistReserve | R |


Anti-block protection

Family: | DDC 2.5 Initialisation
Name: | Anti-block protection
Macro: | _DDC_INANTIBLCK250
Version: | 2.5.000

Description

Central setting of the anti-block protection mechanisms of connected drives (pumps, open/close valves) and continuous drives

Input |
En2P | Allow antiblock protection function for pumps and damper actuator on/off (2 point control)
EnY | Allow antiblock protection for continuous drives

Output |
2P | Weekly requirement for pumps and drives on/off (2 point control)
Y | Weekly requirement for continuous drives

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- 2-point drives --- ] |
Mode | Mode selection of the antiblock protection function
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Downtime | Number of hours after which a movement run is to be activated
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Weekly | Weekday on which the movement mode is to be executed
... Clock time | Clock time of the day on which the movement mode is to be executed
Antiblock protection enabled | Display whether the antiblock protection function may be executed
... Requirement Weekly | Display of the weekly impulse of the movement mode
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Continuous drive --- ] |
Mode | Mode selection for the antiblock protection function
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Downtime | Number of hours after which a movement run is to be activated
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Weekly | Weekday on which the movement mode is to be executed
... Clock time | Clock time of the day on which the movement mode is to be executed
Antiblock protection enabled | Display whether the antiblock protection function may be executed
... Requirement Weekly | Display of the weekly impulse of the movement mode
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- DDC Suite V 2.5 --- ] |

Functional

The FBoxes of the family controls are partially equipped with an anti-block protection, which should prevent the arrest of the drives during long down times, for example heating pumps in summer.

The anti-block protection for connected drives can be generally disabled via the input En2P (EnY for continuous drives). When a high signal is present, the function is ready for operation. The anti-block protection mechanism is selected via the parameter Mode . The following types are available:

- Off : The anti-block protection function is deactivated.

- Down time: The anti-block protection function is activated according to the down time. Each connected drive (and/or continuous drive) monitors itself and if need be, activates a starting.

- Weekly: The anti-block protection function is activated at the set time once a week (Mo-Su). This requirement is also copied on output Uwp (Y in continuous drives).

Systemfunktion BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Object | Note | Specification
MV | - | Prefix of connected drives
AV | - | Number of hours after which a motion sequence should be activated
BV | Commandable | Weekly requirement, e.g. via a scheduler
MV | - | Prefix of continuous drives
AV | - | Number of hours after which a motion sequence should be activated
BV | Commandable | Weekly requirement, e.g. via a scheduler

Predefined

Mode | MotMode | R | 1 = Off
 |  |  | 2 = Downtime
 |  |  | 3 = Weekly
Downtime | MotHours | R | 0..2400
Weekly | MotDay | R | 1 = Monday
 |  |  | 2 = Tuesday
 |  |  | 3 = Wednesday
 |  |  | 4 = Thursday
 |  |  | 5 = Friday
 |  |  | 6 = Saturday
 |  |  | 7 = Sunday
... Clock time | MotTime | R | 0..2359
Antiblock protection enabled | MotEn | F | 0 = Off
 |  |  | 1 = On
... Requirement Weekly | MotWeekPulse | F | 0 = Off
 |  |  | 1 = On
Mode | DrvMode | R | 1 = Off
 |  |  | 2 = Downtime
 |  |  | 3 = Weekly
Downtime | DrvHours | R | 0..2400
Weekly | DrvDay | R | 1 = Monday
 |  |  | 2 = Tuesday
 |  |  | 3 = Wednesday
 |  |  | 4 = Thursday
 |  |  | 5 = Friday
 |  |  | 6 = Saturday
 |  |  | 7 = Sunday
... Clock time | DrvTime | R | 0..2359
Antiblock protection enabled | DrvEn | F | 0 = Off
 |  |  | 1 = On
... Requirement Weekly | DrvWeekPulse | F | 0 = Off
 |  |  | 1 = On


Fire dampers

Family: | DDC 2.5 Initialisation
Name: | Fire dampers
Macro: | _DDC_INFIREDAMP250
Version: | 2.5.000

Description

Initialisation FBox for subsequent error message FBoxes Brandschutzklappe of the family DDC Alarming . This FBox serves for the central activation of a fire damper test for motor-driven dampers

Input |
Test | Starts the fire damper test
Reset | Aborts an active fire damper test

Output |
Test | Requirement for Fire damper test, relay on the FBoxes FireDamper
Date | Date at the start of the Fire damper test
Time | Time of the start of the Fire damper test
Fault | Displays whether at least one feedback of all connected FD was not reported correctly
Memory | After termination of the Fire damper test on 1 for one program cycle for triggering user programed functions

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Damper test --- ] |
Start test | Starts the fire damper test
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Abort test | Aborts the Fire damper test
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Status of the test | Display whether the test is running or is over
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Settings --- ] |
Duration of feedback Closed | Delay until after Actuation Closed the feedback Message Closed must be in place
Duration feedback Open | Delay until after Actuation Open the feedback Message Open must be in place
[ --- Damper test --- ] |
Number of FD connected | Number of the FD connected through Name/Ref
... of successfully tested | Number of the FD tested successfully in the test
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
... of failed test | Number of the faulty FD tested in the test
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Triggered on | Date of the last Fire damper test.
... Time | Time of the last Fire damper test.
Result of the test | Result of the last test, OK or Error
[ --- DDC Suite V 2.5 --- ] |

Functional

Initialisation FBox for subsequent error message FBoxes Fire damper of the family DDC Alarming . This FBox serves for the central activation of a fire damper test for motor-driven dampers.

The FBoxes Fire damper of the family DDC Alarming are attached to this Init-FBox via Name/Ref mechanism. The number of the dampers thus connected is automatically determined.

The lag times for the feedbacks Open and Close are preset here centrally for all connected dampers.

The fire damper test is started in the selection window via the output Test or the button start . A running fire damper test can be discontinued in the selection window via the input Reset or the button cancel .

The output Test is activated with the fire damper test. It is to be linked to all connected dampers, whereby it can take place in parallel and in series (by relay of the fire damper FBox).

The connected dampers subsequently control the damper in direction Close and then in direction Open . Every damper that has successfully tested is counted, just as all dampers which have established a feedback error.

After all the dampers have been tested, the Test end and date, time, error and memory are issued to process the information further.

Systemfunktion BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Object | Note | Specification
BV | - | Start trigger test
BV | - | Cancel trigger test
BI | - | Indication of ongoing test
AV | - | Number of successfully tested dampers
AV | - | Number of dampers which have established a feedback signal error

Predefined

Start test | Start | F | 0 = running..
 |  |  | 1 = Start
Abort test | Cancel | F | 0 = running..
 |  |  | 1 = Abort
Status of the test | Status | F | 0 = Terminated
 |  |  | 1 = running..
Duration of feedback Closed | DurationClose | R | 0..36000
Duration feedback Open | DurationOpen | R | 0..36000
Number of FD connected | NumberFD | R |
... of successfully tested | NumberOK | R |
... of failed test | NumberFail | R |
Triggered on | Date | R |
... Time | Time | R |
Result of the test | Result | F | 0 = OK
 |  |  | 1 = Error


Binary connect 1.5

Family: | DDC 2.5 Initialisation
Name: | Binary connect 1.5
Macro: | _DDC_INCONBIN250
Version: | 2.5.000

Description

This FBox corresponds to the "L" and/or "H" FBoxes from the Heavac library, binary family, but can fit up to 5 outputs

Output |
# | Always outputs 0

Adjust
Value at output #0
Value at output #1
Value at output #2
Value at output #3
Value at output #4
[ --- DDC Suite V 2.5 --- ]

Functional

FBox inputs that are no longer required can be wired to this FBox. It can fit up to 5 outputs and one can select "Low" or "High" for each output

Predefined


Register connect 1.5

Family: | DDC 2.5 Initialisation
Name: | Register connect 1.5
Macro: | _DDC_INCONINT250
Version: | 2.5.000

Description

This FBox is the counterpart of FBox Binary connect for integer values and can fit up to 5 outputs

Output |
# | Gibt immer 0 aus

Adjust
Value at output #0
Value at output #1
Value at output #2
Value at output #3
Value at output #4
[ --- DDC Suite V 2.5 --- ]

Functional

FBox inputs that are no longer required can be wired quickly with this FBox. It can fit up to 5 outputs, and a separate value can be set for each output

Predefined


Manual operation 2.0

Family: | DDC 2.5 Initialisation
Name: | Manual operation 2.0
Macro: | _DDC_INMANUAL250
Version: | 2.5.000

Description

Shows whether FBoxes of the groups control systems (e.g. motors), regulators (all regulators) and drives (here only continuous drives) are not on automatic mode

Output |
Motors | Number of engine modules on manual (2 point)
Drives | Number of drive modules on manual (continous)
Controll | Number of control modules on manual (PID)

Adjust |
[ --- Motors --- ] |
in manual mode | Number of engine modules on manual
Set to | Set all engine modules to Auto
[ --- Drives --- ] |
in manual mode | Number of drive modules on manual
Set to | Set all drive modules to Auto
[ --- Controller --- ] |
in manual mode | Number of control modules on manual
Set to | Set all control modules to Auto
[ --- DDC Suite V 2.5 --- ] |

Functional

If the FBox is placed only once at the beginning of the programme, it monitors whether a button is not on "Auto" mode from all DDC Suite FBoxes of the families Controls and Controller . A reset to automatic mode then affects the entire programme.

If the FBox is set several times, it monitors only FBoxes up to the next FBox Manual operation . A reset to automatic mode then affects only in this section of the programme.

Predefined

in manual mode | MotCount | R |
Set to | MotAuto | F | 0 = ---
 |  |  | 1 = Automatic
in manual mode | DrvCount | R |
Set to | DrvAuto | F | 0 = ---
 |  |  | 1 = Automatic
in manual mode | ContrCount | R |
Set to | ContrAuto | F | 0 = ---
 |  |  | 1 = Automatic


Media access 1.5

Family: | DDC 2.5 Initialisation
Name: | Media access 1.5
Macro: | _DDC_INACCESS250
Version: | 2.5.000

Description

With this FBox, all resources (input, output, flag, timer, counter and index) can be for instance read and written from one terminal. With it, values can be modified on site, which are available on a display and/or a building control system (e.g. delay times of a V belt).

Adjust |
Media | Type of the Closed Resource with which to work
Address | Address of the resource
Value | Value of the resource, read or to write
Read | Action read start
Write | Action write start
Address | Displays an error if the address does not fit the selected resource type
[ --- DDC Suite V 2.5 --- ] |

Functional

By operating the button Read , the value is selected from the set resource and shown in the parameter Value .

By operating the button Write , the value on the parameter Value is written in the set resource.

Predefined

Media | Type | R | 0 = Input/Output
 |  |  | 1 = Flag
 |  |  | 2 = Timer/Counter
 |  |  | 3 = Register
Address | Address | R | 0..16383
Value | ResVal | R |
Read | CmdRead | F | 0 = Read
 |  |  | 1 = Execute
Write | CmdWrite | F | 0 = Write
 |  |  | 1 = Execute
Address | Error | F | 0 = OK
 |  |  | 1 = FALSCH


Offline trending

Family: | DDC 2.5 Initialisation
Name: | Offline trending
Macro: | _DDC_INHDLOG250
Version: | 2.5.000

Description

Basic settings for the trend recording in the DDC Suite FBoxes. Four typical trend types are parameterised These settings are then used in the following FBoxes with "PCD Offline Trending".

Adjust |
[--- Set points ---] |
Minimum value difference | Set point minimum value difference
Minimum delay (s) | Set point minimum delay (s)
Cyclic record (s) | Set point cyclic record (s)
Type of trend track | Set point type of trend track
[--- Actual values ---] |
Minimum value difference | Actual values minimum value difference
Minimum delay (s) | Actual values minimum delay (s)
Cyclic record (s) | Actual values cyclic record (s)
Type of trend track | Actual values type of trend track
[--- Signals ---] |
Minimum value difference | Signals minimum value difference
Minimum delay (s) | Signals minimum delay (s)
Cyclic record (s) | Signals cyclic record (s)
Type of trend track | Signals type of trend track
[--- Operating states ---] |
Minimum delay (s) | Operating states minimum delay (s)
Cyclic record (s) | Operating states cyclic record (s)
Type of trend track | Operating states type of trend track

Functional

The FBox "HDLog Init" should be available as all subsequent FBoxes that are parameterised for "PCD Offline Trending" use the standard HDLog trend functions.

The pre-setting of the data point type (target values, actual values, signals and feedbacks) and the recording mode is undertaken with the aid of this "HDLog" FBox from the DDC Suite. This essentially simplifies the parameterisation as this need be defined only once.

In a "Build" of the programme, these settings are written into the file "DDC_HDLog.txt". In addition, the subsequent FBoxes that are parameterised for "PCD Offline Trending" are also entered in this file. For this reason, there is a list of the settings for the trend recording and all parameterised trend data points.

In addition, you also see which symbol was generated for the connection in the SWeb offline trending macro for each individual trend track. This always begin with the grouping "A.HDLog".

Moreover, the "FBox Property" "Name" should be provided with a meaningful text in the following FBoxes which record the trend tracks. This name is also listed in the file, so that the associated FBox can also be easily found. And in the group "A.HDLog", a symbol under this name is generated for the SWeb trend display

Predefined


Documentation

Family: | DDC 2.5 Initialisation
Name: | Documentation
Macro: | _DDC_INDOCUMENT250
Version: | 2.5.000

Description

With this FBox, self-defined text modules can be linked to the automatically generated documentation files.

Adjust
Documentation macro
[ --- DDC Suite V 2.5 --- ]

Functional

Up to 20 text modules can be selected. The text modules are archived in files "DOC_DDC_UserModule1.src" till "DOC_DDC_UserModule20.src".

Predefined


DDC 2.5 BACnet

Version: 2.5.000

Device V10

Properties

Notification Class

Loop V250

Trendlog

Loop

Device


Device V10

Family: | DDC 2.5 BACnet
Name: | Device V10
Macro: | _DDC_BACDEV250
Version: | 2.5.000

Description

This FBox is required when DDC Suite FBoxes have to generate BACnet objects automatically and also behave accordingly. It must be placed before all other functional DDC Suite FBoxes that have been configured for "BACnet" (even before the Init FBox).

Aktivierung von BACnet Objekten

BACnet objects to be created can be selected in the FBoxes with the BACnet parameter:

This is current standard procedure. Note however that all --- BACnet Object-Name --- parameters are also provided with a text/building code.

In practice, situations frequently occur where BACnet objects may be generated, even though they are not needed, e.g. in FBox Control/Continuous. It is quite common to have manual override, but no real position feedback. To obtain manual intervention as a BACnet object, selection must be made in such a way that a BACnet object is also generated for position feedback. As a result, unnecessary BACnet objects are generated.

To resolve this problem, the parameters --- BACnet Object-Name --- are checked. If nothing has been entered (blank text field) generation of this BACnet object can be suppressed. The following rules should be observed:

1. Einstellung Parameter BACnet

From the selection list, the option listing required BACnet objects must at least be selected. For simplicity, it is possible in each case to select the maximum option.

2. Freie Auswahl der zu erzeugenden BACnet Objekte

All FBoxes that generate at least 2 BACnet objects can now be configured so that only the desired BACnet objects will be generated. For these objects the parameter --- BACnet Object-Name --- should be filled. Objects that are not to be generated must be left blank.

3. Abhängige Objekte

Some BACnet objects are referenced to other objects, e.g. for a measured value the trend log object is referenced to the analog input object. The referenced object must be generated (indication of BACnet Object Name). It is not enough only to parameterize the trend log object. Direct dependencies within an FBox check for this and also automatically suppress the referencing object if the object to be referenced is not generated. In FBoxes with external linkages (e.g. Loop) it is, of course, necessary to ensure that all required objects are generated.

4. Pflicht-Objekte

Some FBoxes have a mandatory object that is always created and cannot be suppressed by leaving bland the parameter --- BACnet Object-Name ---. This applies to the following FBoxes:

- Enable family: all switches (HMI parameter = resulting enable at FBox output)

- Regulation family: regulation signal (Signal parameter = resulting regulation signal at FBox output)

- Controller family: all switches (HMI parameter = resulting control signal at FBox output)

Mandatory objects are identified by an additional "!" in the --- BACnet Object-Name ! --- parameter.

5. FBoxen mit nur einem BACnet Objekt

The BACnet object is always created as soon as there is a BACnet = Yes setting. It is not possible to suppress the BACnet object by leaving blank the parameter --- BACnet Object-Name ---.

Adjust |
[ --- System functions --- ] |
Activate BACnet | Pre selection wheather BACnet is active or not. If activated the BACnet stack must be used - otherwise program won't work properly.
[--- Device ---] |
ID | BACnet Device ID
Name | Device Name of BACnet Controller
Description | Desription
[--- General ---] |
Text No. 1 | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Text No. 2 | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Text No. 3 | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Text No. 4 | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Text No. 5 | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- DDC Suite V 2.5 --- ] |

Functional

The "Device ID" is assigned by the BACnet Network Administrator. This ID may only exist once in any single BACnet network.

With the parameter "BACnet aktivieren" ("Enable BACnet") it is possible to control whether the program generated as a result of a build will work with BACnet or in the conventional way, without BACnet.

"No" means that no BACnet objects will be generated and the program will work without a BACnet stack.

"Yes" means that configured BACnet objects will be generated and the BACnet stack will be required for the program to function. "Yes" does not automatically enable all BACnet objects in subsequent FBoxes: in each FBox it is then possible to define individually which BACnet objects should be generated. An appropriate BACnet configuration must also be loaded into the PCD, as otherwise the FBoxes cannot work correctly.

The FBox independently generates just the "Device Object" in the configuration file "DDC_BACnet.bnt". This file is a complete BACnet configuration file that can be opened with the BACnet configurator. It does not make any sense to change anything in this file, as it is completely rebuilt every time there is a "Build".

Before using any BACnet configuration, a plant identification system (AKS) must be set up for the BACnet Object Name and Property Description. Read more about this in FBoxes "AKS Festlegen" (Define AKS) and "AKS anpassen" (Adapt AKS) in the "Initialization" family.

Texts in the "General" group are provisional and currently not in use in the BACnet configuration.

Predefined


Properties

Family: | DDC 2.5 BACnet
Name: | Properties
Macro: | _DDC_BACPROP250
Version: | 2.5.000

Description

This FBox adapts a BACnet object created in a running FBox into multiple objects (such as "SM engine"). Modification of Active/Inactive texts and Intrinsic Reporting are possible.

Adjust |
[--- Inactive/Active Text ---] |
Inactive text | Text with status [Low]
Active text | Text with status [High]
[--- Intrinsic Reporting ---] |
Use | Selection if this Intrinsic Reporting parameter should to be used or the parameter from Notificatrion Class FBox
Event Enable | Selection parameter Event-Enabled
Notify Type | Selection parameter Notification-Type
Profile Name | Selection parameter Profile-Name
Unsolicidet COV Enabled | Selection parameter Unsolicited-COV
<--- Event Message Text ---> |
To Off-Normal | Event Message Text To Off-Normal
To Fault | Event Message Text To Fault
To Normal | Event Message Text To Normal
[ --- DDC Suite V 2.5 --- ] |

Functional

It may occasionally be necessary to modify an individual object in an FBox. Usually, these will be the Active-Inactive texts or the Intrinsic Reporting, since the Notification Class of the latter is always predefined.

For example, if in FBox "Ala Fuse" (control voltages) it is necessary to change the message object "24 VAC down" in Intrinsic Reporting behaviour, FBox "Properties" must be placed before the FBox that will generate the actual object.

Afterwards, the FBox that generates the object and the "Properties" FBox must be given the same name: in this example "FuseGuard". Next, the Properties FBox must be told which object in the FBox named "FuseGuard" has to be adjusted. Since FBox "Sm Spg" generates 5 BACnet objects, clear assignment is necessary.

This information is contained in the line "--- BACnet Object Name ---". If it is clicked on, a dialog box will be displayed revealing the identifier: in this case Al24AC. The identifier must then be indicated as the reference in the Properties FBox. This specifies, therefore, that in the FBox named "FuseGuard" you wish to adjust object "Al24AC".

It is now simply necessary to set new properties (texts) in the Properties FBox. If the "Intrinsic Reporting" property has been set to "No", the FBox will adopt settings from the corresponding Notification Class. Otherwise, it is possible to define completely different Intrinsic Reporting here.

The adjustment will only apply for this one object in the FBox indicated.

Predefined


Notification Class

Family: | DDC 2.5 BACnet
Name: | Notification Class
Macro: | _DDC_BACNC250
Version: | 2.5.001

Description

This FBox sets up a Notification Class object and defines presets for objects to be associated with this Notification Class.

Adjust |
[ --- System functions --- ] |
Object name | Object Name. It´s NOT generated as in all other FBoxen by using the PCS. Only this text us used!
Description | Description. It´s NOT generated as in all other FBoxen by using the PCS. Only this text us used!
Notification Class | NotificationClass. FBoxes can access via this number all preset values and "inherit" this parameter
Priority | Priority of NotificationClass
Ack Required | Selection which messages of this NotificationClass must be acknowledge
Profile Name | Profile Name of NotoficationClass
Unsolicited COV Enabled | Defines when a message should be sent. Default = false (recomended)
Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Preset Intrinsic Reporting --- ] |
Event Enable | Preset Property Event Enable
Notify Type | Preset Property Notification Type
Profile Name | Preset Property ProfileName
Unsolicited COV Enabled | Preset Property Unsolicited COV Enable
<--- Event Message Text ---> |
To Off-Normal | Preset Property Event Message Text To Off-Normal
To Fault | Preset Property Event Message Text To Fault
To Normal | Preset Property Event Message Text To Normal
[ --- DDC Suite V 2.5 --- ] |

Functional

A Notification Class must be defined before any other FBox links an object with Intrinsic Alarming to this Notification Class.

The behaviour of the Notification Class is defined in the "System functions" group. These parameters belong directly to the NC.

In the "Preset Intrinsic Reporting" group, an alarm configuration is predefined for all objects that should appear as connected to this NC, i.e. all alarms in any one NC have the same behaviour and the same texts.

The "Notification Class" FBox can be used several times; however the Notification Class (numbers) must be different.

FBoxes that provide objects for Intrinsic Reporting have a parameter "- Notification-Class". If this is specified with "-1", the FBox will not generate any Intrinsic Reporting. With a value = 0, Intrinsic Reporting is enabled and linked to the defined Notification Class.

It is therefore possible, for example, to use FBox "Ala 5" to collect messages from an external device, while providing only 2 of them with Intrinsic Reporting, even if all 5 messages are to be generated as BACnet objects. In this example, the 3 objects without Intrinsic Reporting are then just messages like Run, Ready or Standby.

Predefined


Loop V250

Family: | DDC 2.5 BACnet
Name: | Loop V250
Macro: | _DDC_BACLOOP250
Version: | 2.5.000

Description

This FBox is used to set up a Loop object. However, it does not work autonomously, but instead must always be used together with a controller FBox.

If the BACnet Option in the controller FBox is selected as "Y/Setpoint/Param" the Loop object will not be generated, since resources for PID parameters are already provided in autonomous objects!

Adjust
[ --- System functions --- ]
Description
BACnet
<--- BACnet Object-Name --->
- Description
- Optional text
[ --- References --- ]
Controller
Controlled Variable
- Object
- Property
Setpoint
- Object
- Property
Manipulated Variable
- Object
- Property
[ --- Definitions --- ]
COV Hysteresis
[ --- DDC Suite V 2.5 --- ]

Functional

A Loop object is the interface of setpoint, actual value, control parameters and the control signal. This FBox brings all the data together in a way that conforms to BACnet.

Individual objects are made available together through functional FBoxes, generally comprising a measurement FBox, a setpoint FBox and a controller FBox. Since the Loop FBox has to access several FBoxes, while only one reference can be indicated, the reference is set together. As a rule, all FBoxes have a common prefix: in this example all names start with "AHU01_":

This common part is then indicated as the reference in the Loop FBox. The name property of the Loop FBox is freely selectable (e.g. "Cooler"), but must be unique in the program.

For each of the 3 FBoxes, the completion of the FBox name must now be specified. This is done in the properties. There you can specify up to 4 FBoxes:

- Controller = FBox with the control parameters

- Controlled Variable = FBox that provides an AI/AV for the actual value

- Setpoint = FBox that provides the setpoint (may also be the controller FBox if the option "Y/Sollwert" ("Y/Setpoint") has been selected there)

- Manipulated Variable = FBox that provides an AV or AO object in which the control signal is to be output

All 4 information fields must be filled in. It is perfectly possible that this will mean, for example, indicating the controller at "Controller", "Setpoint" and "Manipulated Variable". Fill in the fields with the remaining characters of the FBox name: in this example, adding "Temp", "PID" and "Setpt" after "AHU01_":

During a compile, the FBox checks whether all objects have been found and may output an error message if any object cannot be resolved.

Predefined


Trendlog

Family: | DDC 2.5 BACnet
Name: | Trendlog
Macro: | _DDC_BACTL250
Version: | 2.5.000

Description

Adjusting Trendlog options for BACnet.

Adjust |
[--- Trendlog ---] |
Use | No = no Trendlog Objekts will be generated. As soon a FileSystem is selected all parametrized Trendlog Objekts will be generated and store their data on file system.
Path | Folder where the Trendlogs should be stored. Format /Ordner
Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
notification-threshold | Treshold value records. Contains one of all Trendlog more records an event will be sent via the specified NotificationClass.
[ --- DDC Suite V 2.5 --- ] |

Functional

Some FBoxes are capable of recording history data. If BACnet is used, these history values can be stored in Trendlog objects.

The basic settings for the file storage of Trendlog objects are defined in this FBox. If option "No" is selected in the parameter "Use", the Trendlog option will be disabled in all FBoxes, even if Trendlog has been set there as "Ringbuffer" or "Fill&Stop". This is helpful if, for example, the BACnet Stack has to be commissioned while the memory module is still missing.

However, if memory has been selected for data storage, it is absolutely necessary that this memory should also be available! This cannot be checked during the compiling process. If the memory is not available (M1/2 or slot 0..3) the PCD will go into HALT at the first attempt to save a file!

Predefined


Loop

Family: | DDC 2.5 BACnet
Name: | Loop
Macro: | _DDC_BACLOOP251
Version: | 2.5.002

Description

This FBox is used to set up a Loop object. However, it does not work autonomously, but instead must always be used together with a controller FBox.

If the BACnet Option in the controller FBox is selected as "Y/Setpoint/Param" the Loop object will not be generated, since resources for PID parameters are already provided in autonomous objects!

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
BACnet | Select if and what kind of BACnet objects should be generated automatically
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- References --- ] |
Controller | Suffix of FBox-Name from Controller-FBox providing the PID parameter
Controlled Variable | Suffix of FBox-Name from FBox providing the actial value
- Object | Object type of referenced object actial value
- Property | Property of referenced object actial value
Setpoint | Suffix of FBox-Name from FBox providing the set point
- Object | Object type of referenced object set point
- Property | Property of referenced object set point
Manipulated Variable | Suffix of FBox-Name from FBox providing the manipulated value
- Object | Object type of referenced object manipulated value
- Property | Property referenced object manipulated value
[ --- Definitions --- ] |
COV Hysteresis | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
Time-delay | Delay until an event is sent via NotificationClass
Error-limit | Treshold value for event
Dead-band | Dead band, applies for upper/lower threshold when switching back to normal state.
[ --- DDC Suite V 2.5 --- ] |

Functional

A Loop object is the interface of setpoint, actual value, control parameters and the control signal. This FBox brings all the data together in a way that conforms to BACnet.

Individual objects are made available together through functional FBoxes, generally comprising a measurement FBox, a setpoint FBox and a controller FBox. Since the Loop FBox has to access several FBoxes, while only one reference can be indicated, the reference is set together. As a rule, all FBoxes have a common prefix: in this example all names start with "AHU01_":

This common part is then indicated as the reference in the Loop FBox. The name property of the Loop FBox is freely selectable (e.g. "Cooler"), but must be unique in the program.

For each of the 3 FBoxes, the completion of the FBox name must now be specified. This is done in the properties. There you can specify up to 4 FBoxes:

- Controller = FBox with the control parameters

- Controlled Variable = FBox that provides an AI/AV for the actual value

- Setpoint = FBox that provides the setpoint (may also be the controller FBox if the option "Y/Sollwert" ("Y/Setpoint") has been selected there)

- Manipulated Variable = FBox that provides an AV or AO object in which the control signal is to be output

All 4 information fields must be filled in. It is perfectly possible that this will mean, for example, indicating the controller at "Controller", "Setpoint" and "Manipulated Variable". Fill in the fields with the remaining characters of the FBox name: in this example, adding "Temp", "PID" and "Setpt" after "AHU01_":

During a compile, the FBox checks whether all objects have been found and may output an error message if any object cannot be resolved.

Predefined


Device

Family: | DDC 2.5 BACnet
Name: | Device
Macro: | _DDC_BACDEV251
Version: | 2.5.001

Description

This FBox is required when DDC Suite FBoxes have to generate BACnet objects automatically and also behave accordingly. It must be placed before all other functional DDC Suite FBoxes that have been configured for "BACnet" (even before the Init FBox).

Activating BACnet objects

BACnet objects to be created can be selected in the FBoxes with the BACnet parameter:

This is current standard procedure. Note however that all --- BACnet Object-Name --- parameters are also provided with a text/building code.

In practice, situations frequently occur where BACnet objects may be generated, even though they are not needed, e.g. in FBox Control/Continuous. It is quite common to have manual override, but no real position feedback. To obtain manual intervention as a BACnet object, selection must be made in such a way that a BACnet object is also generated for position feedback. As a result, unnecessary BACnet objects are generated.

To resolve this problem, the parameters --- BACnet Object-Name --- are checked. If nothing has been entered (blank text field) generation of this BACnet object can be suppressed. The following rules should be observed:

1. Setup parameter BACnet

From the selection list, the option listing required BACnet objects must at least be selected. For simplicity, it is possible in each case to select the maximum option.

2. Selecting BACnet objects to generate

All FBoxes that generate at least 2 BACnet objects can now be configured so that only the desired BACnet objects will be generated. For these objects the parameter --- BACnet Object-Name --- should be filled. Objects that are not to be generated must be left blank.

3. Related objects

Some BACnet objects are referenced to other objects, e.g. for a measured value the trend log object is referenced to the analog input object. The referenced object must be generated (indication of BACnet Object Name). It is not enough only to parameterize the trend log object. Direct dependencies within an FBox check for this and also automatically suppress the referencing object if the object to be referenced is not generated. In FBoxes with external linkages (e.g. Loop) it is, of course, necessary to ensure that all required objects are generated.

4. Mandatory objects

Some FBoxes have a mandatory object that is always created and cannot be suppressed by leaving bland the parameter --- BACnet Object-Name ---. This applies to the following FBoxes:

- Enable family: all switches (HMI parameter = resulting enable at FBox output)

- Regulation family: regulation signal (Signal parameter = resulting regulation signal at FBox output)

- Controller family: all switches (HMI parameter = resulting control signal at FBox output)

Mandatory objects are identified by an additional "!" in the --- BACnet Object-Name ! --- parameter.

5. FBoxes with only one BACnet object

The BACnet object is always created as soon as there is a BACnet = Yes setting. It is not possible to suppress the BACnet object by leaving blank the parameter --- BACnet Object-Name ---.

Output |
Err | Indicates that the BACnet stack is not working properly, SW falls back to "Standard" mode.

Adjust |
[ --- System functions --- ] |
Activate BACnet | Pre selection wheather BACnet is active or not. If activated the BACnet stack must be used - otherwise program won't work properly.
[--- Device ---] |
ID | BACnet Device ID
Name | Device Name of BACnet Controller
Description | Desription
[--- General ---] |
Text No. 1 | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Text No. 2 | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Text No. 3 | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Text No. 4 | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Text No. 5 | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[--- Überwachung ---] |
Start delay | Startdelay monitoring BACnet Stack after restart PCD
Max. delay feedback | Maximum delay feedback of BACnet Stack
[ --- DDC Suite V 2.5 --- ] |

Functional

The "Device ID" is assigned by the BACnet Network Administrator. This ID may only exist once in any single BACnet network.

With the parameter "BACnet aktivieren" ("Enable BACnet") it is possible to control whether the program generated as a result of a build will work with BACnet or in the conventional way, without BACnet.

"No" means that no BACnet objects will be generated and the program will work without a BACnet stack.

"Yes" means that configured BACnet objects will be generated and the BACnet stack will be required for the program to function. "Yes" does not automatically enable all BACnet objects in subsequent FBoxes: in each FBox it is then possible to define individually which BACnet objects should be generated. An appropriate BACnet configuration must also be loaded into the PCD, as otherwise the FBoxes cannot work correctly.

The FBox independently generates just the "Device Object" in the configuration file "DDC_BACnet.bnt". This file is a complete BACnet configuration file that can be opened with the BACnet configurator. It does not make any sense to change anything in this file, as it is completely rebuilt every time there is a "Build".

Before using any BACnet configuration, a plant identification system (AKS) must be set up for the BACnet Object Name and Property Description. Read more about this in FBoxes "AKS Festlegen" (Define AKS) and "AKS anpassen" (Adapt AKS) in the "Initialization" family.

Texts in the "General" group are provisional and currently not in use in the BACnet configuration.

The FBox is monitoring the BACnet Stack, means a BI is toggled on PCDInRef and PresentValue must follow within max. delay time. If time has elapsed and PresentValue is not identically to PCDInRef Value the FBox sets output "Err" to high and all FBoxes parameterized for BACnet will copy automatically their own PCDInRef to PresentValue. Features like OutOfService are disabled.

Predefined


DDC 2.5 Alarming

Version: 2.5.000

Control voltages

1 Alarm

1 Alarm/Message

5 Alarms

Delayed Alarm

Set point monitoring

Motor 1 speed

Motor 2 speed

Motor 3 speed

Frost air heater

Fire damper

Acknowledge

Forwarding alarm


Control voltages

Family: | DDC 2.5 Alarming
Name: | Control voltages
Macro: | _DDC_ALFUSE250
Version: | 2.5.000

Description

Serves mainly to create error signal pages, where in the separate signals it is still unclear at the beginning whether these should for instance be included in a turning off chain.

In this way, for instance, an error signal can be removed from an order chain if it turns out that this error should not be included.

Input |
230 | Input fuse monitoring 230 VAC
24~ | Input fuse monitoring 24 VAC
24= | Input fuse monitoring 24 VAC
Ph | Input phase watch
vltg. | Input general control voltage monitoring

Output |
GrpAla | Collective alarm for any fuse failure
StartUp | Display that the start delay is active
[230] | Raw inpute state fuse 230 VAC
[24~] | Raw inpute state fuse 24 VAC
[24=] | Raw inpute state fuse 24 VDC
[Ph] | Raw inpute state phase watch
[Spg] | Raw inpute state general control voltage

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Alarm administration (Index) | Controls whether the alarms in an SWeb alarm list are registered. 0 = No, -1 = Alarm number assigned automatically, >0 = fixed (start) alarm number. (FBox Alarm SWeb/AlarmHdr)
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Parameter --- ] |
Start up delay (s) | Delay until normal status is displayed
[ --- 230 VAC --- ] |
Digital input | Digital input addess
Normal input state | Selection of the normal status of the input
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Alarm status | Status of the alarm
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- 24 VAC --- ] |
Digital input | Digital input addess
Normal input state | Selection of the normal status of the input
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Alarm status | Status of the alarm
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- 24 VDC --- ] |
Digital input | Digital input addess
Normal input state | Selection of the normal status of the input
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Alarm status | Status of the alarm
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Phase watch --- ] |
Digital input | Digital input addess
Normal input state | Selection of the normal status of the input
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Alarm status | Status of the alarm
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Alarm 230 VAC/24 VAC/24 VDC | Selection whether the alarm 230VC/24VAC/24VDC should be triggered internally in parallel
[ --- Control voltage --- ] |
Digital input | Digital input addess
Normal input state | Selection of the normal status of the input
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Alarm status | Status of the alarm
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Alarm 230 VAC/24 VAC/24 VDC | Selection whether the alarm 230VC/24VAC/24VDC should be triggered internally in parallel
[ --- DDC Suite V 2.5 --- ] |

Functional

Up to 5 safety monitoring systems can be connected to this FBox. The normal status open/closed as well as the acknowledgement requirement can be set for each monitoring

This FBox internally provides the error signals. Other FBoxes (predominantly the family "Alarming") can undertake a signal rejection about this information, if a certain safety fuse has blown. Thereby ghost signals are prevented. The FBoxes that support this function are linked to this FBox via the reference "ref".

If, for instance, separate safety fuse monitorings are available per system (ventilation 1, ventilation 2), this FBox can be set several times and clearly designated with the name.

For the signals phase monitoring and control voltage, it can be additionally set whether the signals 230 VAC, 24 VAC and 24 VDC are also internally alerted.

Input contacts

The input contacts to be monitored can be connected to the inputs of the FBox or alternatively in the FBox itself. In the process, the address "-1" indicates that the FBox should use the input contact of FBox input.

As soon as an address is stated between 0 and 1023 (= physical input address), the FBox input is inactive and can be arbitrarily connected with "L" ort "H". The FBox independently reads out the parameterised input and monitors it.

As the input would not be visible at starting up, the outputs of the FBox reflects the corresponding input status in square brackets "[]", regardless of whether it is from the FBox input or from the physical input directly read out FBox. However, this is always the physical status of the input. An optional inversion is not executed here.

System function alarm management

The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.

Index | 230 VAC fuse blown
Index 1 | 24 VAC fuse blown
Index 2 | 24 VDC fuse blown
Index 3 | Phase monitor activated
Index 4 | General control current circuit blown

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Description
230AC | BI | Error signal 230 VAC fuse blown
230AC/24AC | BI | Error signal 24 VAC fuse blown
230AC/24AC/24DC | BI | Error signal 24 VDC fuse blown
All | BI | Error signal phase monitor activated
All | BI | Error signal general control current circuit blown

Predefined

Start up delay (s) | Delay | R | 0..6000
Digital input | DI230AC | R | -1..1023
Normal input state | AC230NoNc | F | 0 = opened
 |  |  | 1 = Closed
Acknowledgement mandatory | AC230MbAck | F | 0 = No
 |  |  | 1 = Yes
Alarm status | AlaAC230 | F | 0 = ok
 |  |  | 1 = ALARM
Digital input | DI24AC | R | -1..1023
Normal input state | AC24NoNc | F | 0 = opened
 |  |  | 1 = Closed
Acknowledgement mandatory | AC24MbAck | F | 0 = No
 |  |  | 1 = Yes
Alarm status | AlaAC24 | F | 0 = ok
 |  |  | 1 = ALARM
Digital input | DI24DC | R | -1..1023
Normal input state | DC24NoNc | F | 0 = opened
 |  |  | 1 = Closed
Acknowledgement mandatory | DC24MbAck | F | 0 = No
 |  |  | 1 = Yes
Alarm status | AlaDC24 | F | 0 = ok
 |  |  | 1 = ALARM
Digital input | DIPhase | R | -1..1023
Normal input state | PhaseNoNc | F | 0 = opened
 |  |  | 1 = Closed
Acknowledgement mandatory | PhaseMbAck | F | 0 = No
 |  |  | 1 = Yes
Alarm status | AlaPhase | F | 0 = ok
 |  |  | 1 = ALARM
Alarm 230 VAC/24 VAC/24 VDC | PhaseOvr | F | 0 = No
 |  |  | 1 = Yes
Digital input | DIVoltage | R | -1..1023
Normal input state | VoltageNoNc | F | 0 = opened
 |  |  | 1 = Closed
Acknowledgement mandatory | VoltageMbAck | F | 0 = No
 |  |  | 1 = Yes
Alarm status | AlaVoltage | F | 0 = ok
 |  |  | 1 = ALARM
Alarm 230 VAC/24 VAC/24 VDC | VoltageOvr | F | 0 = No
 |  |  | 1 = Yes


1 Alarm

Family: | DDC 2.5 Alarming
Name: | 1 Alarm
Macro: | _DDC_AL1ALA250
Version: | 2.5.000

Description

Logging of a signal with inversion and optional requirement of acknowledgement

Input |
Inp | Input to be monitored

Output |
Alarm | Alarm state
[Inp] | Raw input status

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Alarm administration (Index) | Controls whether the alarms in an SWeb alarm list are registered. 0 = No, -1 = Alarm number assigned automatically, >0 = fixed (start) alarm number. (FBox Alarm SWeb/AlarmHdr)
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Alarm parameter --- ] |
Digital input | Digital input address
Normal input state | Selection of the normal status of the input
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Alarm suppression | Associated voltage group for suppressing ghost alarm on voltage shortage
Alarm status | Status of the alarm
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- DDC Suite V 2.5 --- ] |

Functional

The message connected at input In is processed as error signal. The normal status (NO and/or NC) of the signal can be set online. If required, the error signal can be firmly set (with requirement of acknowledgement) and in that case must be reset by a central acknowledgement (see FBox "InitLib").

To prevent ghost signals in case of a fuse failure, a rejection of signal takes place depending on the associated voltage monitoring (see FBox "Control voltages").

Input contacts

The input contacts to be monitored can be connected to the inputs of the FBox or alternatively in the FBox itself. In the process, the address "-1" indicates that the FBox should use the input contact of FBox input.

As soon as an address is stated between 0 and 1023 (= physical input address), the FBox input is inactive and can be arbitrarily connected with "L" ort "H". The FBox independently reads out the parameterised input and monitors it.

As the input would not be visible at starting up, the outputs of the FBox reflects the corresponding input status in square brackets "[]", regardless of whether it is from the FBox input or from the physical input directly read out FBox. However, this is always the physical status of the input. An optional inversion is not executed here.

System function alarm management

The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.

Index Alarm status

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Description
Yes | BI | Signal status

Predefined

Digital input | DITerm | R | -1..1023
Normal input state | NoNc | F | 0 = opened
 |  |  | 1 = Closed
Acknowledgement mandatory | MbAck | F | 0 = No
 |  |  | 1 = Yes
Alarm suppression | VoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Alarm status | Ala | F | 0 = ok
 |  |  | 1 = ALARM


1 Alarm/Message

Family: | DDC 2.5 Alarming
Name: | 1 Alarm/Message
Macro: | _DDC_AL1MSG250
Version: | 2.5.000

Description

Logging of a signal with inversion, optional requirement for acknowledgement, delay and selective processing as error or signal

Input |
Inp | Input to be monitored

Output |
Alarm | Alarm e.g. for an alarm chain
Message | Message e.g. for a pure signalling
[Inp] | Raw input state

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Alarm administration (Index) | Controls whether the alarms in an SWeb alarm list are registered. 0 = No, -1 = Alarm number assigned automatically, >0 = fixed (start) alarm number. (FBox Alarm SWeb/AlarmHdr)
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Alarm parameter --- ] |
Digital input | Digital input address
Normal input state | Selection of the normal status of the conector
Acknowledgement mandatory | Selection whether the Alarm follows the conector or remains stored and must be acknowledged
Alarm suppression | Associated voltage group for suppressing ghost messages on voltage shortage
Output selection | Selection which output should be activated. Internal Alarm/Message is always identified.
On-delay | Duration of the on-delay
Decay delay | Duration of the decay delay
Alarm/Message status | Status of the Alarm/Message
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- DDC Suite V 2.5 --- ] |

Functional

The message connected at input "In" is processed. The normal status (NO and/or NC) of the signal can be set online. If required, the error signal can be firmly set (with requirement of acknowledgement) and in that case must be reset by a central acknowledgement (see FBox "InitLib"). Moreover, an on-delay and dropout delay can be set.

To prevent ghost signals in case of a fuse failure, a rejection of signal takes place depending on the associated voltage monitoring (see FBox "Control voltages").

The FBox has two outputs, "Alarm" and "Message". By a preselection, it can be determined whether the generated signal should be transmitted to:

- No output

- Output "Alarm"

- Output "Message"

- Both outputs

. For this reason, for instance, a fire damper from a turning-off error chain can be re-parameterised to the non-turning-off signal chain.

Input contacts

The input contacts to be monitored can be connected to the inputs of the FBox or alternatively in the FBox itself. In the process, the address "-1" indicates that the FBox should use the input contact of FBox input.

As soon as an address is stated between 0 and 1023 (= physical input address), the FBox input is inactive and can be arbitrarily connected with "L" ort "H". The FBox independently reads out the parameterised input and monitors it.

As the input would not be visible at starting up, the outputs of the FBox reflects the corresponding input status in square brackets "[]", regardless of whether it is from the FBox input or from the physical input directly read out FBox. However, this is always the physical status of the input. An optional inversion is not executed here.

System function alarm management

The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.

Index Alarm status

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Description
Yes | BI | Input contact not in normal status (regardless whether parameterised as "Alarm" or "Message")

Predefined

Digital input | DITerm | R | -1..1023
Normal input state | NoNc | F | 0 = opened
 |  |  | 1 = Closed
Acknowledgement mandatory | MbAck | F | 0 = No
 |  |  | 1 = Yes
Alarm suppression | VoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Output selection | Function | R | 1 = none
 |  |  | 2 = Message
 |  |  | 3 = Alarm
 |  |  | 4 = Message Alarm
On-delay | OnDelay | R | 0..36000
Decay delay | OffDelay | R | 0..36000
Alarm/Message status | Ala | F | 0 = ok
 |  |  | 1 = ALARM


5 Alarms

Family: | DDC 2.5 Alarming
Name: | 5 Alarms
Macro: | _DDC_AL5ALA250
Version: | 2.5.000

Description

Logging of 1 to 5 signals with inversion and requirement of acknowledgement.

Input |
Inp | Input to be monitored

Output |
GrpAla | Collective alarm for any active alarm
Alarm | Status of the alarm
[Inp] | Status of the digital inputs

Adjust |
[ --- System functions --- ] |
Description |
PCD Alarm administration (Index) | Activates alarm management if value greater 0
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Message 1 --- ] |
Digital input | Digital input
Normal input state | Selection of the normal status of the input
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Alarm suppression | Associated voltage group for suppressing ghost alarm on voltage shortage
Alarm status | Status of the alarm
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Message 2 --- ] |
Digital input | Digital input
Normal input state | Selection of the normal status of the input
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Alarm suppression | Associated voltage group for suppressing ghost alarm on voltage shortage
Alarm status | Status of the alarm
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Message 3 --- ] |
Digital input | Digital input
Normal input state | Selection of the normal status of the input
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Alarm suppression | Associated voltage group for suppressing ghost alarm on voltage shortage
Alarm status | Status of the alarm
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Message 4 --- ] |
Digital input | Digital input
Normal input state | Selection of the normal status of the input
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Alarm suppression | Associated voltage group for suppressing ghost alarm on voltage shortage
Alarm status | Status of the alarm
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Message 5 --- ] |
Digital input | Digital input
Normal input state | Selection of the normal status of the input
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Alarm suppression | Associated voltage group for suppressing ghost alarm on voltage shortage
Alarm status | Status of the alarm
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- DDC Suite V 2.5 --- ] |

Functional

The messages connected at input In is processed as error signals. The normal status (NO and/or NC) of the signals can be set online. If required, the error signals can be firmly set (with requirement of acknowledgement) and in that case must be reset by a central acknowledgement (see FBox "InitLib").

To prevent ghost signals in case of a fuse failure, a rejection of signal takes place depending on the associated voltage monitoring (see FBox "Control voltages").

Input contacts

The input contacts to be monitored can be connected to the inputs of the FBox or alternatively in the FBox itself. In the process, the address "-1" indicates that the FBox should use the input contact of FBox input.

As soon as an address is stated between 0 and 1023 (= physical input address), the FBox input is inactive and can be arbitrarily connected with "L" ort "H". The FBox independently reads out the parameterised input and monitors it.

As the input would not be visible at starting up, the outputs of the FBox reflects the corresponding input status in square brackets "[]", regardless of whether it is from the FBox input or from the physical input directly read out FBox. However, this is always the physical status of the input. An optional inversion is not executed here.

System function alarm management

The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.

Index | Alarm status input "In0"
Index 1 | Alarm status input "In1"
Index 2 | Alarm status input "In2"
Index 3 | Alarm status input "In3"
Index 4 | Alarm status input "In4"

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Description
Yes | BI | Alarm status input "In0"
Yes | BI | Alarm status input "In1"
Yes | BI | Alarm status input "In2"
Yes | BI | Alarm status input "In3"
Yes | BI | Alarm status input "In4"

Predefined

Digital input | Msg1DITerm | R | -1..1023
Normal input state | Msg1NoNc | F | 0 = opened
 |  |  | 1 = Closed
Acknowledgement mandatory | Msg1MbAck | F | 0 = No
 |  |  | 1 = Yes
Alarm suppression | Msg1VoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Alarm status | Msg1Ala | F | 0 = ok
 |  |  | 1 = ALARM
Digital input | Msg2DITerm | R | -1..1023
Normal input state | Msg2NoNc | F | 0 = opened
 |  |  | 1 = Closed
Acknowledgement mandatory | Msg2MbAck | F | 0 = No
 |  |  | 1 = Yes
Alarm suppression | Msg2VoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Alarm status | Msg2Ala | F | 0 = ok
 |  |  | 1 = ALARM
Digital input | Msg3DITerm | R | -1..1023
Normal input state | Msg3NoNc | F | 0 = opened
 |  |  | 1 = Closed
Acknowledgement mandatory | Msg3MbAck | F | 0 = No
 |  |  | 1 = Yes
Alarm suppression | Msg3VoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Alarm status | Msg3Ala | F | 0 = ok
 |  |  | 1 = ALARM
Digital input | Msg4DITerm | R | -1..1023
Normal input state | Msg4NoNc | F | 0 = opened
 |  |  | 1 = Closed
Acknowledgement mandatory | Msg4MbAck | F | 0 = No
 |  |  | 1 = Yes
Alarm suppression | Msg4VoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Alarm status | Msg4Ala | F | 0 = ok
 |  |  | 1 = ALARM
Digital input | Msg5DITerm | R | -1..1023
Normal input state | Msg5NoNc | F | 0 = opened
 |  |  | 1 = Closed
Acknowledgement mandatory | Msg5MbAck | F | 0 = No
 |  |  | 1 = Yes
Alarm suppression | Msg5VoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Alarm status | Msg5Ala | F | 0 = ok
 |  |  | 1 = ALARM


Delayed Alarm

Family: | DDC 2.5 Alarming
Name: | Delayed Alarm
Macro: | _DDC_ALDELAY250
Version: | 2.5.000

Description

Logging of a signal with inversion and requirement of acknowledgement, on-delay and dropout delay according to demand.

Input |
En | Approval for monitoring the input
Inp | Input to be monitored

Output |
Alarm | Status of the alarm
[Inp] | Rwa imput state

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Alarm administration (Index) | Controls whether the alarms in an SWeb alarm list are registered. 0 = No, -1 = Alarm number assigned automatically, >0 = fixed (start) alarm number. (FBox Alarm SWeb/AlarmHdr)
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Fault message --- ] |
Digital input | Digital input address
Normal input state | Selection of the normal status of the input
Delay for | Selection whether attack or decay delayed
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Alarm suppression | Associated voltage group for suppressing ghost alarm on voltage shortage
Delay in sec. | Delay until triggering the alarm
Alarm status | Status of the alarm
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Delay --- ] |
Pull-in/Decay delay | Delay
[ --- DDC Suite V 2.5 --- ] |

Functional

The message connected at input In is processed as error signal. The normal status (NO and/or NC) of the signal can be set online. If required, the error signal can be firmly set (with requirement of acknowledgement) and in that case must be reset by a central acknowledgement (see FBox "InitLib").

If the requirement of acknowledgement function is parameterised with "No", the error is automatically reset if the input "En" is reset. This is helpful for the filter monitoring as it prevents the error signal "Filter dirty" from appearing several times a day.

To prevent ghost signals in case of a fuse failure, a rejection of signal takes place depending on the associated voltage monitoring (see FBox "Control voltages").

Input contacts

The input contacts to be monitored can be connected to the inputs of the FBox or alternatively in the FBox itself. In the process, the address "-1" indicates that the FBox should use the input contact of FBox input.

As soon as an address is stated between 0 and 1023 (= physical input address), the FBox input is inactive and can be arbitrarily connected with "L" ort "H". The FBox independently reads out the parameterised input and monitors it.

As the input would not be visible at starting up, the outputs of the FBox reflects the corresponding input status in square brackets "[]", regardless of whether it is from the FBox input or from the physical input directly read out FBox. However, this is always the physical status of the input. An optional inversion is not executed here.

System function alarm management

The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.

Index Alarm status

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Description
Yes | BI | Alarm status

Predefined

Digital input | DITerm | R | -1..1023
Normal input state | NoNc | F | 0 = Closed
 |  |  | 1 = opened
Delay for | DelayType | F | 0 = Pull -in
 |  |  | 1 = Decay
Acknowledgement mandatory | MbAck | F | 0 = No
 |  |  | 1 = Yes
Alarm suppression | VoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Delay in sec. | Delay | R | 0..36000
Alarm status | Ala | F | 0 = ok
 |  |  | 1 = ALARM
Alarm status | Ala | F | 0 = ok
 |  |  | 1 = ALARM


Set point monitoring

Family: | DDC 2.5 Alarming
Name: | Set point monitoring
Macro: | _DDC_ALHYST250
Version: | 2.5.000

Description

Monitoring of a value for a tolerance band.

Input |
En | Approval of the set point monitoring
SetPt | Set point
Sensor | Actual value

Output |
GrpAla | Collective alarm on crossing upwards or downwards
TolHigh | Alarm tolerance range crossed
TolLow | Alarm tolerance range fallen short of

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Alarm administration (Index) | Controls whether the alarms in an SWeb alarm list are registered. 0 = No, -1 = Alarm number assigned automatically, >0 = fixed (start) alarm number. (FBox Alarm SWeb/AlarmHdr)
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Fault message --- ] |
Set point | Set point of the monitoring
... Value specification done | Selection of the specified Set point
Start delay in seconds | Start delay in seconds after approval of limit monitoring
Delay per 1 Sv-change. | Delay per unit for large Set point change
Set point change hysteresis | Hysterese for triggering a new start delay for large Set point change
Tolerance violation | Alarm tolerance high or low
[ --- Tolerance high --- ] |
Hysteresis | Hysteresis tolerance high
Delay in seconds | Delay tolerance low
Alarm status | Alarm tolerance high
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Tolerance low --- ] |
Hysteresis | Hysteresis tolerance low
Delay in seconds | Delay tolerance low
Alarm status | Alarm tolerance low
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Delays --- ] |
Start delay | Start delay
Delay | Delay
[ --- DDC Suite V 2.5 --- ] |

Functional

Monitoring of an actual value. The set point is variable. Separate hystereses and delay periods are used for the exceedance and shortfall.

After enabling, input "En", of the function, the start delay takes place. After it's finished, the actual value is monitored for the limit values "SetPt" hysteresis exceedance and "SetPt" - hysteresis shortfall.

If the respective actual value lies constantly below or above the calculated limit values, the corresponding signal is generated. If the actual value goes again over the tolerance range, the signals are automatically reset again.

In order to prevent the deliberate issue of a limit value violation in case of set point leaps (e.g. in heater loops day/night switching), a set point change hysteresis can be set. If the set point abruptly changes to more than this value (positive or negative), an automatic re-start delay is calculated. This is calculated from the actual set point change and the delay per 1 set point change. Example:

Old set point°C

New set point°C

Delay per 1 set point change.0 seconds

Re-start delay = (55°C-45°C) * 300.0 seconds = 3000.0 seconds = 50 minutes

System function alarm management

The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.

Index | Exceeded tolerance band
Index 1 | Fallen short of tolerance band

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Description
Yes | BI | Exceeded tolerance band
Yes | BI | Fallen short of tolerance band

Predefined

Set point | SetPt | R |
... Value specification done | SetPtType | F | 0 = Internal
 |  |  | 1 = FBox input
Start delay in seconds | StartDelay | R |
Delay per 1 Sv-change. | DelPerUnit | R |
Set point change hysteresis | ChangeHyst | R |
Tolerance violation | GrpAla | F | 0 = No
 |  |  | 1 = ALARM
Hysteresis | HighHyst | R |
Delay in seconds | HighDelay | R |
Alarm status | AlaHigh | F | 0 = ok
 |  |  | 1 = ALARM
Hysteresis | LowHyst | R |
Delay in seconds | LowDelay | R |
Alarm status | AlaLow | F | 0 = ok
 |  |  | 1 = ALARM
Alarm status | AlaLow | F | 0 = ok
 |  |  | 1 = ALARM
Alarm status | AlaLow | F | 0 = ok
 |  |  | 1 = ALARM


Motor 1 speed

Family: | DDC 2.5 Alarming
Name: | Motor 1 speed
Macro: | _DDC_ALMOT1SP250
Version: | 2.5.000

Description

Logging of the most prevalent motor failures, like operating feedback, rotary speed monitoring, motor protection, service switch and manual control.

Input |
Run | Message that the motor was activated and should run
fb | Input of the operation feedback
mp | Input of the motor protection
ss | Input of the service switch
pfb | Input of the process feedback
man | Input of a manual switch for override

Output |
[fb!] | Input status operation feedback
[mp] | Raw input status motor protection
[ss] | Raw input status service switch
[pfb] | Raw input status process feedback
[man] | Raw input status manual override switch
GrpAla | Collective message for any active alarm

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Alarm administration (Index) | Controls whether the alarms in an SWeb alarm list are registered. 0 = No, -1 = Alarm number assigned automatically, >0 = fixed (start) alarm number. (FBox Alarm SWeb/AlarmHdr)
BACnet | Select if and what kind of BACnet objects should be generated automatically
Group alarm from fb/mp/pfb | Selection of the group alarm
[ --- Feedback --- ] |
Digital input | Digital Input feedback
Delay | Maximum delay until feedback is present
Alarm status | Alarm feedback missing
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Process feedback --- ] |
Digital input | Digital Input process feedback
Normal input state | Selection of the normal status of the input
Delay (Sec) | Maximum delay until process feedback is present
Alarm status | Alarm process feedback missing
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Motor protection --- ] |
Digital input | Digital Input motor protection
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Normal input state | Selection of the normal status of the input
Alarm suppression | Associated voltage group for suppressing ghost alarm on voltage shortage
Alarm status | Alarm motor protection triggered
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Service switch --- ] |
Digital input | Digital Input service switch
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Normal input state | Selection of the normal status of the input
Alarm suppression | Associated voltage group for suppressing ghost alarm on voltage shortage
Alarm status | Alarm service switch switched off
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Manual override --- ] |
Digital input | Digital Input manual override switch
Normal input state | Selection of the normal status of the input
Alarm suppression | Associated voltage group for suppressing ghost alarm on voltage shortage
Alarm status | Alarm manual override active
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Delay --- ] |
Mode/Speed | Delay
[ --- DDC Suite V 2.5 --- ] |

Functional

Operating feedback absent

If there is a high signal at input "Run", the motor should be activated. If the operating feedback is not available at input "fb" after the end of the delay, the signal operating feedback absent is issued. This should be reset by a central acknowledgement (see FBox "InitLib").

Process feedback absent

If there is a high signal at input "Run", the motor should be activated. If the rotary speed feedback is not available at input "pfb" after the end of the delay, the signal process signal absent is issued. This should be reset by a central acknowledgement (see FBox "InitLib").

The normal status of the issuer of the process feedback is to be set in such a way that it displays the same status as during turned-off drive!

Motor protection activated

Is monitored independent of the operating status of the motor. The normal status (NO and/or NC) of the signal can be set online. If required, the error signal can be firmly set (with requirement of acknowledgement) and in that case must be reset by a central acknowledgement (see FBox "InitLib").

To prevent ghost signals in case of a fuse failure, a rejection of signal takes place depending on the associated voltage monitoring (see FBox "Control voltages").

Service switch turned off

Is monitored independent of the operating status of the motor. The normal status (NO and/or NC) of the signal can be set online. If required, the error signal can be firmly set (with requirement of acknowledgement) and in that case must be reset by a central acknowledgement (see FBox "InitLib").

To prevent ghost signals in case of a fuse failure, a rejection of signal takes place depending on the associated voltage monitoring (see FBox "Control voltages").

Manual intervention

Is monitored independent of the operating status of the motor. The normal status (NO and/or NC) of the signal can be set online.

To prevent ghost signals in case of a fuse failure, a rejection of signal takes place depending on the associated voltage monitoring (see FBox Control voltages).

The error signal manual intervention deactivated and/or an absent operating feedback.

Collective error

The collective error at output "GrpAla" consists of 3 standard signals.

- Operating feedback absent

- Motor protection activated

- Process feedback

Alternatively, it can be still parameterised whether the signals service switch and/or manual intervention should be likewise included in the collective error signal.

Input contacts

The input contacts to be monitored can be connected to the inputs of the FBox or alternatively in the FBox itself. In the process, the address "-1" indicates that the FBox should use the input contact of the FBox input.

As soon as an address is stated between 0 and 1023 (= physical input address), the FBox input is inactive and can be arbitrarily connected with "L" ort "H". The FBox independently reads out the parameterised input and monitors it.

As the input would not be visible at starting up, the outputs of the FBox reflects the corresponding input status in square brackets "[]", regardless of whether it is from the FBox input or from the physical input directly read out from FBox. However, this is always the physical status of the input. An optional inversion is not executed here.

System function alarm management

The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.

Index | Operating feedback absent
Index 1 | Motor protection activated
Index 2 | Service switch turned off
Index 3 | Process feedback absent
Index 4 | Manual intervention

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Description
mo | BI | Operating feedback absent
mp/fb | BI | Motor protection activated
mp/fb/ss | BI | Service switch turned off
mp/fb/ss/pfb | BI | Process feedback absent
all | BI | Manual intervention

Predefined

Group alarm from fb/mp/pfb | GrpAlaType | R | 1 = Only these
 |  |  | 2 = ss
 |  |  | 3 = man
 |  |  | 4 = ss man
Digital input | FbDITerm | R | -1..1023
Delay | FbDelay | R | 0..6000
Alarm status | FbAla | F | 0 = ok
 |  |  | 1 = ALARM
Digital input | PfbDITerm | R | -1..1023
Normal input state | PfbNoNc | F | 0 = opened
 |  |  | 1 = Closed
Delay (Sec) | PfbDelay | R | 0..6000
Alarm status | PfbAla | F | 0 = ok
 |  |  | 1 = ALARM
Digital input | MotDITerm | R | -1..1023
Acknowledgement mandatory | MotMbAck | F | 0 = No
 |  |  | 1 = Yes
Normal input state | MotNoNc | F | 0 = opened
 |  |  | 1 = Closed
Alarm suppression | MotVoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Alarm status | MotAla | F | 0 = ok
 |  |  | 1 = ALARM
Digital input | SsDITerm | R | -1..1023
Acknowledgement mandatory | SsMbAck | F | 0 = No
 |  |  | 1 = Yes
Normal input state | SsNoNc | F | 0 = opened
 |  |  | 1 = Closed
Alarm suppression | SsVoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Alarm status | SsAla | F | 0 = ok
 |  |  | 1 = ALARM
Digital input | ManDITerm | R | -1..1023
Normal input state | ManNoNc | F | 0 = opened
 |  |  | 1 = Closed
Alarm suppression | ManVoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Alarm status | ManAla | F | 0 = ok
 |  |  | 1 = ALARM
Alarm status | ManAla | F | 0 = ok
 |  |  | 1 = ALARM


Motor 2 speed

Family: | DDC 2.5 Alarming
Name: | Motor 2 speed
Macro: | _DDC_ALMOT2SP250
Version: | 2.5.000

Description

Logging of the most prevalent motor failures, like operating feedback, rotary speed monitoring, motor protection, service switch and manual control.

Input |
Run | Message that the motor was activated and should run
fb1 | Input of the feedback speed 1
fb2 | Input of the feedback speed 2
mp1 | Input of the motor protection speed 1
mp2 | Input of the motor protection speed 2
ss | Input of the service switch
pfb | Input of the process feedback
man1 | Input of a manual switch for override speed 1
man2 | Input of a manual switch for override speed 2

Output |
[fb1!] | input status feedback speed 1
[fb2!] | input status feedback speed 2
[mp1] | Raw input status motor protection speed 1
[mp2] | Raw input status motor protection speed 2
[ss] | Raw input status service switch
[pfb] | Raw input status process feedback
[man1] | Raw input status manual switch speed 1
[man2] | Raw input status manual switch speed 2
GrpAla | Collective message for any active alarm

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Alarm administration (Index) | Controls whether the alarms in an SWeb alarm list are registered. 0 = No, -1 = Alarm number assigned automatically, >0 = fixed (start) alarm number. (FBox Alarm SWeb/AlarmHdr)
BACnet | Select if and what kind of BACnet objects should be generated automatically
Group alarm from fb/mp/pfb | Selection of the group alarm
[ --- Feedback --- ] |
Digital Input speed 1 | Digital Input feedback speed 1
Digital Input speed 2 | Digital Input feedback speed 2
Delay | Maximum delay until feedback is present
Alarm status | Alarm feedback missing
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Process feedback --- ] |
Digital input | Digital Input process feedback
Normal input state | Selection of the normal status of the input
Delay (Sec) | Maximum delay until process feedback is present
Alarm status | Alarm process feedback missing
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Motor protection --- ] |
Digital Input speed 1 | Digital Input motor protection speed 1
Digital Input speed 2 | Digital Input motor protection speed 2
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Normal input state | Selection of the normal status of the input
Alarm suppression | Associated voltage group for suppressing ghost alarm on voltage shortage
Alarm status | Alarm motor protection triggered
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Service switch --- ] |
Digital input | Digital Input service switch
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Normal input state | Selection of the normal status of the input
Alarm suppression | Associated voltage group for suppressing ghost alarm on voltage shortage
Alarm status | Alarm service switch switched off
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Manual override --- ] |
Digital Input speed 1 | Digital Input manual override switch speed 1
Digital Input speed 2 | Digital Input manual override switch speed 2
Normal input state | Selection of the normal status of the input
Alarm suppression | Associated voltage group for suppressing ghost alarm on voltage shortage
Alarm status | Alarm manual override active
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Delay --- ] |
Mode/Speed | Delay
[ --- DDC Suite V 2.5 --- ] |

Functional

Operating feedback absent

If there is a high signal at input "Run", the motor should be activated. If the operating feedback is not available at input "fb" after the end of the delay, the signal operating feedback absent is issued. This should be reset by a central acknowledgement (see FBox "InitLib").

Process feedback absent

If there is a high signal at input "Run", the motor should be activated. If the rotary speed feedback is not available at input "pfb" after the end of the delay, the signal process signal absent is issued. This should be reset by a central acknowledgement (see FBox "InitLib").

The normal status of the issuer of the process feedback is to be set in such a way that it displays the same status as during turned-off drive!

Motor protection activated

Is monitored independent of the operating status of the motor. The normal status (NO and/or NC) of the signal can be set online. If required, the error signal can be firmly set (with requirement of acknowledgement) and in that case must be reset by a central acknowledgement (see FBox "InitLib").

To prevent ghost signals in case of a fuse failure, a rejection of signal takes place depending on the associated voltage monitoring (see FBox "Control voltages").

Service switch turned off

Is monitored independent of the operating status of the motor. The normal status (NO and/or NC) of the signal can be set online. If required, the error signal can be firmly set (with requirement of acknowledgement) and in that case must be reset by a central acknowledgement (see FBox "InitLib").

To prevent ghost signals in case of a fuse failure, a rejection of signal takes place depending on the associated voltage monitoring (see FBox "Control voltages").

Manual intervention

Is monitored independent of the operating status of the motor. The normal status (NO and/or NC) of the signal can be set online.

To prevent ghost signals in case of a fuse failure, a rejection of signal takes place depending on the associated voltage monitoring (see FBox Control voltages).

The error signal manual intervention deactivated and/or an absent operating feedback.

Collective error

The collective error at output "GrpAla" consists of 3 standard signals.

- Operating feedback absent

- Motor protection activated

- Process feedback

Alternatively, it can be still parameterised whether the signals service switch and/or manual intervention should be likewise included in the collective error signal.

Input contacts

The input contacts to be monitored can be connected to the inputs of the FBox or alternatively in the FBox itself. In the process, the address "-1" indicates that the FBox should use the input contact of the FBox input.

As soon as an address is stated between 0 and 1023 (= physical input address), the FBox input is inactive and can be arbitrarily connected with "L" ort "H". The FBox independently reads out the parameterised input and monitors it.

As the input would not be visible at starting up, the outputs of the FBox reflects the corresponding input status in square brackets "[]", regardless of whether it is from the FBox input or from the physical input directly read out from FBox. However, this is always the physical status of the input. An optional inversion is not executed here.

System function alarm management

The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.

Index | Operating feedback absent
Index 1 | Motor protection activated
Index 2 | Service switch turned off
Index 3 | Process feedback absent
Index 4 | Manual intervention

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Description
mo | BI | Operating feedback absent
mp/fb | BI | Motor protection activated
mp/fb/ss | BI | Service switch turned off
mp/fb/ss/pfb | BI | Process feedback absent
all | BI | Manual intervention

Predefined

Group alarm from fb/mp/pfb | GrpAlaType | R | 1 = Only these
 |  |  | 2 = ss
 |  |  | 3 = man
 |  |  | 4 = ss man
Digital Input speed 1 | FbSp1DITerm | R | -1..1023
Digital Input speed 2 | FbSp2DITerm | R | -1..1023
Delay | FbDelay | R | 0..6000
Alarm status | FbAla | F | 0 = ok
 |  |  | 1 = ALARM
Digital input | PfbDITerm | R | -1..1023
Normal input state | PfbNoNc | F | 0 = opened
 |  |  | 1 = Closed
Delay (Sec) | PfbDelay | R | 0..6000
Alarm status | PfbAla | F | 0 = ok
 |  |  | 1 = ALARM
Digital Input speed 1 | MotSp1DITerm | R | -1..1023
Digital Input speed 2 | MotSp2DITerm | R | -1..1023
Acknowledgement mandatory | MotMbAck | F | 0 = No
 |  |  | 1 = Yes
Normal input state | MotNoNc | F | 0 = opened
 |  |  | 1 = Closed
Alarm suppression | MotVoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Alarm status | MotAla | F | 0 = ok
 |  |  | 1 = ALARM
Digital input | SsDITerm | R | -1..1023
Acknowledgement mandatory | SsMbAck | F | 0 = No
 |  |  | 1 = Yes
Normal input state | SsNoNc | F | 0 = opened
 |  |  | 1 = Closed
Alarm suppression | SsVoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Alarm status | SsAla | F | 0 = ok
 |  |  | 1 = ALARM
Digital Input speed 1 | ManSp1DITerm | R | -1..1023
Digital Input speed 2 | ManSp2DITerm | R | -1..1023
Normal input state | ManNoNc | F | 0 = opened
 |  |  | 1 = Closed
Alarm suppression | ManVoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Alarm status | ManAla | F | 0 = ok
 |  |  | 1 = ALARM
Alarm status | ManAla | F | 0 = ok
 |  |  | 1 = ALARM


Motor 3 speed

Family: | DDC 2.5 Alarming
Name: | Motor 3 speed
Macro: | _DDC_ALMOT3SP250
Version: | 2.5.000

Description

Logging of the most prevalent motor failures, like operating feedback, rotary speed monitoring, motor protection, service switch and manual control.

Input |
Run | Message that the motor was activated and should run
fb1 | Input of the feedback speed 1
fb2 | Input of the feedback speed 2
fb3 | Input of the feedback speed 3
mp1 | Input of the motor protection speed 1
mp2 | Input of the motor protection speed 2
mp3 | Input of the motor protection speed 3
ss | Input of the service switch
pfb | Input of the process feedback
man1 | Input of a manual switch for override speed 1
man2 | Input of a manual switch for override speed 2
man3 | Input of a manual switch for override speed 3

Output |
[fb1!] | input status feedback speed 1
[fb2!] | input status feedback speed 2
[fb3!] | input status feedback speed 3
[mp1] | Raw input status motor protection speed 1
[mp2] | Raw input status motor protection speed 2
[mp3] | Raw input status motor protection speed 3
[ss] | Raw input status service switch
[pfb] | Raw input status process feedback
[man1] | Raw input status manual override speed 1
[man2] | Raw input status manual override speed 2
[man3] | Raw input status manual override speed 3
GrpAla | Collective message for any active alarm

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Alarm administration (Index) | Controls whether the alarms in an SWeb alarm list are registered. 0 = No, -1 = Alarm number assigned automatically, >0 = fixed (start) alarm number. (FBox Alarm SWeb/AlarmHdr)
BACnet | Select if and what kind of BACnet objects should be generated automatically
Group alarm from fb/mp/pfb | Selection of the group alarm
[ --- Feedback --- ] |
Digital Input speed 1 | Digital Input feedback speed 1
Digital Input speed 2 | Digital Input feedback speed 2
Digital Input speed 3 | Digital Input feedback speed 3
Delay | Maximum delay until feedback is present
Alarm status | Alarm feedback missing
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Process feedback --- ] |
Digital input | Digital Input process feedback
Normal input state | Selection of the normal status of the input
Delay (Sec) | Maximum delay until process feedback is present
Alarm status | Alarm process feedback missing
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Motor protection --- ] |
Digital Input speed 1 | Digital Input motor protection speed 1
Digital Input speed 2 | Digital Input motor protection speed 2
Digital Input speed 3 | Digital Input motor protection speed 3
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Normal input state | Selection of the normal status of the input
Alarm suppression | Associated voltage group for suppressing ghost alarm on voltage shortage
Alarm status | Alarm motor protection triggered
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Service switch --- ] |
Digital input | Digital Input service switch
Acknowledgement mandatory | Selection whether the alarm follows the input or remains stored and must be acknowledged
Normal input state | Selection of the normal status of the input
Alarm suppression | Associated voltage group for suppressing ghost alarm on voltage shortage
Alarm status | Alarm service switch switched off
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Manual override --- ] |
Digital Input speed 1 | Digital Input manual override speed 1
Digital Input speed 2 | Digital Input manual override speed 2
Digital Input speed 3 | Digital Input manual override speed 3
Normal status | Selection of the normal status of the input
Alarm suppression | Associated voltage group for suppressing ghost alarm on voltage shortage
Alarm status | Alarm manual override active
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Delay --- ] |
Mode/Speed | Delay
[ --- DDC Suite V 2.5 --- ] |

Functional

Operating feedback absent

If there is a high signal at input "Run", the motor should be activated. If the operating feedback is not available at input "fb" after the end of the delay, the signal operating feedback absent is issued. This should be reset by a central acknowledgement (see FBox "InitLib").

Process feedback absent

If there is a high signal at input "Run", the motor should be activated. If the rotary speed feedback is not available at input "pfb" after the end of the delay, the signal process signal absent is issued. This should be reset by a central acknowledgement (see FBox "InitLib").

The normal status of the issuer of the process feedback is to be set in such a way that it displays the same status as during turned-off drive!

Motor protection activated

Is monitored independent of the operating status of the motor. The normal status (NO and/or NC) of the signal can be set online. If required, the error signal can be firmly set (with requirement of acknowledgement) and in that case must be reset by a central acknowledgement (see FBox "InitLib").

To prevent ghost signals in case of a fuse failure, a rejection of signal takes place depending on the associated voltage monitoring (see FBox "Control voltages").

Service switch turned off

Is monitored independent of the operating status of the motor. The normal status (NO and/or NC) of the signal can be set online. If required, the error signal can be firmly set (with requirement of acknowledgement) and in that case must be reset by a central acknowledgement (see FBox "InitLib").

To prevent ghost signals in case of a fuse failure, a rejection of signal takes place depending on the associated voltage monitoring (see FBox "Control voltages").

Manual intervention

Is monitored independent of the operating status of the motor. The normal status (NO and/or NC) of the signal can be set online.

To prevent ghost signals in case of a fuse failure, a rejection of signal takes place depending on the associated voltage monitoring (see FBox Control voltages).

The error signal manual intervention deactivated and/or an absent operating feedback.

Collective error

The collective error at output "GrpAla" consists of 3 standard signals.

- Operating feedback absent

- Motor protection activated

- Process feedback

Alternatively, it can be still parameterised whether the signals service switch and/or manual intervention should be likewise included in the collective error signal.

Input contacts

The input contacts to be monitored can be connected to the inputs of the FBox or alternatively in the FBox itself. In the process, the address "-1" indicates that the FBox should use the input contact of the FBox input.

As soon as an address is stated between 0 and 1023 (= physical input address), the FBox input is inactive and can be arbitrarily connected with "L" ort "H". The FBox independently reads out the parameterised input and monitors it.

As the input would not be visible at starting up, the outputs of the FBox reflects the corresponding input status in square brackets "[]", regardless of whether it is from the FBox input or from the physical input directly read out from FBox. However, this is always the physical status of the input. An optional inversion is not executed here.

System function alarm management

The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.

Index | Operating feedback absent
Index 1 | Motor protection activated
Index 2 | Service switch turned off
Index 3 | Process feedback absent
Index 4 | Manual intervention

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Description
mo | BI | Operating feedback absent
mp/fb | BI | Motor protection activated
mp/fb/ss | BI | Service switch turned off
mp/fb/ss/pfb | BI | Process feedback absent
all | BI | Manual intervention

Predefined

Group alarm from fb/mp/pfb | GrpAlaType | R | 1 = Only these
 |  |  | 2 = ss
 |  |  | 3 = man
 |  |  | 4 = ss man
Digital Input speed 1 | FbSp1DITerm | R | -1..1023
Digital Input speed 2 | FbSp2DITerm | R | -1..1023
Digital Input speed 3 | FbSp3DITerm | R | -1..1023
Delay | FbDelay | R | 0..6000
Alarm status | FbAla | F | 0 = ok
 |  |  | 1 = ALARM
Digital input | PfbDITerm | R | -1..1023
Normal input state | PfbNoNc | F | 0 = opened
 |  |  | 1 = Closed
Delay (Sec) | PfbDelay | R | 0..6000
Alarm status | PfbAla | F | 0 = ok
 |  |  | 1 = ALARM
Digital Input speed 1 | MotSp1DITerm | R | -1..1023
Digital Input speed 2 | MotSp2DITerm | R | -1..1023
Digital Input speed 3 | MotSp3DITerm | R | -1..1023
Acknowledgement mandatory | MotMbAck | F | 0 = No
 |  |  | 1 = Yes
Normal input state | MotNoNc | F | 0 = opened
 |  |  | 1 = Closed
Alarm suppression | MotVoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Alarm status | MotAla | F | 0 = ok
 |  |  | 1 = ALARM
Digital input | SsDITerm | R | -1..1023
Acknowledgement mandatory | SsMbAck | F | 0 = No
 |  |  | 1 = Yes
Normal input state | SsNoNc | F | 0 = opened
 |  |  | 1 = Closed
Alarm suppression | SsVoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Alarm status | SsAla | F | 0 = ok
 |  |  | 1 = ALARM
Digital Input speed 1 | ManSp1DITerm | R | -1..1023
Digital Input speed 2 | ManSp2DITerm | R | -1..1023
Digital Input speed 3 | ManSp3DITerm | R | -1..1023
Normal status | ManNoNc | F | 0 = opened.
 |  |  | 1 = Closed
Alarm suppression | ManVoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Alarm status | ManAla | F | 0 = ok
 |  |  | 1 = ALARM
Alarm status | ManAla | F | 0 = ok
 |  |  | 1 = ALARM


Frost air heater

Family: | DDC 2.5 Alarming
Name: | Frost air heater
Macro: | _DDC_ALFROST250
Version: | 2.5.001

Description

Frost protection monitoring of the preheater for ventilation systems.

Input |
AirFt | Input of the anti-frost thermostats
RetT | Return temperature of the pre-heater

Output |
[AirFt] | Raw status of the digital input of the thermostat
AlaAirFt | Frost warning through side air circuit anti-frost thermostat
AlaRetT | Frost warning on too low return temperature
AlaFr | Frost warning or frost error
QitAla | Requirement hardware reset for wiping the thermostat lock

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Alarm administration (Index) | Controls whether the alarms in an SWeb alarm list are registered. 0 = No, -1 = Alarm number assigned automatically, >0 = fixed (start) alarm number. (FBox Alarm SWeb/AlarmHdr)
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Air circuit thermostat --- ] |
Digital input | Digital input
Normal input state | Selection of the normal status of the input
Alarm suppression | Associated voltage group for suppressing ghost alarm on voltage shortage
[ --- Return temperature --- ] |
Warning if RetT less than | Limit low, if less the frost warning for return temperature is outputted
Normal if RetT bigger than | Limit high, if bigger the normal status is reached
[ --- Delays --- ] |
Delay on 1. warning (Sec.) | Period in which the heat exchanger is flushed and effort is made to restore normal status
Monitoring after 1. warning (Sec.) | If there is a frost alarm on restart of the system within this time, an alarm is generated
Delay in sec. | Delay
[ --- Alarms --- ] |
Frost warning air | Alarm frost warning air circuit
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Frost warning water | Alarm frost warning water circuit
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Frost program running | Alarm frost program running
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Frost alarm | Alarm frost
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- DDC Suite V 2.5 --- ] |

Functional

The downstream frost protection thermostat can be parametered as NO or NC. To prevent ghost signals in case of a fuse failure, a rejection of signal takes place depending on the associated voltage monitoring (see FBox "Control voltages").

The frost programme takes place as follows:

1. Determination of a frost warning through downstream frost protection thermostat or return temperature of lower limit value of frost warning in return temperature lower °C.

2. Signal of the respective frost warning, output "AlaFr" is high

3. After the end of the delay for the 1st warning, an impulse for hardware acknowledgement is triggered at output "QitAla" (if necessary, it is to be connected at input "QHw" of the module "InitLIb" if an automatic hardware reset is desired) in order to check whether the downstream frost protection goes back to lock.

4a. If after the hardware acknowledgement, the return temperature is greater than the limit value of normal signal with return temperature greater than °C and the frost protection thermostat in normal position, the output "AlaFr" is reset and a monitoring time delay for the 2nd warning is started. If a frost warning appears again within this period, the output "AlaFr" is set. This error should be reset by the central acknowledgement (see FBox "InitLib").

4b. If the return temperature after the hardware acknowledgement is still not above the limit value of normal signal with return temperature greater than °C or the frost protection temperature is still in alarm position, the output "AlaFr" remains set. This error should be reset by the central acknowledgement (see FBox "InitLib").

Input contacts

The input contacts to be monitored can be connected to the inputs of the FBox or alternatively in the FBox itself. In the process, the address "-1" indicates that the FBox should use the input contact of the FBox input.

As soon as an address is stated between 0 and 1023 (= physical input address), the FBox input is inactive and can be arbitrarily connected with "L" ort "H". The FBox independently reads out the parameterised input and monitors it.

As the input would not be visible at starting up, the outputs of the FBox reflects the corresponding input status in square brackets "[]", regardless of whether it is from the FBox input or from the physical input directly read out from FBox. However, this is always the physical status of the input. An optional inversion is not executed here.

System function alarm management

The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.

Index | Downstream frost protection activated
Index 1 | Return temperature too low
Index 2 | Frost programme activated
Index 3 | Frost alarm at the heater coil

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Description
Fr | BI | Frost alarm at the heater coil
Fr/AirFt | BI | Downstream frost protection activated
Fr/AirFt/RetT | BI | Return temperature too low
All | BI | Frost programme activated

Predefined

Digital input | AirDITerm | R | -1..1023
Normal input state | AirNoNc | F | 0 = opened
 |  |  | 1 = Closed
Alarm suppression | AirVoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Warning if RetT less than | WaterLimLow | R | 0..500
Normal if RetT bigger than | WaterLimOk | R | 0..500
Delay on 1. warning (Sec.) | Delay1 | R | 0..6000
Monitoring after 1. warning (Sec.) | Delay2 | R | 0..9000
Monitoring after 1. warning (Sec.) | Delay2 | R | 0..9000
Frost warning air | AirAla | F | 0 = ok
 |  |  | 1 = ALARM
Frost warning water | WaterAla | F | 0 = ok
 |  |  | 1 = ALARM
Frost program running | Ala | F | 0 = ok
 |  |  | 1 = ALARM
Frost alarm | FrostAla | F | 0 = ok
 |  |  | 1 = ALARM


Fire damper

Family: | DDC 2.5 Alarming
Name: | Fire damper
Macro: | _DDC_ALFD250
Version: | 2.5.000

Description

Module for the control and monitoring of a motor-driven fire damper. This FBox presupposes the module "Bsk Init" from the "DDC Initialisation" family.

Input |
Open | Requirement to open the fire damper
fbC | Feedback closed
fbO | Feedback opened
Test | Requirement test activation (open/ close) the fire damper

Output |
Open | Control command to open the fire damper
GrpAla | Group alarm (Open/close missing) for further preparation
AlaC | Alarm feedback closed missing
AlaO | Alarm feedback open missing
GrpMsg | Message (Open/close missing) for further preparation
Test | Relaying the test requirement to the next sequentially wired fire damper
[fbO!] | Raw digital input status feedback open
[fbC!] | Raw digital input status feedback closed

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Alarm administration (Index) | Controls whether the alarms in an SWeb alarm list are registered. 0 = No, -1 = Alarm number assigned automatically, >0 = fixed (start) alarm number. (FBox Alarm SWeb/AlarmHdr)
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Fire damper --- ] |
Selection | Mode selection of the damper actuator
[ --- Monitoring --- ] |
Digital input feedback open | Digital input feedback open
Digital input feedback closed | Digital input feedback closed
Acknowledgement mandatory | Setting the mandatory acknowledgement for the alarm Closed and Open
Function Output | Selection of the forwarding the feedback alarms to the outputs GrpAla and GrpMsg
Alarm feedback closed missing | Alarm feedback closed missing
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Alarm feedback open missing | Alarm feedback open missing
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Status indicators --- ] |
Activation | Status display of the activation
Feedback closed | Status display feedback closed
Feedback open | Status display feedback open
Duration until feedback closed | Duration of the drive from activation command Closed until feedback Closed completed
Duration until feedback open | Duration of the drive from activation command Open until feedback Open completed
[ --- DDC Suite V 2.5 --- ] |

Functional

The FBox is linked to the Init module via the name/reference mechanism. The input "Test" enforces a flap test, in which the flap is first closed and then opened. The feedbacks are monitored and the result of the test is entered in the Init module.

The operating times are logged, so that it is identifiable in due time whether a motor should be replaced if necessary.

The signals feedback Open absent and feedback Close absent are separately issued for further processing. In addition, it can be selected whether the outputs "GrpAla" and "GrpMsg" or none or both should be controlled. This enables a linkage in, for example, a turning off or only signalling error chain.

Function Selection

Close | Damper control remains permanently in direction off (Output Open = Low)
Auto (Wiper) | Damper control depends on the input Open. The output Open will be uniquely triggered on positive edge over the duration of the runtime (FBox BSK Init) (e.g. for lock)
Auto (Duration) | Damper control depends on the input Open. The output Open becomes permanently low or high
Open | Damper control remains permanently in direction on (Output Open = High)
table
Input contacts
The input contacts to be monitored can be connected to the inputs of the FBox or alternatively in the FBox itself. In the process, the address "-1" indicates that the FBox should use the input contact of the FBox input.
As soon as an address is stated between 0 and 1023 (= physical input address), the FBox input is inactive and can be arbitrarily connected with "L" ort "H". The FBox independently reads out the parameterised input and monitors it.
As the input would not be visible at starting up, the outputs of the FBox reflects the corresponding input status in square brackets "[]", regardless of whether it is from the FBox input or from the physical input directly read out FBox. However, this is always the physical status of the input. An optional inversion is not executed here.
System function alarm management
The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.
table
Index | Feedback Open absent
Index 1 | Feedback Close absent

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Description
Yes | BI | Feedback Open absent
Yes | BI | Feedback Close absent

Predefined

Selection | Mode | R | 0 = Closed
 |  |  | 1 = Auto (Duration)
 |  |  | 2 = Auto (Wiper)
 |  |  | 3 = Up
Digital input feedback open | FbOpenDITerm | R | -1..1000
Digital input feedback closed | FbCLosedDITerm | R | -1..1000
Acknowledgement mandatory | MbAck | F | 0 = No
 |  |  | 1 = Yes
Function Output | FuncOut | R | 0 = Without
 |  |  | 1 = GrpMsg
 |  |  | 2 = GrpAla
 |  |  | 3 = GrpMsg GrpAla
Alarm feedback closed missing | AlaClosed | F | 0 = ok
 |  |  | 1 = ALARM
Alarm feedback open missing | AlaOpen | F | 0 = ok
 |  |  | 1 = ALARM
Activation | Status | F | 0 = Closed
 |  |  | 1 = Open
Feedback closed | FbClosed | F | 0 = -
 |  |  | 1 = closed
Feedback open | FbOpen | F | 0 = -
 |  |  | 1 = open
Duration until feedback closed | DelClosed | R |
Duration until feedback open | DelOpen | R |


Acknowledge

Family: | DDC 2.5 Alarming
Name: | Acknowledge
Macro: | _DDC_ALRESET250
Version: | 2.5.000

Description

Offers the possibility to execute an acknowledgement.

Adjust |
Acknowledge stored alarms | Acknowledge stored alarms from this position till end of program
[ --- DDC Suite V 2.5 --- ] |

Functional

If this FBox is set on each page which generates error signals requiring acknowledgement, no troublesome jumping to the initialisation page is required in order to activate the acknowledgement through the FBox "InitLib".

The acknowledgement is carried out only from the position of the FBox till the end of the Fupla. Therefore always set on the left upper corner!

Predefined


Forwarding alarm

Family: | DDC 2.5 Alarming
Name: | Forwarding alarm
Macro: | _DDC_ALUSE250
Version: | 2.5.000

Description

Simple relaying of a digital status.

Input |
Us | Alarm to forward

Output |
e | forwarded alarm

Adjust |
Alarm forewarding | Selection if alarm on input should be forwarded to output
[ --- DDC Suite V 2.5 --- ] |

Functional

Serves mainly to create error signal pages, where it is still unclear at the beginning in the separate signals whether these should, for instance, be included in a turning-off chain.

In this way, for instance, an error signal can be removed from an order chain if it turns out that this error should not be included.

Predefined

Alarm forewarding | Forwarded | F | 0 = No
 |  |  | 1 = Yes


DDC 2.5 Set points

Version: 2.5.000

With Hysteresis

Set point room

Linear 2-Points

Linear 4-Points

Binary

Integer

Integer (MV)


With Hysteresis

Family: | DDC 2.5 Set points
Name: | With Hysteresis
Macro: | _DDC_SPHYSP250
Version: | 2.5.000

Description

Constant set point with hystereses and external manipulation.

Input |
Ext. | External Set point or correction

Output |
Hyst | Basic Set point with positive hysteresis
SetPt | Basic Set point
-Hyst | Basic Set point with negative hysteresis

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BAcnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
External specification | Function selection of the input Ext
Set point of external | Display of the external value
Set point basic | Basic Set point
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Set point hysteresis | positive and negative hystereses for basic Set point
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Set point with pos. hysteresis | Set point with positive hysteresis
Resultant Set point | Mean desired Set point
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Set point with neg. hysteresis | Set point with negative hysteresis
[ --- Definitions --- ] |
Unit | Unit
COV Hysteresis | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
[ --- DDC Suite V 2.5 --- ] |

Functional

Used mainly for humidification and dehumidification. For a dead band to be present between the humidification and dehumidification, often 2 set points are stated. The following functions can be provided via an external specification, e.g. set-point device:

- Inactive, the basis of the set point is the desired set point with which an upper and lower set point is calculated by the hysteresis.

- Anh/Abs, the basis of the set point is the desired set point with which the external specification can be still raised or lowered (e.g. set point device - 3 K). With the set point resulting from it, the upper and lower set point is calculated by the hysteresis.

- Absolute, the external specification is the desired set point with which an upper and lower set point is calculated by the hysteresis.

System function Offline Trending

The resulting set point (output "Sw") can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Base | AV | - | Base set point
Base/Res. | AV | - | Resultant set point
Base/Res. | TR | optional | Resulting set point
Base/Res./Hyst. | AV | - | Hysteresis

Predefined

External specification | ExtFunc | R | 0 = inactive
 |  |  | 1 = Correction /-
 |  |  | 2 = Absolute
Set point of external | ExtVal | R |
Set point basic | BaseSetPt | R |
Set point hysteresis | Hysteresis | R |
Set point with pos. hysteresis | SetPtPosHyst | R |
Resultant Set point | SetPtAver | R |
Set point with neg. hysteresis | SetPtNegHyst | R |


Set point room

Family: | DDC 2.5 Set points
Name: | Set point room
Macro: | _DDC_SPROOM250
Version: | 2.5.000

Description

Room set-point calculation according to DIN with external manipulation.

Input |
Ext | External value
OutTemp | Outdoor air temperature

Output |
SetPt | Resultant Set point

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
External specification | Selection Function of the external value
Raising/Lowering | Display of the external value
Set point determination | Selection of the function of Set point calculation
Set point basic | Basic Set point
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Difference To according to DIN | DIN Difference of outside temperature to Set point room
Set point maximum | Maximum Set point for DIN Limit
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Resultant Set point | Actual Set point
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
[ --- Definitions --- ] |
Unit | Unit
COV Hysteresis | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
[ --- DDC Suite V 2.5 --- ] |

Functional

Calculation of the room set point according to DIN. The following functions can be provided via an external specification, e.g. set-point device:

- Inactive, the value set-point basis is the desired set point

- Anh/Abs, the value set-point basis is raised or lowered with the value from input "Ext". The value resulting from it is the desired set point.

- Absolute, the value from input "Ext" is the basis and thus also the desired set point.

The desired set point determined in this way is influenced by the selection of the set-point determination.

- According to DIN, if the desired set point is greater than outside air temperature less the difference to the outside temperature, the desired set point is stated as the resultant set point, or else the calculated value from outside air temperature less the difference to the outside temperature.

- Limited, as described earlier, but if this value is greater than maximum set point, the maximum set point is stated as the resultant set point.

- Constant, the desired set point is stated as the resultant set point.

System function Offline Trending

The resulting set point (output "SetPt") can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Base | AV | - | Base set point
Base/Res | AV | - | Resultant set point
Base/Res | TR | optional | Resulting set point
Base/Res/Max | AV | - | Max. limiting

Predefined

External specification | ExtFunc | R | 0 = inactive
 |  |  | 1 = Correction /-
 |  |  | 2 = Absolute
Raising/Lowering | ExtVal | R |
Set point determination | SetPtType | R | 0 = accoding to DIN
 |  |  | 1 = Limited
 |  |  | 2 = Constant
Set point basic | BaseSetPt | R | 0..1000
Difference To according to DIN | DiffDin | R | 0..200
Set point maximum | Maximum | R | 0..1000
Resultant Set point | SetPt | R |


Linear 2-Points

Family: | DDC 2.5 Set points
Name: | Linear 2-Points
Macro: | _DDC_SPLIN2P250
Version: | 2.5.000

Description

Linear equation, limited.

Input |
X | Value to be transformed

Output |
Y | Calculated value

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
Calculated value | Resultant value from the conversion
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
(X1) Outside air temperature. | X1-value
<--- BACnet common X1/2 ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
<--- BACnet Object-Name ---> | Suffix of Object Name
(Y1) associated Set point | Y1-value
<--- BACnet common Y1/2 ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
<--- BACnet Object-Name ---> | Suffix of Object Name
(X2) Outside air temperature. | X2-value
<--- BACnet Object-Name ---> | Suffix of Object Name
(Y2) associated Set point | Y2-value
<--- BACnet Object-Name ---> | Suffix of Object Name
[ --- Definitions --- ] |
X-values unit | Unit X-value
X-values COV Hysteresis | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
Y-values unit | Unit Y-value
Y-values COV Hysteresis | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
[ --- DDC Suite V 2.5 --- ] |

Functional

Simple linear equation. If the transformative value lies below X1, Y1 is issued. If the transofrmative value is above X2, Y2 is issued. X2 must be greater than X1, Y1 and Y2 can be optionally stated.

System function Offline Trending

The calculated value (output "Y") can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
SetPt | AV | - | Set point
SetPt | TR | optional | Set point
SetPt/Y-values | AV | - | Parameter Y1
SetPt/Y-values | AV | - | Parameter Y2
SetPt/X/Y-values | AV | - | Parameter X1
SetPt/X/Y-values | AV | - | Parameter X2

Predefined

Calculated value | Result | R
(X1) Outside air temperature. | CurveX1 | R
(Y1) associated Set point | CurveY1 | R
(X2) Outside air temperature. | CurveX2 | R
(Y2) associated Set point | CurveY2 | R


Linear 4-Points

Family: | DDC 2.5 Set points
Name: | Linear 4-Points
Macro: | _DDC_SPLIN4P250
Version: | 2.5.000

Description

Linear equaltion x3, limited.

Input |
X | Value to be transformed

Output |
Y | Calculated value

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
Calculated value | Resultant value from the conversion
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
(X1) Outside air temperature. | X1-value
<--- BACnet common X1..4 ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
<--- BACnet Object-Name ---> | Suffix of Object Name
(Y1) associated Set point | Y1-value
<--- BACnet common Y1..4 ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
<--- BACnet Object-Name ---> | Suffix of Object Name
(X2) Outside air temperature. | X2-value
<--- BACnet Object-Name ---> | Suffix of Object Name
(Y2) associated Set point | Y2-value
<--- BACnet Object-Name ---> | Suffix of Object Name
(X3) Outside air temperature. | X3 value
<--- BACnet Object-Name ---> | Suffix of Object Name
(Y3) associated Set point | Y3 value
<--- BACnet Object-Name ---> | Suffix of Object Name
(X4) Outside air temperature. | X4 value
<--- BACnet Object-Name ---> | Suffix of Object Name
(Y4) associated Set point | Y4 value
<--- BACnet Object-Name ---> | Suffix of Object Name
[ --- Definitions --- ] |
X-values unit | Unit X-value
X-values COV Hysteresis | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
Y-values unit | Unit Y-value
Y-values COV Hysteresis | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
[ --- DDC Suite V 2.5 --- ] |

Functional

Simple linear equation. If the transformative value lies below X1, Y1 is issued. If the transofrmative value is above X4, Y4 is issued. X4 must be greater than X3, X3 must be greater than X2, X2 must be greater than X1 , Y1, Y2, Y3 and Y4 can be optionally stated.

System function Offline Trending

The calculated value (output "Y") can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
SetPt | AV | - | Set point
SetPt | TR | optional | Set point
SetPt/Y-values | AV | - | Parameter Y1
SetPt/Y-values | AV | - | Parameter Y2
SetPt/Y-values | AV | - | Parameter Y3
SetPt/Y-values | AV | - | Parameter Y4
SetPt/X/Y-values | AV | - | Parameter X1
SetPt/X/Y-values | AV | - | Parameter X2
SetPt/X/Y-values | AV | - | Parameter X3
SetPt/X/Y-values | AV | - | Parameter X4

Predefined

Calculated value | Result | R
(X1) Outside air temperature. | CurveX1 | R
(Y1) associated Set point | CurveY1 | R
(X2) Outside air temperature. | CurveX2 | R
(Y2) associated Set point | CurveY2 | R
(X3) Outside air temperature. | CurveX3 | R
(Y3) associated Set point | CurveY3 | R
(X4) Outside air temperature. | CurveX4 | R
(Y4) associated Set point | CurveY4 | R


Binary

Family: | DDC 2.5 Set points
Name: | Binary
Macro: | _DDC_SPBIN250
Version: | 2.5.000

Description

Setting a binary value. This FBox is mainly used to prepare digital information for ViSi.Plus or BACnet.

Output |
Val | Status of the binary value

Adjust |
[ --- System functions --- ] |
Bezeichnung | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
Description | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
Pre-selection | Preset value
State | Status of the binary output
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Inactive text | Text with status [Low]
- Active text | Text with status [High]
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
<--- Commandable ---> |
Use | Select whether the BACnet object is to support the function Commandable.
Priority 08 (Service) | Status commandable value
... Value | Preset commandable value
[ --- DDC Suite V 2.5 --- ] |

Functional

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Yes | BV | - | Binary value
Yes | TR | optional | Binary value

Predefined

Pre-selection | Value | F | 0 = Low
 |  |  | 1 = High
State | Output | F | 0 = Low
 |  |  | 1 = High
Priority 08 (Service) | Prio8En | F | 0 = Off
 |  |  | 1 = On
... Value | Prio8Val | F | 0 = Low
 |  |  | 1 = High


Integer

Family: | DDC 2.5 Set points
Name: | Integer
Macro: | _DDC_SPINT250
Version: | 2.5.001

Description

Setting an analogue value. This FBox is mainly used to prepare analogue information for ViSi.Plus or BACnet.

Output |
Val | Status of the binary value

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
Pre-selection | Preet value
State | Status of the integer output
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
<--- Commandable ---> |
Use | Select whether the BACnet object is to support the function Commandable.
Priority 08 (Service) | Status commandable value
... Value | Preset commandable value
<--- Intrinsic Reporting ---> |
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- High Limit | Upper threshold leading to an alarm message.
- Low Limit | Lower threshold leading to an alarm message.
- Deadband | Dead band, applies for upper/lower threshold when switching back to normal state.
- Limit Enable | Select which threshold violation should be enabled.
[ --- Definitions --- ] |
Unit | Unit
COV Hysteresis | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
[ --- DDC Suite V 2.5 --- ] |

Functional

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Yes | AV | - | Integer Wert value
Yes | TR | optional | Integer value

Predefined

Pre-selection | Value | R |
State | Output | R |
Priority 08 (Service) | Prio8En | F | 0 = Off
 |  |  | 1 = On
... Value | Prio8Val | R |


Integer (MV)

Family: | DDC 2.5 Set points
Name: | Integer (MV)
Macro: | _DDC_SPINTMV251
Version: | 2.5.001

Description

Setting an analogue value as enumeration, starting from 1. This FBox is mainly used to prepare numeric information (enumeration) for ViSi.Plus or BACnet.

Output |
Val(MV) | Status of the binary value

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
Pre-selection | Preet value
State | Status of the integer output
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
<--- Commandable ---> |
Use | Select whether the BACnet object is to support the function Commandable.
Priority 08 (Service) | Status commandable value
... Value | Preset commandable value
<--- Intrinsic Reporting ---> |
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
Alarm Values | Values forcing an alarm. List, values seperated with comma
Fault Values | Values forcing an fault. List, values seperated with comma
[--- State Text ---] |
Number of States | Number of states (1..100)
Use till No. | Defines which of the texts will be used to generate the state text.
No. 1 .. 10 | Text 1 format "Text1" or an enumeration format "Text1","Text2", ... ,"Text10" (between texte a comma mus set,, at the end none!)
No. 11 .. 20 | Text 2 format "Text11" or an enumeration format "Text11","Text12", ... ,"Text20" (between texte a comma mus set,, at the end none!)
No. 21 .. 30 | Text 3 format "Text21" or an enumeration format "Text21","Text22", ... ,"Text30" (between texte a comma mus set,, at the end none!)
No. 31 .. 40 | Text 4 format "Text31" or an enumeration format "Text31","Text32", ... ,"Text40" (between texte a comma mus set,, at the end none!)
No. 41 .. 50 | Text 5 format "Text41" or an enumeration format "Text41","Text42", ... ,"Text50" (between texte a comma mus set,, at the end none!)
No. 51 .. 60 | Text 6 format "Text51" or an enumeration format "Text51","Text52", ... ,"Text60" (between texte a comma mus set,, at the end none!)
No. 61 .. 70 | Text 7 format "Text61" or an enumeration format "Text61","Text62", ... ,"Text70" (between texte a comma mus set,, at the end none!)
No. 71 .. 80 | Text 8 format "Text71" or an enumeration format "Text71","Text72", ... ,"Text80" (between texte a comma mus set,, at the end none!)
No. 81 .. 90 | Text 9 format "Text81" or an enumeration format "Text81","Text82", ... ,"Text90" (between texte a comma mus set,, at the end none!)
No. 91 .. 100 | Text 10 format "Text91" or an enumeration format "Text91","Text92", ... ,"Text100" (between texte a comma mus set,, at the end none!)
[ --- DDC Suite V 2.5 --- ] |

Functional

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Yes | MV | - | Integer Wert value
Yes | TR | optional | Integer value

Predefined

Pre-selection | Value | R | 1..1000
State | Output | R |
Priority 08 (Service) | Prio8En | F | 0 = Off
 |  |  | 1 = On
... Value | Prio8Val | R | 1..1000


DDC 2.5 Analogue values

Version: 2.5.000

Binary

Binary (BV)

Integer

Integer (AV)

Integer (MI)

Integer (MV)

Sensor

Selection

Analog as Digital

Counter


Binary

Family: | DDC 2.5 Analogue values
Name: | Binary
Macro: | _DDC_ANBIN250
Version: | 2.5.000

Description

Picks up the value from the FBox input and copies it to an internal variable and to the FBox output. With the BACnet option, the OutOfService property will also be taken into account. This FBox is mainly used to prepare digital information for ViSi.Plus or BACnet.

Input |
Value | Status of the binary value

Output |
 | Status of the binary value

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
Pre-selection | Status of the binary output
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Inactive text | Text with status [Low]
- Active text | Text with status [High]
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
[ --- DDC Suite V 2.5 --- ] |

Functional

Systemfunktion BACnet

This FBox can generate BACnet objects automatically. The corresponding options in the "BACnet" parameter create the following BACnet objects:

Option | Object | Note | Description
Ja | BV | - | Value
Ja | TR | Optional | Value

Predefined

Pre-selection | Value | F | 0 = Low
 |  |  | 1 = High


Binary (BV)

Family: | DDC 2.5 Analogue values
Name: | Binary (BV)
Macro: | _DDC_ANBINBV251
Version: | 2.5.000

Description

Picks up the value from the FBox input and copies it to an internal variable and to the FBox output. With the BACnet option, the OutOfService property will also be taken into account. This FBox is mainly used to prepare digital information for ViSi.Plus or BACnet.

Input |
Val(BV) | Status of the binary value

Output |
 | Status of the binary value

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
Pre-selection | Status of the binary output
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Inactive text | Text with status [Low]
- Active text | Text with status [High]
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
[ --- DDC Suite V 2.5 --- ] |

Functional

Systemfunktion BACnet

This FBox can generate BACnet objects automatically. The corresponding options in the "BACnet" parameter create the following BACnet objects:

Option | Object | Note | Description
Ja | BV | - | Value
Ja | TR | Optional | Value

Predefined

Pre-selection | Value | F | 0 = Low
 |  |  | 1 = High


Integer

Family: | DDC 2.5 Analogue values
Name: | Integer
Macro: | _DDC_ANINT250
Version: | 2.5.000

Description

Picks up the value from the FBox input and copies it to an internal variable and to the FBox output. With the BACnet option, the OutOfService property will also be taken into account. This FBox is mainly used to prepare analogue information for ViSi.Plus or BACnet.

Input |
Value | Status of the integer value

Output |
 | Status of the integer value

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
Pre-selection | Status of the integer input
State | Status of the integer output
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
[ --- Intrinsic Reporting --- ] |
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- High Limit | Upper threshold leading to an alarm message.
- Low Limit | Lower threshold leading to an alarm message.
- Deadband | Dead band, applies for upper/lower threshold when switching back to normal state.
- Limit Enable | Select which threshold violation should be enabled.
[ --- Definitions --- ] |
Unit | Unit
COV Hysteresis | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
Phys. value min. | Minimum physical value
Phys. value max. | Maximum physical value
[ --- DDC Suite V 2.5 --- ] |

Functional

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Ja | AI | - | Value
Ja | TR | Optional | Value

Predefined

Pre-selection | Value | R
State | Output | R


Integer (AV)

Family: | DDC 2.5 Analogue values
Name: | Integer (AV)
Macro: | _DDC_ANINTAV251
Version: | 2.5.000

Description

Picks up the value from the FBox input and copies it to an internal variable and to the FBox output. With the BACnet option, the OutOfService property will also be taken into account. This FBox is mainly used to prepare analogue information for ViSi.Plus or BACnet.

Input |
Val(AV) | Status of the integer value

Output |
 | Status of the integer value

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
Pre-selection | Status of the integer input
State | Status of the integer output
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
[ --- Intrinsic Reporting --- ] |
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- High Limit | Upper threshold leading to an alarm message.
- Low Limit | Lower threshold leading to an alarm message.
- Deadband | Dead band, applies for upper/lower threshold when switching back to normal state.
- Limit Enable | Select which threshold violation should be enabled.
[ --- Definitions --- ] |
Unit | Unit
COV Hysteresis | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
[ --- DDC Suite V 2.5 --- ] |

Functional

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Ja | AV | - | Value
Ja | TR | Optional | Value

Predefined

Pre-selection | Value | R
State | Output | R


Integer (MI)

Family: | DDC 2.5 Analogue values
Name: | Integer (MI)
Macro: | _DDC_ANINTMI251
Version: | 2.5.000

Description

Picks up the value from the FBox input (enumeration starting at 1) and copies it to an internal variable and to the FBox output. With the BACnet option, the OutOfService property will also be taken into account. This FBox is mainly used to prepare an enumeration for ViSi.Plus or BACnet.

Input |
Val(MI) | Status of the integer value

Output |
 | Status of the integer value

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
Pre-selection | Status of the integer input
State | Status of the integer output
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
[ --- Intrinsic Reporting --- ] |
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
Alarm Values | Values forcing an alarm. List, values seperated with comma
Fault Values | Values forcing an fault. List, values seperated with comma
[--- State Text ---] |
Number of STates | Number of states (1..100)
Use till No. | Defines which of the texts will be used to generate the state text.
No. 1 .. 10 | Text 1 format "Text1" or an enumeration format "Text1","Text2", ... ,"Text10" (between texte a comma mus set,, at the end none!)
No. 11 .. 20 | Text 2 format "Text11" or an enumeration format "Text11","Text12", ... ,"Text20" (between texte a comma mus set,, at the end none!)
No. 21 .. 30 | Text 3 format "Text21" or an enumeration format "Text21","Text22", ... ,"Text30" (between texte a comma mus set,, at the end none!)
No. 31 .. 40 | Text 4 format "Text31" or an enumeration format "Text31","Text32", ... ,"Text40" (between texte a comma mus set,, at the end none!)
No. 41 .. 50 | Text 5 format "Text41" or an enumeration format "Text41","Text42", ... ,"Text50" (between texte a comma mus set,, at the end none!)
No. 51 .. 60 | Text 6 format "Text51" or an enumeration format "Text51","Text52", ... ,"Text60" (between texte a comma mus set,, at the end none!)
No. 61 .. 70 | Text 7 format "Text61" or an enumeration format "Text61","Text62", ... ,"Text70" (between texte a comma mus set,, at the end none!)
No. 71 .. 80 | Text 8 format "Text71" or an enumeration format "Text71","Text72", ... ,"Text80" (between texte a comma mus set,, at the end none!)
No. 81 .. 90 | Text 9 format "Text81" or an enumeration format "Text81","Text82", ... ,"Text90" (between texte a comma mus set,, at the end none!)
No. 91 .. 100 | Text 10 format "Text91" or an enumeration format "Text91","Text92", ... ,"Text100" (between texte a comma mus set,, at the end none!)
[ --- DDC Suite V 2.5 --- ] |

Functional

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Object | Note | Description |
Ja | MI | - | Value
Ja | TR | Optional | Value

Predefined

Pre-selection | Value | R
State | Output | R


Integer (MV)

Family: | DDC 2.5 Analogue values
Name: | Integer (MV)
Macro: | _DDC_ANINTMV251
Version: | 2.5.000

Description

Picks up the value from the FBox input (enumeration starting at 1) and copies it to an internal variable and to the FBox output. With the BACnet option, the OutOfService property will also be taken into account. This FBox is mainly used to prepare an enumeration for ViSi.Plus or BACnet.

Input |
Val(MV) | Status of the integer value

Output |
 | Status of the integer value

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
Pre-selection | Status of the integer input
State | Status of the integer output
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
[ --- Intrinsic Reporting --- ] |
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
Alarm Values | Values forcing an alarm. List, values seperated with comma
Fault Values | Values forcing an fault. List, values seperated with comma
[--- State Text ---] |
Number of STates | Number of states (1..100)
Use till No. | Defines which of the texts will be used to generate the state text.
No. 1 .. 10 | Text 1 format "Text1" or an enumeration format "Text1","Text2", ... ,"Text10" (between texte a comma mus set,, at the end none!)
No. 11 .. 20 | Text 2 format "Text11" or an enumeration format "Text11","Text12", ... ,"Text20" (between texte a comma mus set,, at the end none!)
No. 21 .. 30 | Text 3 format "Text21" or an enumeration format "Text21","Text22", ... ,"Text30" (between texte a comma mus set,, at the end none!)
No. 31 .. 40 | Text 4 format "Text31" or an enumeration format "Text31","Text32", ... ,"Text40" (between texte a comma mus set,, at the end none!)
No. 41 .. 50 | Text 5 format "Text41" or an enumeration format "Text41","Text42", ... ,"Text50" (between texte a comma mus set,, at the end none!)
No. 51 .. 60 | Text 6 format "Text51" or an enumeration format "Text51","Text52", ... ,"Text60" (between texte a comma mus set,, at the end none!)
No. 61 .. 70 | Text 7 format "Text61" or an enumeration format "Text61","Text62", ... ,"Text70" (between texte a comma mus set,, at the end none!)
No. 71 .. 80 | Text 8 format "Text71" or an enumeration format "Text71","Text72", ... ,"Text80" (between texte a comma mus set,, at the end none!)
No. 81 .. 90 | Text 9 format "Text81" or an enumeration format "Text81","Text82", ... ,"Text90" (between texte a comma mus set,, at the end none!)
No. 91 .. 100 | Text 10 format "Text91" or an enumeration format "Text91","Text92", ... ,"Text100" (between texte a comma mus set,, at the end none!)
[ --- DDC Suite V 2.5 --- ] |

Functional

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Object | Note | Description |
Ja | MV | - | Value
Ja | TR | Optional | Value

Predefined

Pre-selection | Value | R
State | Output | R


Sensor

Family: | DDC 2.5 Analogue values
Name: | Sensor
Macro: | _DDC_ANSENSOR250
Version: | 2.5.001

Description

Recording an analogue measurement reading. The measurement reading can be converted and provided with filtering and monitoring of an upper and lower limit value.

Input |
Inp | Value of the sensor, raw card value or physical value

Output |
Value | Physical value of the sensor
AlaHigh | Value bigger than High limit
AlaLow | Value less than Low limit

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
PCD Alarm administration (Index) | Controls whether the alarms in an SWeb alarm list are registered. 0 = No, -1 = Alarm number assigned automatically, >0 = fixed (start) alarm number. (FBox Alarm SWeb/AlarmHdr)
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Sensor --- ] |
Card type | Selection of the conversion of the value connected at the input
Correction | Correction value in physical quantity
Physical Value (corrected) | Physical value of the sensor = Output Value
<--- BACnet Object Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
[ --- Filtering --- ] |
Smoothening of scanning Sec. | Scanning time of the sensor value for filtering
Smoothing factor | Factor for influencing a change in reading in the current actual value
[ --- Conversion --- ] |
Physical. Value min. | Minimum physical value
Physical. Value max. | Maximum physical value
raw input value min | Minimum raw value of the input card
raw input value max | Maximum raw value of the input card
Message suppression | Associated voltage group for suppressing ghost messages on voltage shortage
[ --- Alarm limit values --- ] |
Hysteresis | Hysteresis tresholdvalues
Delay | Delay tresholdvalues
High limit | High limit, for passive sensors e.g. cable break
... status | Message Value bigger than High limit
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
Low limit | Low limit, for passive sensors e.g. short circuit
... status | Message Value less than Low limit
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- Intrinsic Reporting ---> |
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Limit Enable | Select which threshold violation should be enabled.
[ --- Definitions --- ] |
Unit | Unit
COV Hysteresis | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
Skaling (decimal) | Scaling (recommended: 1)
[ --- DDC Suite V 2.5 --- ] |

Functional

The analogue value connected to the input In can be upgraded according to the setting:

- PCD2.W220 NI1000 DIN : The raw value is supplied by the card (standard/analogue module/PCD2.W220) and the physical value calculated here

- PCD2.W340 NI1000 DIN : The raw score is supplied by the card (standard/analogue module/PCD2.W340) and the physical value calculated here

- 1:1 : The physical value is already available

- Conversion: An arbitrary value (mostly from an active sensor) is converted by means of a linear equation.

Calibration

The recorded measurement reading can be calibrated by specifying an adjustment.

Filtering

The recorded measurement reading is filtered. The frequency of the measurement reading can be set, the smoothing factor of the allotment, which is included in the new measurement reading in case of a measured value alteration. Example:

Current measurement reading | 10.0 °C
New neasurement reading | 14.3 °C
Smoothing factor |  | 10

The formula is:

Current measurement reading=(New measurement reading - current measurement reading) / Smoothing factor current measured reading

Current measurement reading=(14.3 - 10.0) / 10 10.00 = 4.3 / 10 10.0 = 10.4°C

The more the smoothing factor, more sluggish is the measurement reading. The new measurement reading is directly used in factor 1.

Limit value monitoring

It additionally monitors for an upper and lower limit value. To prevent ghost signals in case of a fuse failure, a rejection of signal takes place depending on the associated voltage monitoring.

System function offline trending

The physical measured value can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function alarm management

The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.

Index |  | Exceeded upper limit value
Index 1 | Fallen below lower limit value |

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Ja | AI | - | Physical measurement
Ja | TR | Optional | Physical measurement

Predefined

Card type | ConvType | R | 0 = PCD2.W220 NI1000
 |  |  | 1 = PCD2.W340 NI1000
 |  |  | 2 = 1:1 physical
 |  |  | 3 = Conversion
Correction | Correction | R | -1000..1000
Physical Value (corrected) | PhysVal | R |
Smoothening of scanning Sec. | ScanTime | R | 0..600
Smoothing factor | ScanFact | R | 1..200
Physical. Value min. | PhysValY1 | R |
Physical. Value max. | PhysValY2 | R |
raw input value min | RawValX1 | R |
raw input value max | RawValX2 | R |
Message suppression | VoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Hysteresis | GwHyst | R | -1000..1000
Delay | GwVerz | R | 0..36000
High limit | LimHigh | R |
... status | AlaLimHigh | F | 0 = Ok
 |  |  | 1 = exceeded
Low limit | LimLow | R |
... status | AlaLimLow | F | 0 = Ok
 |  |  | 1 = fallen short of


Selection

Family: | DDC 2.5 Analogue values
Name: | Selection
Macro: | _DDC_ANSELECT250
Version: | 2.5.001

Description

Selection of up to 10 values for further processing, e.g. for selection of the leading actual value in 2 room temperature sensors and an outlet air temperature.

Input |
Inp | Value which can flow into the selection

Output |
max. | Maximum from all allowed values
Avg | Average value from all allowed values
min. | Minimum from all allowed values
#1 | Depending on the selection Min/Average/Maximum
#2 | Depending on the selection Min/Average/Maximum

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
Apply Value 1 | Selection whether value is applied to Inp0
Apply Value 2 | Selection whether value is applied to Inp1
Apply Value 3 | Selection whether value is applied to Inp2
Apply Value 4 | Selection whether value is applied to In3
Apply Value 5 | Selection whether value is applied to Inp4
Apply Value 6 | Selection whether value is applied to Inp5
Apply Value 7 | Selection whether value is applied to Inp6
Apply Value 8 | Selection whether value is applied to Inp7
Apply Value 9 | Selection whether value is applied to Inp8
Apply Value 10 | Selection whether value is applied to Inp9
[ --- Values --- ] |
Maximum value | Maximal value of all applied values
Average value | Average value of all applied values
Minimum value | Minimum value of all applied values
[ --- Outputs --- ] |
Output 1 | Selection Max/Average/Min for output #1
... Value | Value at output #1
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Output 2 (s) | Selection Max/Average/Min for output #2
... Value | Value at output #2
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
<--- Intrinsic Reporting ---> |
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- Deadband | Dead band, applies for upper/lower threshold when switching back to normal state.
- Limit Enable | Select which threshold violation should be enabled.
- High Limit | Upper threshold leading to an alarm message.
- Low Limit | Lower threshold leading to an alarm message.
[ --- Definitions --- ] |
Unit | Unit
COV Hysteresis | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
Phys. value min. | Minimum physical value
Phys. value max. | Maximum physical value
[ --- DDC Suite V 2.5 --- ] |

Functional

The input values, maximum 10, can be selected from a choice of maximum, medium and minimum. First, the considered value should be specified (selection "Yes"). The minimum, medium and maximum are then automatically computed from the values to be considered and issued to the corresponding outputs.

If all values are parameterised by mistake with the selection "No", the initial value is automatically reactivated.

The outputs "#1" and "#2" can be parameterised online to the minimum, medium and maximum value.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Output 1 | AI | - | Value at output #1
Output 1 | TR | Optional | Value at output #1
Output 1 und 2 | AI | - | Value at output #2
Output 1 und 2 | TR | Optional | Value at output #2

Predefined

Apply Value 1 | In1Activ | F | 0 = No
 |  |  | 1 = Yes
Apply Value 2 | In2Activ | F | 0 = No
 |  |  | 1 = Yes
Apply Value 3 | In3Activ | F | 0 = No
 |  |  | 1 = Yes
Apply Value 4 | In4Activ | F | 0 = No
 |  |  | 1 = Yes
Apply Value 5 | In5Activ | F | 0 = No
 |  |  | 1 = Yes
Apply Value 6 | In6Activ | F | 0 = No
 |  |  | 1 = Yes
Apply Value 7 | In7Activ | F | 0 = No
 |  |  | 1 = Yes
Apply Value 8 | In8Activ | F | 0 = No
 |  |  | 1 = Yes
Apply Value 9 | In9Activ | F | 0 = No
 |  |  | 1 = Yes
Apply Value 10 | In10Activ | F | 0 = No
 |  |  | 1 = Yes
Maximum value | Maximum | R |
Average value | Average | R |
Minimum value | Minimum | R |
Output 1 | Out1Sel | R | 0 = Minimum
 |  |  | 1 = Average
 |  |  | 2 = Maximum
... Value | Out1Val | R |
Output 2 (s) | Out2Sel | R | 0 = Minimum
 |  |  | 1 = Average
 |  |  | 2 = Maximum
... Value | Out2Val | R |


Analog as Digital

Family: | DDC 2.5 Analogue values
Name: | Analog as Digital
Macro: | _DDC_ANAD250
Version: | 2.5.000

Description

Can be used as a 2-point controller or threshold switch. Main application area was the PCS1, as analogue inputs are frequently used as digital inputs.

Input |
A | Analog value which is to be assessed as digital value

Output |
D | Status of the emulated digital value

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
Limit value High | Threshold value for Sigal High
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Limit value Low | Threshold value for Sigal Low
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Status | Status of the digital value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Inactive text | Text with status [Low]
- Active text | Text with status [High]
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
[ --- Definitions --- ] |
Unit | Unit
COV Hysteresis | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
[ --- DDC Suite V 2.5 --- ] |

Functional

If the input value is above the limit value High, a High signal is issued at the output. If the input signal falls below the limit value Low, a Low signal is issued at the output. If the input signal lies between the limit values, there is no status change of the output.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Limit values | AV | - | Upper limit value
Limit values | AV | - | Lower limit value
Limit value and status | BI - | Status of the determined digital value |

Predefined

Limit value High | High | R |
Limit value Low | Low | R |
Status | Status | F | 0 = Low
 |  |  | 1 = High


Counter

Family: | DDC 2.5 Analogue values
Name: | Counter
Macro: | _DDC_ANCOUNT250
Version: | 2.5.000

Description

Recording of a counter pulse via a digital input. Beforehand, the FBox "Zklische Aufgabe installieren" from the standard library should be set

Input |
Imp | Direct digital input or hard addressed flag of the impulse transmitter

Output |
Val | Current count
Res | Current residual value
LastVal | Last stored count
LastRes | Last stored residual value

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- History --- ] |
Store in every (month) | Selection in which month the count/ residual value should be stored
Storing every x. of the month | Day of the month of storing
Last count | Stored count
Last residual | Stored residual value
[ --- Current --- ] |
XOB-Number | Selection in which cyclical task the count should be integrated
Impulse factor | Impulse factor for converting the count impulses in the physical quantity
Reduction factor | Reduction factor for enlarging the counting area
Count | Current count
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Unit | Unit
COV Hysteresis | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Residual | Current residual value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Unit | Unit
COV Hysteresis | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
[ --- DDC Suite V 2.5 --- ] |

Functional

The counter connected on the input Imp is included and evaluated. The value of the impulse can be set via the impulse factor. If, for example, a counter emits 23 impulses for a KWh, this value is to be entered.

Counted measurand for instance can be split up into MWh and KWh via a reduction factor. A reduction factor of 1000 is to be specified in this example. Then the counted measurand includes the MWh, the balance the KWh. If the reduction factor is 1, the value is directly incremented in the counted measurand, the remaining value is always 0.

The values can be cyclically saved. This can take place each month or in a certain month (=annual reading). A day can be specified for the month. The reading then takes place at midnight.

Attention! On the input Imp, only a digital input or a flag with a permanent address is allowed to be directly connected.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Count | AV | - | Count value (higher value number range)
Count | TR | optional | Count value (higher value number range)
Count/Residual | AV | - | Remainder value (lower value number range)

Predefined

Store in every (month) | Month | R | 0 = each
 |  |  | 1 = January
 |  |  | 2 = February
 |  |  | 3 = March
 |  |  | 4 = April
 |  |  | 5 = May
 |  |  | 6 = June
 |  |  | 7 = July
 |  |  | 8 = August
 |  |  | 9 = September
 |  |  | 10 = October
 |  |  | 11 = November
 |  |  | 12 = December
Storing every x. of the month | Day | R | 1..31
Last count | StoredCount | R |
Last residual | StoredResid | R |
Impulse factor | ImpFactor | R |
Reduction factor | RedFactor | R |
Count | CountedVal | R |
Residual | ResidualVal | R |


DDC 2.5 Controls

Version: 2.5.000

Motor 1 speed

Motor 2 speed

Motor 3 speed

Pump

Drive Open/ Closed

Drive continous

Boiler 1.3


Motor 1 speed

Family: | DDC 2.5 Controls
Name: | Motor 1 speed
Macro: | _DDC_COMOT1SP250
Version: | 2.5.000

Description

Motor control of a 1-stage drive.

Input |
En | start motor
fb | feedback
Ala | Switching off alarm - block motor

Output |
Run | Inticates motor should run
CntH | Counter operating hours
CntFb | Counter feedback (input fb)
Mt | Mainenance necessary

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Alarm administration (Index) | Controls whether the alarms in an SWeb alarm list are registered. 0 = No, -1 = Alarm number assigned automatically, >0 = fixed (start) alarm number. (FBox Alarm SWeb/AlarmHdr)
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
Digital output | Digital output motor
HMI Higher prio | Mode HMI higher priority
HMI Lower prio | Mode HMI lower priority
Start delay (s) | Delay from start command to activation of motor
Requested mode | Display requestet motor state
Output | Display if motor should run
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Notification-class |
Feedback | Corresponds to the input fb = feedback
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Maintenance message | Message mainenenace neccessary
... Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
Motor status | Motor blocked due to alarm
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
[ --- Counting --- ] |
Feedback | Number of feedback on
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Message after feedback | Number of feedback on until message maintenance appears
Hours | Number of operating hours
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Message after hours | Number of operating hours until message maintenance appears
[ --- DDC Suite V 2.5 --- ] |

Functional

Control of a 1-stage motor. The control has 3 levels:

1. Level : Manual switch, Parameter HMI high prior

As it is rarely available, this is not connected here (it means no FBox inputs available), but can be enforced by describing the data point. This switch has the positions Off - Auto - On. The position is set on "Auto" one time after the programme download.

If there is no manual switch available, this parameter can be used for instance for a higher level virtual operation.

If BACnet is activated, this parameter cannot be used otherwise. This parameter then shows Auto, if the resulting system enabling of BACnet is identical with the requirement (regardless of whether the system should be Off or On). If a different operating mode is enforced through BACnet, the corresponding status is displayed (e.g. On or Off)

2. Level : BC switch, Parameter HMI low prior

Effective only if the manual control switch is on Auto. This switch has the positions Off - Auto - On.

This parameter is normally used in the virtual operation in a SCADA (ViSi.Plus) or WebPanel.

3. Level : Automatic requirements

Effective only if the manual control switch and the building control switch are in auto mode. The start command for the drive is to be attached at the input "En".

Operating data / Maintenance

A metering of the operating hours and the switching cycles take place. When it reaches the set maximum value, a warning signal is issued. This can be reset via a central acknowledgement (see FBox "InitLib") or separately and only for this drive.

The input "fb" is to be connected with a proper feedback signal as the metering monitors this input and not the output "Out" - as one cannot be sure here whether the drive actually runs. If no physical input is available, this should be emulated, e.g. through feedback of the output "Out" via an auxiliary connector.

Output contacts

The output "Run" indicates the status which the physical output should adopt. For this purpose, as a rule, a connector with the address of the digital output is connected. Alternatively, this digital output can also be defined in the FBox itself. In the process, the address "-1" indicates that the FBox should not activate an output.

As soon as an address is stated between 0 and 1023 (= physical output address), the FBox activates the parameterised output.

System function alarm management

The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.

Index Maintenance signal

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
HMI | BO | Commandable | Switching function Auto/Off/On
HMI/fb | BI | - | Feedback (not if NC in used in HMI)
HMI/fb/Mt | BI | Alarm | Maintenance signal
HMI/fb/Mt | BI | Alarm | Alarm
HMI/fb/Mt/CntH | AV | - | Operating hours
HMI/fb/Mt/CntH/CntFb | AV | - | Circuits

Predefined

Digital output | RequiredDO | R | -1..1023
HMI Higher prio | ModeHiPri | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = On
HMI Lower prio | ModeLoPri | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = On
Start delay (s) | StartDelay | R | 0..36000
Requested mode | Demand | F | 0 = Off
 |  |  | 1 = On
Output | Required | F | 0 = Off
 |  |  | 1 = On
Feedback | Feedback | F | 0 = Off
 |  |  | 1 = On
Maintenance message | Maintenance | F | 0 = Off
 |  |  | 1 = On
Motor status | GrpAla | F | 0 = ok
 |  |  | 1 = BLOCKED
Feedback | EnCnt | R | 0..2000000000
Message after feedback | EnCntMax | R | 0..2000000000
Hours | HrsCnt | R | 0..2000000000
Message after hours | HrsCntMax | R | 0..2000000000


Motor 2 speed

Family: | DDC 2.5 Controls
Name: | Motor 2 speed
Macro: | _DDC_COMOT2SP250
Version: | 2.5.000

Description

Motor control of a 2-stage drive.

Input |
En1 | start motor speed 1
En2 | start motor speed 2
fb1 | feedback speed 1
fb2 | feedback speed 2
Ala | Switching off alarm - block motor

Output |
Run1 | Inticates motor should run in speed 1
Run2 | Inticates motor should run in speed 2
CntH | Counter operating hours
CntFb | Counter feedback (input fb)
Mt | Mainenance necessary

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Alarm administration (Index) | Controls whether the alarms in an SWeb alarm list are registered. 0 = No, -1 = Alarm number assigned automatically, >0 = fixed (start) alarm number. (FBox Alarm SWeb/AlarmHdr)
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
Digital output speed 1 | Digital output motor speed 1
Digital output speed 2 | Digital output motor speed 2
HMI Higher prio | Mode HMI higher priority
HMI Lower prio | Mode HMI lower priority
Start delay Sec. | Delay from start command to activation of motor
Delay St1>St2 | Minimum duration until 1->2 possible
Delay St2>St1 | Run out time until approval 2 -> 1
Requested mode | Display requested motor state
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
Feedback | Corresponds to the input fb1/2 = feedback
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Maintenance messge | Medssage maintenance neccessary
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
Motor status | Motor blocked due to alarm
[ --- Counting --- ] |
<--- BACnet Object common ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Feedback speed 1 | Number of feedback on speed 1
<--- BACnet Object-Name ---> | Suffix of Object Name
Feedback speed 2 | Number of feedback on speed 2
<--- BACnet Object-Name ---> | Suffix of Object Name
Message after feedback | Number of feedback on until message maintetance appears
<--- BACnet Object common ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Hours speed 1 | Number of operating hours speed 1
<--- BACnet Object-Name ---> | Suffix of Object Name
Hours speed 2 | Number of operating hours speed 2
<--- BACnet Object-Name ---> | Suffix of Object Name
Message after hours | Number of operating hours until message meintenance appears
[ --- DDC Suite V 2.5 --- ] |

Functional

Control of a 2-stage motor. The control has 3 levels:

1. Level : Manual switch, Parameter HMI high prior

As it is rarely available, this is not connected here (it means no FBox inputs available), but can be enforced by describing the data point. This switch has the positions Off - Auto -Stage 1 - Stage 2. The position is set one-time on "Auto" after programme download.

If there is no manual switch available, this parameter can be used for instance for a higher level virtual operation.

If BACnet is activated, this parameter cannot be used otherwise. This parameter then shows Auto, if the resulting system enabling of BACnet is identical with the requirement (regardless of whether the system should be Off or On). If a different operating mode is enforced through BACnet, the corresponding status is displayed (e.g. On or Off)

2. Level : BC switch, Parameter HMI low prior

Effective only if the manual control switch is on Auto. This switch has the positions Off - Auto - stage 11 - stage 2.

This parameter is normally used in the virtual operation in a SCADA (ViSi.Plus) or WebPanel.

3. Level : Automatic requirements

Effective only if the manual control switch and the building control switch are in auto mode. The start command for the drive is to be attached at the input "En".

Operating data / Maintenance

A metering of the operating hours and the switching cycles take place. When it reaches the set maximum value, a warning signal is issued. This can be reset via a central acknowledgement (see FBox "InitLib") or separately and only for this drive.

The input "fb" is to be connected with a proper feedback signal as the metering monitors this input and not the output "Run" - as one cannot be sure here whether the drive actually runs. If no physical input is available, this should be emulated, e.g. through feedback of the output "Run" via an auxiliary connector.

Switching delays

After enabling of the drive ("En", mandatorily required), the stage 1 is turned on after the completion of the start delay. With the switching on of stage 1, the delay Sp1-Sp2 starts.

The upshift to stage 2, if need be, takes place only at the end of this delay. Only one of the two outputs St1 and/or St2 is turned on at a time.

During upshift to stage 1, the output Sp1 is turned off first. The output Sp2 turns on after half a second.

During downshift, the output Sp2 is first turned off. Then the output Sp1 is turned on after the re-switch delay.

Output contacts

The output "Run1/Run2" indicates the status which the physical output should adopt. For this purpose, as a rule, a connector with the address of the digital output is connected. Alternatively, this digital output can also be defined in the FBox itself. In the process, the address "-1" indicates that the FBox should not activate an output.

As soon as an address is stated between 0 and 1023 (= physical output address), the FBox activates the parameterised output.

System function alarm management

The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.

Index Maintenance signal

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
HMI | MO | Commandable | Switching function Auto/Off/Stage 1/Stage 2
HMI/fb | MI | - | Feedback (not if NC in used in HMI)
HMI/fb/Mt | BI | Alarm | Maintenance signal
HMI/fb/Mt/CntH | AV | - | Operating hours Stage 1
HMI/fb/Mt/CntH | AV | - | Operating hours Stage 2
HMI/fb/Mt/CntH/CntFb | AV | - | Circuits Stage 1
HMI/fb/Mt/CntH/CntFb | AV | - | Circuits Stage 2

Predefined

Digital output speed 1 | RequiredSp1DO | R | -1..1023
Digital output speed 2 | RequiredSp2DO | R | -1..1023
HMI Higher prio | ModeHiPri | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = Speed 1
 |  |  | 4 = Speed 2
HMI Lower prio | ModeLoPri | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = Speed 1
 |  |  | 4 = Speed 2
Start delay Sec. | StartDelay | R | 0..36000
Delay St1>St2 | DelaySp2 | R | 0..36000
Delay St2>St1 | DelaySp1 | R | 0..36000
Requested mode | Demand | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = Speed 1
 |  |  | 4 = Speed 2
Feedback | Feedback | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = Speed 1
 |  |  | 4 = Speed 2
Maintenance messge | Maintenance | F | 0 = Off
 |  |  | 1 = On
Motor status | GrpAla | F | 0 = ok
 |  |  | 1 = BLOCKED
Feedback speed 1 | EnCntSp1 | R |
Feedback speed 2 | EnCntSp2 | R |
Message after feedback | EnCntMax | R |
Hours speed 1 | HrsCntSp1 | R |
Hours speed 2 | HrsCntSp2 | R |
Message after hours | HrsCntMax | R |


Motor 3 speed

Family: | DDC 2.5 Controls
Name: | Motor 3 speed
Macro: | _DDC_COMOT3SP250
Version: | 2.5.005

Description

Motor control of a 3-stage drive.

Input |
En1 | start motor speed 1
En2 | start motor speed 2
En3 | start motor speed 3
fb1 | feedback speed 1
fb2 | feedback speed 2
fb3 | feedback speed 3
Ala | Switching off alarm - block motor

Output |
Run1 | Inticates motor should run in speed 1
Run2 | Inticates motor should run in speed 2
Run3 | Inticates motor should run in speed 3
CntH | Counter operating hours
CntFb | Counter feedback (input fb)
Mt | Mainenance necessary

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Alarm administration (Index) | Controls whether the alarms in an SWeb alarm list are registered. 0 = No, -1 = Alarm number assigned automatically, >0 = fixed (start) alarm number. (FBox Alarm SWeb/AlarmHdr)
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
Digital output speed 1 | Digital output motor speed 1
Digital output speed 2 | Digital output motor speed 2
Digital output speed 3 | Digital output motor speed 3
HMI Higher prio | Mode HMI higher priority
HMI Lower prio | Mode HMI lower priority
Start delay Sec. | Delay from start command to activation of motor
Minimum delay 1>2 or 2>3 | Minimum duration until 1->2 or 2->3 possible
Delay 3>2 or 2>1 | Run out time until approval 3->2 or 2 -> 1
Requested mode | Display if motor should run
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
Feedback | Corresponds to the input fb1/2/3 = feedback
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Maintenance messge | Message mainenance neccessary
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
Motor status | Motor blocked due to alarm
[ --- Counting --- ] |
<--- BACnet Object common ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Feedback speed 1 | Number of feedback on speed 1
<--- BACnet Object-Name ---> | Suffix of Object Name
Feedback speed 2 | Number of feedback on speed 2
<--- BACnet Object-Name ---> | Suffix of Object Name
Feedback speed 3 | Number of feedback on speed 3
<--- BACnet Object-Name ---> | Suffix of Object Name
Message after feedback | Number of feedback on until message maintenance appears
<--- BACnet Object common ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Hours speed 1 | Number of operating hours speed 1
<--- BACnet Object-Name ---> | Suffix of Object Name
Hours speed 2 | Number of operating hours speed 2
<--- BACnet Object-Name ---> | Suffix of Object Name
Hours speed 3 | Number of operating hours speed 3
<--- BACnet Object-Name ---> | Suffix of Object Name
Message after hours | Number of operating hours until message maintenance appears
[ --- DDC Suite V 2.5 --- ] |

Functional

Control of a 3-stage motor. The control has 3 levels:

1. Level : Manual switch, Parameter HMI high prior

As it is rarely available, this is not connected here (it means no FBox inputs available), but can be enforced by specifying the data point. This switch has the positions Off - Auto -Stage 1 - Stage 2 - Stage 3. The position is set one-time on "Auto" after programme download.

If there is no manual switch available, this parameter can be used for instance for a higher level virtual operation.

If BACnet is activated, this parameter cannot be used otherwise. This parameter then shows Auto, if the resulting system enabling of BACnet is identical with the requirement (regardless of whether the system should be Off or On). If a different operating mode is enforced through BACnet, the corresponding status is displayed (e.g. On or Off)

2. Level : BC switch, Parameter HMI low prior

Effective only if the manual control switch is on Auto. This switch has the positions Off - Auto - stage 1 - stage 2 - stage 3.

This parameter is normally used in the virtual operation in a SCADA (ViSi.Plus) or WebPanel.

3. Level : Automatic requirements

Effective only if the manual control switch and the building control switch are in auto mode. The start command for the drive is to be attached at the input "En".

Operating data / Maintenance

A metering of the operating hours and the switching cycles take place. When it reaches the set maximum value, a warning signal is issued. This can be reset via a central acknowledgement (see FBox "InitLib") or separately and only for this drive.

The input "fb" is to be connected with a proper feedback signal as the metering monitors this input and not the output "Run" - as one cannot be sure here whether the drive actually runs. If no physical input is available, this should be emulated, e.g. through feedback of the output "Run" via an auxiliary connector.

Switching delays

After enabling of the drive ("En", mandatorily required), the stage 1 is turned on after the completion of the start delay. With the switching on of stage 1, the delay Sp1-Sp2 starts.

The upshift to stage 2, if need be, takes place only at the end of this delay. Only one of the two outputs Sp1 and/or Sp2 is turned on at a time.

During upshift to stage 1, the output Run1 is first of all turned off. The output Run2 turns on after half a second.

During downshift, the output Run2 is first turned off. Then the output Run1 is turned on after the re-switch delay.

The same applies to the shift from stage 2 to stage 3 and back.

Output contacts

The output "Run1/Run2/Run3" gives the status to the physical output that should agree. For this purpose, as a rule, a connector with the address of the digital output is connected. Alternatively, this digital output can also be defined in the FBox itself. In the process, the address "-1" indicates that the FBox should not activate an output.

As soon as an address is stated between 0 and 1023 (= physical output address), the FBox activates the parameterised output.

System function alarm management

The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.

Index Maintenance signal

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
HMI | MO | Commandable | Switching function Auto/Off/Stage 1/Stage 2/Stage 3
HMI/fb | MI | - | Feedback (not if NC in used in HMI)
HMI/fb/Mt | BI | Alarm | Maintenance signal
HMI/fb/Mt/CntH | AV | - | Operating hours Stage 1
HMI/fb/Mt/CntH | AV | - | Operating hours Stage 2
HMI/fb/Mt/CntH | AV | - | Operating hours Stage 3
HMI/fb/Mt/CntH/CntFb | AV | - | Circuits Stage 1
HMI/fb/Mt/CntH/CntFb | AV | - | Circuits Stage 2
HMI/fb/Mt/CntH/CntFb | AV | - | Circuits Stage 3

Predefined

Digital output speed 1 | RequiredSp1DO | R | -1..1023
Digital output speed 2 | RequiredSp2DO | R | -1..1023
Digital output speed 3 | RequiredSp3DO | R | -1..1023
HMI Higher prio | ModeHiPri | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = Speed 1
 |  |  | 4 = Speed 2
 |  |  | 5 = Speed 3
HMI Lower prio | ModeLoPri | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = Speed 1
 |  |  | 4 = Speed 2
 |  |  | 5 = Speed 3
Start delay Sec. | StartDelay | R | 0..36000
Minimum delay 1>2 or 2>3 | DelaySp2 | R | 0..36000
Delay 3>2 or 2>1 | DelaySp1 | R | 0..36000
Requested mode | Demand | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = Speed 1
 |  |  | 4 = Speed 2
 |  |  | 5 = Speed 3
Feedback | Feedback | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = Speed 1
 |  |  | 4 = Speed 2
 |  |  | 5 = Speed 3
Maintenance messge | Maintenance | F | 0 = Off
 |  |  | 1 = On
Motor status | GrpAla | F | 0 = ok
 |  |  | 1 = BLOCKED
Feedback speed 1 | EnCntSp1 | R |
Feedback speed 2 | EnCntSp2 | R |
Feedback speed 3 | EnCntSp3 | R |
Message after feedback | EnCntMax | R |
Hours speed 1 | HrsCntSp1 | R |
Hours speed 2 | HrsCntSp2 | R |
Hours speed 3 | HrsCntSp3 | R |
Message after hours | HrsCntMax | R |


Pump

Family: | DDC 2.5 Controls
Name: | Pump
Macro: | _DDC_COPUMP250
Version: | 2.5.005

Description

Motor control of a 1-stage drive with anti-block protection function

Input |
En | start pump
fb | feedback
Ala | Switching off alarm - block pump
Y | signal continous drive

Output |
Run | Inticates pump should run
CntH | Counter operating hours
CntFb | Counter feedback (input fb)
Mt | Mainenance necessary

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Alarm administration (Index) | Controls whether the alarms in an SWeb alarm list are registered. 0 = No, -1 = Alarm number assigned automatically, >0 = fixed (start) alarm number. (FBox Alarm SWeb/AlarmHdr)
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
Digital output | Digital output
HMI Higher prio | Mode HMI higher priority
HMI Lower prio | Mode HMI lower priority
turn-off delay (s) | Turn off delay
Use antiblock protection | Mode antiblock protection function
[ --- Demand --- ] |
Outside temperature | Mode function of outside air temperature
... limit value | Limit for outside air temperature
Signal input Y | Mode function of control signal
... limit value | Limit of the control signal
Demand acc. to outside temp. | Display demand for outside temperature function
Demand from input Y | Display demand for control signal function
[ ---Status --- ] |
Required mode | Display requested pump state
Output | Display if pump should run
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
Feedback | Corresponds to the input fb = feedback
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Maintenance messge | Message maintenance neccessary
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
Motor status | Motor blocked due to alarm
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
[ --- Counting --- ] |
Feedback | Number of feedback on
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Message after feedback | Number of switchings on until message maintenance appears
Hours | Number of operating hours
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Message after hours | Number of operating hours until message maintenance appears
[ --- DDC Suite V 2.5 --- ] |

Functional

Control of a 1-stage motor, normally for a circulation pump. The control has 3 levels:

1. Level : Manual switch, Parameter HMI high prior

As it is rarely available, this is not connected here (it means no FBox inputs available), but can be enforced by describing the data point. This switch has the positions Off - Auto - On. The position is set on "Auto" one time after the programme download.

If there is no manual switch available, this parameter can be used for instance for a higher level virtual operation.

If BACnet is activated, this parameter cannot be used otherwise. This parameter then shows Auto, if the resulting system enabling of BACnet is identical with the requirement (regardless of whether the system should be Off or On). If a different operating mode is enforced through BACnet, the corresponding status is displayed (e.g. On or Off)

2. Level : BC switch, Parameter HMI low prior

Effective only if the manual control switch is on Auto. This switch has the positions Off - Auto - On.

This parameter is normally used in the virtual operation in a SCADA (ViSi.Plus) or WebPanel.

3. Level : Automatic requirements

Effective only if the manual control switch and the building control switch are in auto mode. There are 2 automatic requests:

- Input "En", the start command for the drive is to be attached here.

- Requirement, in which the requirement can be parameterised through 2 causes, according to outside air temperature (smaller/greater limit value or inactive) and/or signal requirement (typically valve position).

Both automatic requirements have equal rights, which means a logical OR.

Operating data / Maintenance

A metering of the operating hours and the switching cycles take place. When it reaches the set maximum value, a warning signal is issued. This can be reset via a central acknowledgement (see FBox "InitLib") or separately and only for this drive.

The input "fb" is to be connected with a proper feedback signal as the metering monitors this input and not the output "Run" - as one cannot be sure here whether the drive actually runs. If no physical input is available, this should be emulated, e.g. through feedback of the output "Run" via an auxiliary connector.

Output contacts

The output "Run" gives the status to the physical output that should agree. For this purpose, as a rule, a connector with the address of the digital output is connected. Alternatively, this digital output can also be defined in the FBox itself. In the process, the address "-1" indicates that the FBox should not activate an output.

As soon as an address is stated between 0 and 1023 (= physical output address), the FBox activates the parameterised output.

System function alarm management

The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.

Index Maintenance signal

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
HMI | BO | Commandable | Switching function Auto/Off/On
HMI/fb | BI | - | Feedback (not if NC in used in HMI)
HMI/fb/Mt | BI | Alarm | Maintenance signal
HMI/fb/Mt | BI | Alarm | Alarm
HMI/fb/Mt/CntH | AV | Alarm | Operating hours
HMI/fb/Mt/CntH/CntFb | AV | - | Circuits

Predefined

Digital output | RequiredDO | R | -1..1023
HMI Higher prio | ModeHiPri | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = On
HMI Lower prio | ModeLoPri | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = On
turn-off delay (s) | TurnOffDelay | R | 0..36000
Use antiblock protection | AntiBlock | R | 0 = No
 |  |  | 1 = Yes
 |  |  | 2 = Inactiv
Outside temperature | DemToMode | R | 1 = without function
 |  |  | 2 = lower than
 |  |  | 3 = higher than
... limit value | DemToLim | R | -1000..1000
Signal input Y | DemYMode | R | 1 = Y without funct.
 |  |  | 2 = or Y >
 |  |  | 3 = and Y >
... limit value | DemYLim | R | 30..1000
Demand acc. to outside temp. | DemTo | F | 0 = Off
 |  |  | 1 = On
Demand from input Y | DemY | F | 0 = Off
 |  |  | 1 = On
Required mode | Demand | F | 0 = Off
 |  |  | 1 = On
Output | Required | F | 0 = Off
 |  |  | 1 = On
Feedback | Feedback | F | 0 = Off
 |  |  | 1 = On
Maintenance messge | Meintenance | F | 0 = Off
 |  |  | 1 = On
Motor status | GrpAla | F | 0 = ok
 |  |  | 1 = BLOCKED
Feedback | EnCnt | R | 0..2000000000
Message after feedback | EnCntMax | R | 0..2000000000
Hours | HrsCnt | R | 0..2000000000
Message after hours | HrsCntMax | R | 0..2000000000


Drive Open/ Closed

Family: | DDC 2.5 Controls
Name: | Drive Open/ Closed
Macro: | _DDC_COOPENCLOSE250
Version: | 2.5.001

Description

Control of a 2-point drive (typically flap drive Open/Close) with anti-block protection function.

Input |
En | open drive
fbO | feedback drive open
fbC | feedback drive closed
Ovr | Override, Forced override
man | contact manual operation

Output |
Up | Activation Open
GrpAla | Group alarm feedback missing
AlaO | Alarm no feedback open
AlaC | Alarm no feedback closed
[fbO!] | Feedback open (emulated or hardware)
[fbC!] | Feedback Closed (emulated or hardware)
[man] | Manual operation

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Alarm administration (Index) | Controls whether the alarms in an SWeb alarm list are registered. 0 = No, -1 = Alarm number assigned automatically, >0 = fixed (start) alarm number. (FBox Alarm SWeb/AlarmHdr)
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Switching --- ] |
Digital output | Digital output
HMI Higher prio | HMI higher priority
HMI Lower prio | HMI lower priority
Use antiblock protection | Mode antiblock protection function
Compulsory override forced | Mode on forced override
Messages Open/ Closed | Feedbacks are available or are emulated
turn-off delay (s) | Turn-off delay
[ --- Statuses --- ] |
Forced override | Display forced override active
Required | Requested state close/open
Output | Signa on output Up
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
[ --- Manual operation--- ] |
Digital input | Digital Input manual operation
Normal input state | Selection of the normal status of the hand switch
Alarm suppression | Associated voltage group for suppressing ghost messages on voltage shortage
ALARM status | Alarm manual override active
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
[ --- Feedback --- ] |
Feedback | Feedback
<--- BACnet common ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Notification-class |
<--- BACnet Object-Name ---> | Suffix of Object Name
Digital input feedback Open | Digital input feedback open
Digital input feedback Closed | Digital input feedback closed
Operating period | Run time of the drive from 0 to 100
Acknowledgement mandatory | Selection of the mandatory acknowledgement on setting feedback violation
Alarm suppression | Associated voltage group for suppressing ghost messages on voltage shortage
Alarm no feedback Open | Alarm feedback Open missing
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Suffix of Object Name
Alarm no feedback closed | Alarm feedback Closed missing
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Suffix of Object Name
Delay in monitoring... | Remaining run time
[ --- DDC Suite V 2.5 --- ] |

Functional

Drive 2-point (flap drive) with potential position feedback, enforced override, anti-block protection and manual override.

1. Level : Manual switch, Parameter HMI high prior

As it is rarely available, this is not connected here (it means no FBox inputs available), but can be enforced by describing the data point. This switch has the positions Close - Auto - Open. The position is set on "Auto" one time after the programme download.

If there is no manual switch available, this parameter can be used for instance for a higher level virtual operation.

If BACnet is activated, this parameter cannot be used otherwise. This parameter then shows Auto, if the resulting system enabling of BACnet is identical with the requirement (regardless of whether the drive should be Open or On). If a different operating mode is enforced through BACnet, the corresponding status is displayed (e.g. Open or Close)

2. Level : BC switch, Parameter HMI low prior

Effective only if the manual control switch is on Auto. This switch has the positions Close - Auto - Open.

This parameter is normally used in the virtual operation in a SCADA (ViSi.Plus) or WebPanel.

3. Level : Automatic requirements

Effective only if the manual control switch and the building control switch are in auto mode. There are 2 automatic requirements:

General functions

In case of an enforced override (input "Ovr"), how the drive should be controlled can be specified.

The drive can be provided with a turn-off delay. This is for instance required in flap drives with spring return, as they close faster than the fans run out.

An anti-block protection can be set. This controls the drive for the duration of the operating time with Open. The mechanism of the anti-block protection is centrally defined. See initialisation family, anti-block protection FBox.

The feedback signals can be directly connected. If there is no position feedback available, this can be emulated through FBox (e.g. for the Start Ventilation FBox). The control is compared with the feedbacks. If the corresponding feedback is missing after the end of the operating time, an error signal is issued.

Input contacts

The input contacts to be monitored can be connected to the inputs of the FBox or alternatively in the FBox itself. In the process, the address "-1" indicates that the FBox should use the input contact of the FBox input.

As soon as an address is stated between 0 and 1023 (= physical input address), the FBox input is inactive and can be arbitrarily connected with "L" ort "H". The FBox independently reads out the parameterised input and monitors it.

As the input would not be visible at starting up, the outputs of the FBox reflects the corresponding input status in square brackets "[]", regardless of whether it is from the FBox input or from the physical input directly read out from the FBox. However, this is always the physical status of the input. An optional inversion is not executed here.

Output contacts

The output "Out" gives the status to the physical output that should agree. For this purpose, as a rule, a connector with the address of the digital output is connected. Alternatively, this digital output can also be defined in the FBox itself. In the process, the address "-1" indicates that the FBox should not activate an output.

As soon as an address is stated between 0 and 1023 (= physical output address), the FBox activates the parameterised output.

System function Offline Trending

The feedback (Close/Open/Runs) can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function alarm management

The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.

Index | Feedback Open absent
Index 1 | Feedback Close absent
Index 2 | Manual intervention

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
HMI | BO | Commandable | Control function output
HMI | TR | optional | Control function output
HMI/fb | BI | - | Feedback (not if NC is used in HMI)
HMI/fb/AlaO C | BI | Alarm | Feedback Open absent
HMI/fb/AlaO C | BI | Alarm | Feedback Close absent
HMI/fb/AlaO C/AlaMan | BI | Alarm | Manual intervention

Predefined

Digital output | RequestedDO | R | -1..1023
HMI Higher prio | ModeHiPri | R | 1 = Automatic
 |  |  | 2 = Close
 |  |  | 3 = Open
HMI Lower prio | ModeLoPri | R | 1 = Automatic
 |  |  | 2 = Close
 |  |  | 3 = Open
Use antiblock protection | AntiBlock | R | 0 = No
 |  |  | 1 = Yes
 |  |  | 2 = Inactive
Compulsory override forced | BetriebZwang | F | 0 = Close
 |  |  | 1 = Open
Messages Open/ Closed | FbType | F | 0 = Hardware
 |  |  | 1 = Emulate
turn-off delay (s) | TurnOffDelay | R | 0..36000
Forced override | OvrActive | F | 0 = Off
 |  |  | 1 = active
Required | Demand | F | 0 = Close
 |  |  | 1 = Open
Output | Requested | F | 0 = Close
 |  |  | 1 = Open
Digital input | ManDITerm | R | -1..1023
Normal input state | ManNoNc | F | 0 = opened
 |  |  | 1 = Closed
Alarm suppression | ManVoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230VAC
 |  |  | 3 = 24 AC
 |  |  | 4 = 24VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Control volt.
ALARM status | ManAla | F | 0 = ok
 |  |  | 1 = ALARM
Feedback | Feedback | R | 1 = Closed
 |  |  | 2 = running..
 |  |  | 3 = Open
Digital input feedback Open | FbOpenDITerm | R | -1..1023
Digital input feedback Closed | FbClosedDITerm | R | -1..1023
Operating period | RunTime | R | 0..36000
Acknowledgement mandatory | FbMbAck | F | 0 = No
 |  |  | 1 = Yes
Alarm suppression | FbVoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Alarm no feedback Open | FbOpenAla | F | 0 = ok
 |  |  | 1 = ALARM
Alarm no feedback closed | FbCloseAla | F | 0 = ok
 |  |  | 1 = ALARM
Alarm no feedback closed | FbCloseAla | F | 0 = ok
 |  |  | 1 = ALARM


Drive continous

Family: | DDC 2.5 Controls
Name: | Drive continous
Macro: | _DDC_COCONTINOUS250
Version: | 2.5.001

Description

Control of a continuous drive with anti-block protection function.

Input |
Y | Signal
Yfb | Signal feedback
Ovr | Override, Forced override
man | contact manual operation

Output |
Y | Activation of drive (0 - 100
Yinv | Activation of drive Invers (100 - 0
GrpAla | Group alarm feedback to high/low
AlaHigh | Alarm feedback to high
AlaLow | Alarm feedback to low
[man] | Manual operation

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
PCD Alarm administration (Index) | Controls whether the alarms in an SWeb alarm list are registered. 0 = No, -1 = Alarm number assigned automatically, >0 = fixed (start) alarm number. (FBox Alarm SWeb/AlarmHdr)
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Switching --- ] |
HMI | Mode function continuous drive for HMI
Maual input | Signal, which is outputted on manual override
Use antiblock protection | Mode antiblock protection function
Override contact forceing | Signal, which is outputted if there is a High signal at the input Ovr
Signal inversion at output | Inverting the signal at the outputs Y and YIn
[ --- Manual operation--- ] |
Digital input | Digital Input manual operation
Normal input statue | Selection of the normal status of the hand switch
Alarm suppression | Associated voltage group for suppressing ghost messages on voltage shortage
Alarm status | Alarm manual override active
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
- High Limit | Upper threshold leading to an alarm message.
- Low Limit | Lower threshold leading to an alarm message.
- Deadband | Dead band, applies for upper/lower threshold when switching back to normal state.
- Limit Enable | Select which threshold violation should be enabled.
[ --- Statuses --- ] |
Forced override | Display forced override active
Requirement from Input Y | Signal, which comes from control
Resultant required Y | Requirement signal from FBox functionality
Output Y | Signal, which is outputted
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Output Yinv | Signal, inverted, which is outputted
[ --- Feedback --- ] |
Feedback in | Calculated value of feedback
<--- BACnet common ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Notification-class | Notification Class to be used. A Notification Class must be created with the number indicated (FBox NC) as the defaults are used from there. The value -1 disables Intrinsic Reporting.
<--- BACnet Object-Name ---> | Suffix of Object Name
Feedback on input Yfb | Selection whether a hardware feedback is available
Raw value minimum | Minimum raw value of feedback
Raw value maximum | Minimum raw value of feedback
Operating period | Run time of the drive from 0 to 100
Hysteresis feedback | Tolerance between signal and feedback for the monitoring
Acknowledgement mandatory | Selection of the mandatory acknowledgement on setting feedback violation
Alarm suppression | Associated voltage group for suppressing ghost messages on voltage shortage
Alarm feedback to high | Alarm feedback to high
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Suffix of Object Name
Alarm feedback to low | Alarm feedback to low
Alarmtext | Alarmtext. Used when configuring for SWeb Alarming (AlmHeader + Alarming level 1-10 + Name + This text).
<--- BACnet Object-Name ---> | Suffix of Object Name
Delay in monitoring... | Remaining run time
[ --- Definitions --- ] |
Unit | Unit
COV Hysteresis | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
Phys. value min. | Minimum physical value
Phys. value max. | Maximum physical value
[ --- DDC Suite V 2.5 --- ] |

Functional

Continuous drive with potential position feedback, enforced override, anti-block protection and manual override.

The drive can be activated manually via an HMI switch. In case of an enforced override (input "Ovr"), the signal amplitude to be issued can be specified.

The outputs Y and Yinv are in opposite directions (e.g. to attach exhaust air and recirculating air flaps).

Anti-block protection

An anti-block protection can be set. This has 100ontrol of the drive for the duration of the operating time. The mechanism of the anti-block protection is centrally defined. See initialisation family, anti-block protection FBox.

Feedback monitoring

The feedback signal can be directly connected from an analogue input card. A conversion from 0 - 100akes place automatically. Only the input variables (raw value minimum and raw value maximum) are to be stated. The issued signal is compared with the feedback.

If the feedback signal lies outside the position hysteresis after the end of the operating time, an error signal is issued.

Input contacts

The input contacts to be monitored can be connected to the inputs of the FBox or alternatively in the FBox itself. In the process, the address "-1" indicates that the FBox should use the input contact of the FBox input.

As soon as an address is stated between 0 and 1023 (= physical input address), the FBox input is inactive and can be arbitrarily connected with "L" ort "H". The FBox independently reads out the parameterised input and monitors it.

As the input would not be visible at starting up, the outputs of the FBox in square brackets "[]" reflect the corresponding input status, regardless of whether the physical input is read out from the FBox input or directly from the FBox. However, this is always the physical status of the input. An optional inversion is not executed here.

System function Offline Trending

The control signal (output "Y") can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function alarm management

The two limit value monitorings can be integrated in the alarm management as soon as the alarm index is greater than 0.

Index | Feedback signal too high
Index 1 | Feedback signal too low
Index 2 | Manual intervention

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Y | AO | Commandable | Control function Output signal
Y | TR | optional | Control function Output signal
Y | AI | - | Feedback signal
Y/AlaHiLo | BI | Alarm | Feedback signal too high
Y/AlaHiLo | BI | Alarm | Feedback signal too low
Y/AlaHiLo/AlaMan | BI | Alarm | Manual intervention

Predefined

HMI | Mode | F | 0 = Automatic
 |  |  | 1 = Manual
Maual input | SignalMan | R | 0..1000
Use antiblock protection | AntiBlock | R | 0 = No
 |  |  | 1 = Yes
 |  |  | 2 = Inactive
Override contact forceing | SignalOvr | R | 0..1000
Signal inversion at output | Invert | F | 0 = No
 |  |  | 1 = Yes
Digital input | ManDITerm | R | -1..1023
Normal input statue | ManNoNc | F | 0 = Opened
 |  |  | 1 = Closed
Alarm suppression | ManVoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Control volt.
Alarm status | ManAla | F | 0 = ok
 |  |  | 1 = ALARM
Forced override | OvrActive | F | 0 = Off
 |  |  | 1 = active
Requirement from Input Y | SignalContr | R |
Resultant required Y | Demand | R |
Output Y | Signal | R |
Output Yinv | SignalInv | R |
Feedback in | FbSignal | R |
Raw value minimum | FbRawMin | R | 0..4095
Raw value maximum | FbRawMax | R | 0..4095
Operating period | RunTime | R | 0..36000
Hysteresis feedback | FbHyst | R | 0..1000
Acknowledgement mandatory | FbMbAck | F | 0 = No
 |  |  | 1 = Yes
Alarm suppression | FbVoltGrp | R | 0 = Never
 |  |  | 1 = for appl. vltg.
 |  |  | 2 = 230 VAC
 |  |  | 3 = 24 VAC
 |  |  | 4 = 24 VDC
 |  |  | 5 = Phase watch
 |  |  | 6 = Voltage monitoring.
Alarm feedback to high | FbHighAla | F | 0 = Off
 |  |  | 1 = ALARM
Alarm feedback to low | FbLowAla | F | 0 = Off
 |  |  | 1 = ALARM
Alarm feedback to low | FbLowAla | F | 0 = Off
 |  |  | 1 = ALARM


Boiler 1.3

Family: | DDC 2.5 Controls
Name: | Boiler 1.3
Macro: | _DDC_COBOILER240
Version: | 1.3.000

Description

Kesselsteuerung in Abhängigkeit von Schalthysteresen

Input |
SetPt | Set point inflow temperature
Value | Actual value of inflow temperature
En | Approval boiler
fb | Operational feedback Boiler
fbSeq | Operational feedback next stage or next boiler
GrpAla | Collective fault boiler

Output |
Run | Approval boiler
Seq | Approval next stage or next boiler
CntH | Operating hours:
CntFb | Switching operations
Mt | Service

Adjust |
Has next boiler /stage | Prefix whether boiler should request a next boiler / stage
[ --- Settings --- ] |
Prefix GLT | Prefix circuit for HMI or GLT
Delay in switching on again | For this period at least the boiler remains off after a switch off
Min.-running time | For this period at least the boiler remains active after a switch on
Min.-running time for next approval | The boiler must operate for this period before the next stage is demanded.
Min.-running time after next reswitching | For this period at least the boiler remains active after a reswitching the next stage
Switching on hysteresis [K] | Switching on hysteresis
Switch off hysteresis [K] | Switch off hysteresis
[ --- Statuses --- ] |
Set point | Set point inflow temperature
Actual value | Actual value of inflow temperature
Demand PWW | Status of the input Frg
Approval boiler | Activation of the boilder is done
Boiler operation | Operational feedback of the boiler
Approval of next boiler | Approval of next stage
Servicing messge | Servicing needed
Error | Boiler blocked due to fault(s)
[ --- Counting --- ] |
Switching operations | Number of switching-on
Message after switchings | Number of switchings on until servicing message appears
seconds | Number of operating seconds
Message after seconds | Number of operating seconds until servicing message appears
[ --- DDC Suite V 1.3 --- ] |

Functional

Steueurng eines Kessels. Über den Optionsschalter "Hat Kesselfolge" kann eine Folgestufe bzw. ein Folgekessel eingestellt werden. In diesem Fall fordert der Kessel bei Bedarf die nächste Stufe autotmatisch an.

Nach Anforderung des Kessels Frg wird der Kessel eingeschaltet, wenn der Istwert der Vorlauftemperatur kleiner dem Sollwert der Vorlauftemperatur abzüglich der Einschalthysterese ist. Wurde der Kessel kurz vorher ausgeschalten, kommt die Wiedereinschaltverzögerung noch zum zuge. Diese stellt sicher, das ein ständiges hin- und herschalten vermieden wird.

Nach Einschalten des Kessels (Kes) bleibt dieser mindestens für die Dauer der Min.-Laufzeit eingeschalten, auch wenn der Istwert ein Ausschalten des Kessels bedingen würde.

Zeitgleich mit dem Einschalten wird auch die Min.-Laufzeit bis Folgefreigabe gestartet. Ist der Istwert der Vorlauftemperatur noch unter dem Ausschaltgrenzwert, wird die Folgestufe (Fol) freigegeben. Liegt am Eingang BFo die Betriebsmeldung der Folgestufe bzw. des Folgekessels an, schaltet der Kessel nicht ab, auch wenn die Vorlauftemperatur die bedingen würde.

Nachdem die Meldung BFo zurückgesetzt wurde, wird der Kessel über die Dauer der Min.-Laufzeit nach Folgerückschaltung in Betrieb gehalten, auch wenn die Vorlauftemperatur ein Abschalten bedingen würde. Nach Ablauf der Verzögerung wird der Kessel bei Bedarf ausgeschalten, wenn der Istwert der Vorlauftemnperatur über dem Sollwert der Vorlauftemperatur abzüglich dem Ausschaltgrenzwert liegt.

Es erfolgt eine Zählung der Betriebsstunden und der Schaltspiele. Bei erreichen der eingestellten Maximalwerte wird eine Wartungsmeldung ausgegeben. Diese kann über eine Zentrale Quittierung zurückgesetzt werden (siehe FBox Bibliothek).

Die Zählung der Betriebsstunden erfolgt intern in Sekunden, am Ausgang Std werden Stunden ausgegeben.

Predefined

Has next boiler /stage | SecondStage | F | 0 = No
 |  |  | 1 = Yes
Prefix GLT | Mode | R | 0 = Off
 |  |  | 1 = AUTO
 |  |  | 2 = On
Delay in switching on again | MinOffTime | R | 0..36000
Min.-running time | MinOnTimet | R | 0..36000
Min.-running time for next approval | MinOnTimeStage | R | 0..36000
Min.-running time after next reswitching | MinOnTimeBack | R | 0..36000
Switching on hysteresis [K] | HystOn | R | -200..200
Switch off hysteresis [K] | HystOff | R | -200..200
Set point | SetPt | R |
Actual value | ContrVal | R |
Demand PWW | Required | F | 0 = Off
 |  |  | 1 = On
Approval boiler | Demand | F | 0 = Off
 |  |  | 1 = On
Boiler operation | Feedback | F | 0 = Off
 |  |  | 1 = On
Approval of next boiler | FeedbackStage | F | 0 = Off
 |  |  | 1 = On
Servicing messge | Maintenance | F | 0 = Off
 |  |  | 1 = On
Error | GrpAla | F | 0 = ok
 |  |  | 1 = Error
Switching operations | EnCnt | R |
Message after switchings | EnCntMax | R |
seconds | SecCnt | R |
Message after seconds | SecCntMax | R |


DDC 2.5 Controller

Version: 2.5.000

Controller

Limiter

Humidification

Dehumidification

Cooler

Mixed air

Heat recovery

Preheater

Re-heater

Master Cascade

Enable zone


Controller

Family: | DDC 2.5 Controller
Name: | Controller
Macro: | _DDC_LOController250
Version: | 2.5.000

Description

PID controller for general purposes.

Input |
En | Enable contoller
Invers | Working direction, Low = Heating (direct) High = Cooling (indirect)
ContrVal | Controlled value, e.g. temperature, pressure, humidity
SetPt | Set point controlled value
YMin | Minimum signal Y
YMax | Maximum signal Y

Output |
Y | Control signal
SetPt | Set point - same as input SetPt or internal set point

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Current values--- ] |
Controlled value | Current controlled value, e.g. temperature, pressure, humidity
... Value specification done | Selection whether Set point is used by Input or internally in FBox
Set point | Set point of input SetPt or direct Set point if specification internal
Unit | Unit controlled value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Signal | Current actual value of the control variable
Unit | Unit manipulated value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
(unused) | Unused, provision for other functionalities.
(unused) | Unused, provision for other functionalities.
[ --- Parameter --- ] |
<--- BACnet common ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
-Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Proportional band | P-Range in unit, e.g. P-Band= 25.0 means a P-jump of 100f the deviation Set point to actual value is 25 (unit)
<--- BACnet Object-Name ---> | Suffix of Object Name
Integration time (s) | Integration time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Derivation time (s) | Derivation time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Dead range | Dead range (signal jump, before it is relayed at output Y
Scan time (s) | Scan time of the controller, should be taken into consideration with integration time
Manual override | Manual override of the control value
... Manual value | Manual value of control value
Min/Max value specification done | Prefix of Min/Max over Input of the FBox or internal
... Minimum value | Minimum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
... Maximum value | Maximum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
[ --- DDC Suite V 2.5 --- ] |

Functional

Simple controller for heating, cooling, pressure control, etc. Cannot be linked with other controllers.

The set point of the control variable can be present at input "SetPt" (... preset value is carried out = FBox input) or optionally be switched constant (... preset value is carried out = internally). The same applies for the min./max. limiting of the control signal.

Min. and max. values are only active with attached controller enabling.

The controller can be directly switched to reverse (so, from heating to cooling) via the input "Invers".

System function Offline Trending

The control signal can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Y | AV | - | Signal
Y | TR | optional | Signal
Y/SetPt | AV | - | Set point of control variable
Y/SetPt | TR | optional | Set point of control variable
Y/SetPt/Param | AV | - | Proportional band
Y/SetPt/Param | AV | - | Reset time
Y/SetPt/Param | AV | - | Differential time
Y/SetPt/Param | AV | - | Min. value of signal
Y/SetPt/Param | AV | - | Max. value of signal

Predefined

Controlled value | ContrVal | R |
... Value specification done | SetPtMode | F | 0 = Internal
 |  |  | 1 = FBox-Input
Set point | SetPt | R |
Signal | Signal | R |
(unused) | Message4 | F | 0 = unused
 |  |  | 1 = unused
(unused) | Message5 | F | 0 = unused
 |  |  | 1 = unused
Proportional band | PRange | R | 1..500000
Integration time (s) | IntTime | R | 0..360000
Derivation time (s) | DerTime | R | 0..36000
Dead range | DeadRange | R | 0..1000
Scan time (s) | ScanTime | R | 1..36000
Manual override | SignalMode | F | 0 = automatic
 |  |  | 1 = Manual
... Manual value | SignalMan | R | 0..1000
Min/Max value specification done | MinMaxMode | F | 0 = Internal
 |  |  | 1 = FBox-Input
... Minimum value | SignalMin | R | 0..1000
... Maximum value | SignalMax | R | 0..1000


Limiter

Family: | DDC 2.5 Controller
Name: | Limiter
Macro: | _DDC_LOLIMITER250
Version: | 2.5.000

Description

PID controller for minimum or maximum limiting.

Input |
ContrVal | Controlled value, e.g. temperatur, pressure, humidity
SetPt | Set point controlled value

Output |
Y | Control signal
SetPt | Set point - same as input SetPt or internal set point

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Current values--- ] |
Controlled value | Current controlled value, e.g. temperature, pressure, humidity
... Value specification done | Selection whether Set point is used by Input or internally in FBox
Set point | Set point of input SetPt or direct Set point if specification internal
Unit | Unit controlled value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Signal | Current actual value of the control variable
Unit | Unit manipulated value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Control type | Working direction of the controller, heat (direct) or cool (indirect)
(unused) | Unused, provision for other functionalities.
[ --- Parameter --- ] |
<--- BACnet common ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Proportional band | P-Range in unit, e.g. P-Band= 25.0 means a P-jump of 100f the deviation Set point to actual value is 25 (unit)
<--- BACnet Object-Name ---> | Suffix of Object Name
Integration time (s) | Integration time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Derivation time (s) | Derivation time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Dead range | Dead range (signal jump, before it is relayed at output Y
Scan time (s) | Scan time of the controller, should be taken into consideration with integration time
Manual override | Manual override of the control value
... Manual value | Manual value of control value
(unused) | Unused, provision for other functionalities.
... Minimum value | Minimum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
... Maximum value | Maximum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
[ --- DDC Suite V 2.5 --- ] |

Functional

Simple min./max. limiting controller, e.g. for a maximum return speed limitation. The controller is always active.

The set point of the control variable can be present at input "Setpt" (... preset value is carried out = FBox input) or optionally be switched constant (... preset value is carried out = internally).

System function Offline Trending

The control signal can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Y | AV | - | Signal
Y | TR | optional | Signal
Y/SetPt | AV | - | Set point of control variable
Y/SetPt | TR | optional | Set point of control variable
Y/SetPt/Param | AV | - | Proportional band
Y/SetPt/Param | AV | - | Reset time
Y/SetPt/Param | AV | - | Differential time
Y/SetPt/Param | AV | - | Min. value of signal
Y/SetPt/Param | AV | - | Max. value of signal

Predefined

Controlled value | ContrVal | R |
... Value specification done | SetPtMode | F | 0 = Internal
 |  |  | 1 = FBox-Input
Set point | SetPt | R |
Signal | Signal | R |
Control type | Message4 | F | 0 = Heating
 |  |  | 1 = Cooling
(unused) | Message5 | F | 0 = unused
 |  |  | 1 = unused
Proportional band | PRange | R | 1..500000
Integration time (s) | IntTime | R | 0..360000
Derivation time (s) | DerTime | R | 0..36000
Dead range | DeadRange | R | 0..1000
Scan time (s) | ScanTime | R | 1..36000
Manual override | SignalMode | F | 0 = automatic
 |  |  | 1 = Manual
... Manual value | SignalMan | R | 0..1000
(unused) | MinMaxMode | F | 0 = Internal
 |  |  | 1 = Internal
... Minimum value | SignalMin | R | 0..1000
... Maximum value | SignalMax | R | 0..1000


Humidification

Family: | DDC 2.5 Controller
Name: | Humidification
Macro: | _DDC_LOHUMID250
Version: | 2.5.001

Description

Humidification controller.

Input |
Encontr | Enable contoller
SetPt | Set point controlled value
Humidity | Controlled value, humidity

Output |
Y | Signal Humidifier
Act | Active, High if humidifier is working
SetPt | Set point - same as input SetPt or internal set point

Const |
Hum | Activation flag of the humidification controller (this FBox)
DeH | Activation flag of the Dehumidification controller
Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Current values--- ] |
Controlled value | Current controlled value, humidity
... Value specification done | Selection whether Set point is used by Input or internally in FBox
Set point | Set point of input SetPt or direct Set point if specification internal
Unit | Unit controlled value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Signal | Current actual value of the control variable
Unit | Unit manipulated value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
(unused) | Unused, provision for other functionalities.
(unused) | Unused, provision for other functionalities.
[ --- Parameter --- ] |
<--- BACnet common ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Proportional band | P-Range in um., e.g. P-Band= 25.0 means a P-jump of 100f the deviation Set point to actual value is 25um.
<--- BACnet Object-Name ---> | Suffix of Object Name
Integration time (s) | Integration time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Derivation time (s) | Derivation time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Dead range | Dead range (signal jump, before it is relayed at output Y
Scan time (s) | Scan time of the controller, should be taken into consideration with integration time
Manual override | Manual override of the control value
... Manual value | Manual value of control value
(unused) | Unused, provision for other functionalities.
Minimum value | Minimum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
Maximum value | Maximum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
[ --- DDC Suite V 2.5 --- ] |

Functional

Humidification controller, normally influencing the supply air humidity or ambient/exhaust air humidity. The interlinking of the controllers takes place by designation in the enabling flags (constants). These are to be clearly designated. As only the humidification and dehumidification FBoxes are in cooperative sequence, this controller automatically turns on when the control is enabled.

If there is no need for dehumidification, the dehumidification FBox is not to be placed, but the designation of the enabling flag remains identical.

The set point of the control variable can be present at input "SetPt" (... preset value is carried out = FBox input) or optionally be switched constant (... preset value is carried out = internally).

Minimum and maximum values are active only with attached controller enabling (also if the controller is inactive)

System function Offline Trending

The signal of the humidifier can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Y | AV | - | Signal
Y | TR | optional | Signal
Y/SetPt | AV | - | Set point of control variable
Y/SetPt | TR | optional | Set point of control variable
Y/SetPt/Param | AV | - | Proportional band
Y/SetPt/Param | AV | - | Reset time
Y/SetPt/Param | AV | - | Differential time
Y/SetPt/Param | AV | - | Min. value of signal
Y/SetPt/Param | AV | - | Max. value of signal

Predefined

Controlled value | ContrVal | R |
... Value specification done | SetPtMode | F | 0 = Internal
 |  |  | 1 = FBox-Input
Set point | SetPt | R | 0..1000
Signal | Signal | R |
(unused) | Message4 | F | 0 = unused
 |  |  | 1 = unused
(unused) | Message5 | F | 0 = unused
 |  |  | 1 = unused
Proportional band | PRange | R | 1..500000
Integration time (s) | IntTime | R | 0..360000
Derivation time (s) | DerTime | R | 0..36000
Dead range | DeadRange | R | 0..100
Scan time (s) | ScanTime | R | 1..36000
Manual override | SignalMode | F | 0 = automatic
 |  |  | 1 = Manual
... Manual value | SignalMan | R | 0..1000
(unused) | MinMaxMode | F | 0 = Internal
 |  |  | 1 = Internal
Minimum value | SignalMin | R | 0..1000
Maximum value | SignalMax | R | 0..1000


Dehumidification

Family: | DDC 2.5 Controller
Name: | Dehumidification
Macro: | _DDC_LODEHUMID250
Version: | 2.5.001

Description

Dehumidification controller.

Input |
EnContr | Enable contoller
SetPt | Set point controlled value
Humidity | Controlled value, humidity
YCooler | Control signal of the cooler from the controller temperature

Output |
Y | Signal Cooler valve
Act | Active, High if cooler is working
Dehumid | Message Dehumidification active (connect to FBox Start AC)
SetPt | Set point - same as input SetPt or internal set point

Const |
Hum | Activation flag of the humidification controller
DeH | Activation flag of the Dehumidification controller (this FBox)
Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Current values--- ] |
Controlled value | Current controlled value, humidity
... Value specification done | Selection whether Set point is used by Input or internally in FBox
Set point | Set point of input SetPt or direct Set point if specification internal
Unit | Unit controlled value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Signal | Current actual value of the control variable
Unit | Unit manipulated value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Dehumidification | Message Dehumidification active
(unused) | Unused, provision for other functionalities.
[ --- Parameter --- ] |
<--- BACnet common ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Proportional band | P-Range in um., e.g. P-Band= 25.0 means a P-jump of 100f the deviation Set point to actual value is 25um.
<--- BACnet Object-Name ---> | Suffix of Object Name
Integration time (s) | Integration time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Derivation time (s) | Derivation time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Dead range | Dead range (signal jump, before it is relayed at output Y
Scan time (s) | Scan time of the controller, should be taken into consideration with integration time
Manual override | Manual override of the control value
... Manual value | Manual value of control value
(unused) | Unused, provision for other functionalities.
Minimum value | Minimum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
Maximum value | Maximum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
[ --- DDC Suite V 2.5 --- ] |

Functional

Dehumidification controller, normally influencing the supply air humidity or ambient/exhaust air humidity. The interlinking of the controllers takes place by designation in the enabling flags (constants). These are to be clearly designated. As only the humidification and dehumidification FBoxes are in cooperative sequence, this controller automatically turns on when the control is enabled.

If there is no need for humidification, the humidification FBox is not to be placed, but the designation of the enabling flag remains identical.

The set point of the control variable can be present at input "SetPt" (... preset value is carried out = FBox input) or optionally be switched constant (... preset value is carried out = internally).

Minimum and maximum values are active only with attached controller enabling (also if the controller is inactive)

If the signal of the dehumidification controller is greater than the signal present at input "YCooler" of the cooler controller, the dehumidify signal turns active. Only when the signal of the dehumidification controller falls below 5the dehumidification active signal is cancelled.

For all the other system controllers to recognise that dehumidification is active, the input "Dehumid" should be connected to the FBox "Start Fan" at the input with the same name.

System function Offline Trending

The cooler valve signal can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Y | AV | - | Signal
Y | TR | optional | Signal
Y/SetPt | AV | - | Set point of control variable
Y/SetPt | TR | optional | Set point of control variable
Y/SetPt/Param | AV | - | Proportional band
Y/SetPt/Param | AV | - | Reset time
Y/SetPt/Param | AV | - | Differential time
Y/SetPt/Param | AV | - | Min. value of signal
Y/SetPt/Param | AV | - | Max. value of signal

Predefined

Controlled value | ContrVal | R |
... Value specification done | SetPtMode | F | 0 = Internal
 |  |  | 1 = FBox-Input
Set point | SetPt | R | 0..1000
Signal | Signal | R |
Dehumidification | Message4 | F | 0 = inactive
 |  |  | 1 = active
(unused) | Message5 | F | 0 = unused
 |  |  | 1 = unused
Proportional band | PRange | R | 1..500000
Integration time (s) | IntTime | R | 0..360000
Derivation time (s) | DerTime | R | 0..36000
Dead range | DeadRange | R | 0..100
Scan time (s) | ScanTime | R | 1..36000
Manual override | SignalMode | F | 0 = automatic
 |  |  | 1 = Manual
... Manual value | SignalMan | R | 0..1000
(unused) | MinMaxMode | F | 0 = Internal
 |  |  | 1 = Internal
Minimum value | SignalMin | R | 0..1000
Maximum value | SignalMax | R | 0..1000


Cooler

Family: | DDC 2.5 Controller
Name: | Cooler
Macro: | _DDC_LOCOOLER250
Version: | 2.5.000

Description

Cooler controller.

Input |
EnContr | Enable contoller
SetPt | Set point controlled value
Temp | Controlled value, supply air temperatur
Lock | Locks the controller

Output |
Y | Signal Cooler valve
Act | Active, High if cooler is working
SetPt | Set point - same as input SetPt or internal set point

Const |
C | Activation flag of the cooler controller (this FBox)
+ | Activation flag of controller afterwards, e.g. mixed air, pre-heater, re-heater
Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Current values--- ] |
Controlled value | Current controlled value, supply air temperature
... Value specification done | Selection whether Set point is used by Input or internally in FBox
Set point | Set point of input SetPt or direct Set point if specification internal
Unit | Unit controlled value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Signal Valve | Current actual value of the control variable
Unit | Unit manipulated value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
(unused) | Unused, provision for other functionalities.
(unused) | Unused, provision for other functionalities.
[ --- Parameter --- ] |
<--- BACnet common ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Proportional range | P-Range in °C, e.g. P-Band= 25.0 means a P-jump of 100f the deviation Set point to actual value is 25°K
<--- BACnet Object-Name ---> | Suffix of Object Name
Integration time (s) | Integration time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Derivation time (s) | Derivation time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Dead range | Dead range (signal jump, before it is relayed at output Y
Scan time (s) | Scan time of the controller, should be taken into consideration with integration time
Manual override | Manual override of the control value
... Manual value | Manual value of control value
(unused) | Unused, provision for other functionalities.
Minimum value | Minimum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
Maximum value | Maximum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
[ --- DDC Suite V 2.5 --- ] |

Functional

Cooler controller, normally influencing the supply air temperature. The interlinking of the controllers takes place by designation in the enabling flags (constants). These are to be clearly specified. See example of interlinking of controllers in the controller family overview .

The set point of the control variable can be present at input "SetPt" (... preset value is carried out = FBox input) or optionally be switched to constant (... preset value is carried out = internally).

Function of a normal cooler controller. This does NOT switch to active mode, but is activated by a preceding controller if need be (e.g. air circulation controller). Minimum and maximum values are active only with attached controller enabling (even if the controller is inactive)

During dehumidification, the controller remains active and/or switches to active mode, but does not issue a signal (0.0 In this case, the cooler controller waits until the dehumidification controller turns off the dehumidification (control signal dehumidification smaller than 5and then actively takes control. See also Dehumidification controller.

System function Offline Trending

The signal of the cooler valve can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Y | AV | - | Signal
Y | TR | optional | Signal
Y/SetPt | AV | - | Set point of control variable
Y/SetPt | TR | optional | Set point of control variable
Y/SetPt/Param | AV | - | Proportional band
Y/SetPt/Param | AV | - | Reset time
Y/SetPt/Param | AV | - | Differential time
Y/SetPt/Param | AV | - | Min. value of signal
Y/SetPt/Param | AV | - | Max. value of signal

Predefined

Controlled value | ContrVal | R |
... Value specification done | SetPtMode | F | 0 = Internal:
 |  |  | 1 = FBox-Input
Set point | SetPt | R |
Signal Valve | Signal | R |
(unused) | Message4 | F | 0 = unused
 |  |  | 1 = unused
(unused) | Message5 | F | 0 = unused
 |  |  | 1 = unused
Proportional range | PRange | R | 1..500000
Integration time (s) | IntTime | R | 0..360000
Derivation time (s) | DerTime | R | 0..36000
Dead range | DeadRange | R | 0..100
Scan time (s) | ScanTime | R | 1..36000
Manual override | SignalMode | F | 0 = automatic
 |  |  | 1 = Manual
... Manual value | SignalMan | R | 0..1000
(unused) | MinMaxMode | F | 0 = Internal
 |  |  | 1 = Internal
Minimum value | SignalMin | R | 0..1000
Maximum value | SignalMax | R | 0..1000


Mixed air

Family: | DDC 2.5 Controller
Name: | Mixed air
Macro: | _DDC_LOMIXEDAIR250
Version: | 2.5.000

Description

Air circulation controller with supply/demand control, minimum ratio of outside air

Input |
EnContr | Enable contoller
SetPt | Set point controlled value
Temp | Controlled value, supply air temperatur
RoomTemp | Room or exhaust temperature for the offer/demand control

Output |
Y | Control signal for the air circulation damper
YInv | Control signal for outside / supply air circulation damper
Act | Active, High if mixed air is working
SetPt | Set point - same as input SetPt or internal set point

Const |
- | Activation flag of controller before, e.g. cooler
MA | Activation flag of the mixed air controller (this FBox)
+ | Activation flag of controller afterwards, e.g. pre-heater, re-heater
Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Current values--- ] |
Controlled value | Current controlled value, supply air temperature
... Value specification done | Selection whether Set point is used by Input or internally in FBox
Set point | Set point of input SetPt or direct Set point if specification internal
Unit | Unit controlled value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Signal damper (mixed air) | Control signal, damper
Unit | Unit manipulated value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Offer/Demand | Display of the type of air used (room /outside) for control
(unused) | Unused, provision for other functionalities.
[ --- Parameter --- ] |
Hysterese To-Tr | Hysteresis temperatur room/outdoor
<--- BACnet common ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Proportional range | P-Range in °C, e.g. P-Band= 25.0 means a P-jump of 100f the deviation Set point to actual value is 25°K
<--- BACnet Object-Name ---> | Suffix of Object Name
Integration time (s) | Integration time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Derivation time (s) | Derivation time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Dead range | Dead range (signal jump, before it is relayed at output Y
Scan time (s) | Scan time of the controller, should be taken into consideration with integration time
Manual override | Manual override of the control value
... Manual value | Manual value of control value
(unused) | Unused, provision for other functionalities.
Minimum value | Minimum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
Maximum value | Maximum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
[ --- DDC Suite V 2.5 --- ] |

Functional

Air circulation controller, normally influencing the supply air temperature. The interlinking of the controllers takes place by designation in the enabling flags (constants). These are to be clearly specified. See example of interlinking of controllers in the controller family overview .

The set point of the control variable can be present at input "SetPt" (... preset value is carried out =FBox input) or optionally be switched constant (... preset value is carried out = internally).

Function of a normal air circulation controller. This does NOT switch to active mode, but is activated by a preceding controller if need be (e.g. preheater controller).

To include a minimum ratio of outside air, the maximum value has to be limited, e.g. maximum value=75orresponds to a minimum outside air ratio of 25Minimum and maximum values are active only with attached controller enabling (also if the controller is inactive)

The outside air temperature (provided via the module "InitLib") is compared with the temperature at input "Rt" and uses the favourable air according to heat or cold (supply/demand).

If the air circulation controller is not active (e.g. preheater has taken over), the flaps reverse the position if need be, when the supply/demand ratio changes.

If the free cooling is active, the air circulation shuts down (0and the exhaust air opens to 100

System function Offline Trending

The signal of the mixed air valve can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Y | AV | - | Signal
Y | TR | optional | Signal
Y/SetPt | AV | - | Set point of control variable
Y/SetPt | TR | optional | Set point of control variable
Y/SetPt/Param | AV | - | Proportional band
Y/SetPt/Param | AV | - | Reset time
Y/SetPt/Param | AV | - | Differential time
Y/SetPt/Param | AV | - | Min. value of signal
Y/SetPt/Param | AV | - | Max. value of signal

Predefined

Controlled value | ContrVal | R |
... Value specification done | SetPtMode | F | 0 = Internal
 |  |  | 1 = FBox-Input
Set point | SetPt | R |
Signal damper (mixed air) | Signal | R |
Offer/Demand | Message4 | F | 0 = Outside
 |  |  | 1 = Room/Exhaust
(unused) | Message5 | F | 0 = unused
 |  |  | 1 = unused
Proportional range | PRange | R | 1..500000
Integration time (s) | IntTime | R | 0..360000
Derivation time (s) | DerTime | R | 0..36000
Dead range | DeadRange | R | 0..100
Scan time (s) | ScanTime | R | 1..36000
Manual override | SignalMode | F | 0 = automatic
 |  |  | 1 = Manual
... Manual value | SignalMan | R | 0..1000
(unused) | MinMaxMode | F | 0 = Internal
 |  |  | 1 = Internal
Minimum value | SignalMin | R | 0..1000
Maximum value | SignalMax | R | 0..1000


Heat recovery

Family: | DDC 2.5 Controller
Name: | Heat recovery
Macro: | _DDC_LOHEATRECOVER250
Version: | 2.5.000

Description

Heat recovery controller with supply-demand control and frost function

Input |
EnContr | Enable contoller
SetPt | Set point controlled value
Temp | Controlled value, supply air temperatur
RoomTemp | Room or exhaust temperature for the offer/demand control
Ala | Alarm on heat recoveing
YFrost | Signal on frost alarm

Output |
Y | Signal Valve /speed
Act | Active, High if heat recovery is working
SetPt | Set point - same as input SetPt or internal set point

Const |
- | Activation flag of controller before, e.g. cooler
HR | Activation flag of the heat recovery controller (this FBox)
+ | Activation flag of controller afterwards, e.g. mixed air, pre-heater, re-heater
Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Current values--- ] |
Controlled value | Current controlled value, supply air temperature
... Value specification done | Selection whether Set point is used by Input or internally in FBox
Set point | Set point of input SetPt or direct Set point if specification internal
Unit | Unit controlled value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Signal Valve | Control signal, heat recovery valve
Unit | Unit manipulated value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Offer/Demand | Display of the type of air used (room /outside) for control
(unused) | Unused, provision for other functionalities.
[ --- Parameter --- ] |
Hysterese To-Tr | Hysteresis temperature room/outdoor
<--- BACnet common ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Proportional range | P-Range in °C, e.g. P-Band= 25.0 means a P-jump of 100f the deviation Set point to actual value is 25°K
<--- BACnet Object-Name ---> | Suffix of Object Name
Integration time (s) | Integration time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Derivation time (s) | Derivation time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Dead range | Dead range (signal jump, before it is relayed at output Y
Scan time (s) | Scan time of the controller, should be taken into consideration with integration time
Manual override | Manual override of the control value
... Manual value | Manual value of control value
(unused) | Unused, provision for other functionalities.
Minimum value | Minimum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
Maximum value | Maximum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
[ --- DDC Suite V 2.5 --- ] |

Functional

Heat recovery controller for cable distribution cabinet or circulating heat exchanger, etc., normally influences the supply air temperature. The interlinking of the controllers takes place by designation in the enabling flags (constants). These are to be clearly specified. See example of interlinking of controllers in the controller family overview .

The set point of the control variable can be present at input "SetPt" (... preset value is carried out =FBox input) or optionally be switched to constant (... preset value is carried out = internally).

Function of a normal heat recovery controller. This does NOT switch to active mode, but is activated by a preceding controller if need be (e.g. preheater controller).

If there is a failure present at input "Ala", the signal with 0s issued. The frost safety function however overrides.

If there is a danger of frost in the preheater (detected via FBox "Start FAN" name/ref mechanism), the signal at input YFrost is issued as signal.

The outside air temperature (is provided via the module "InitLib") is compared with the temperature at input "Rt" and uses the favourable air according to heat or cold.

System function Offline Trending

The signal of the valve/rpm can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Y | AV | - | Signal
Y | TR | optional | Signal
Y/SetPt | AV | - | Set point of control variable
Y/SetPt | TR | optional | Set point of control variable
Y/SetPt/Param | AV | - | Proportional band
Y/SetPt/Param | AV | - | Reset time
Y/SetPt/Param | AV | - | Differential time
Y/SetPt/Param | AV | - | Min. value of signal
Y/SetPt/Param | AV | - | Max. value of signal

Predefined

Controlled value | ContrVal | R |
... Value specification done | SetPtMode | F | 0 = Internal
 |  |  | 1 = FBox-Input
Set point | SetPt | R |
Signal Valve | Signal | R |
Offer/Demand | Message4 | F | 0 = Outside
 |  |  | 1 = Room/Exhaust
(unused) | Message5 | F | 0 = unused
 |  |  | 1 = unused
Proportional range | PRange | R | 1..500000
Integration time (s) | IntTime | R | 0..360000
Derivation time (s) | DerTime | R | 0..36000
Dead range | DeadRange | R | 0..100
Scan time (s) | ScanTime | R | 1..36000
Manual override | SignalMode | F | 0 = automatic
 |  |  | 1 = Manual
... Manual value | SignalMan | R | 0..1000
(unused) | MinMaxMode | F | 0 = Internal
 |  |  | 1 = Internal
Minimum value | SignalMin | R | 0..1000
Maximum value | SignalMax | R | 0..1000


Preheater

Family: | DDC 2.5 Controller
Name: | Preheater
Macro: | _DDC_LOPREHTEAT250
Version: | 2.5.000

Description

Preheater controller with frost protection safety function.

Input |
EnContr | Enable contoller
SetPt | Set point controlled value
Temp | Controlled value, supply air temperatur
YCldStrt | Cold start value after preflushing phase

Output |
Y | Signal preheater valve
Act | Active, High if pre heater is working
SetPt | Set point - same as input SetPt or internal set point

Const |
- | Activation flag of controller before, e.g. mixed air, cooler
PH | Activation flag of the pre-heater controller (this FBox)
+ | Activation flag of controller afterwards, e.g. re-heater
Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Current values--- ] |
Controlled value | Current controlled value, supply air temperature
... Value specification done | Selection whether Set point is used by Input or internally in FBox
Set point | Set point of input SetPt or direct Set point if specification internal
Unit | Unit controlled value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Signal Valve | Control signal, pre-heater valve
Unit | Unit manipulated value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
(unused) | Unused, provision for other functionalities.
(unused) | Unused, provision for other functionalities.
[ --- Parameter --- ] |
<--- BACnet common ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Proportional band | P-Range in °C, e.g. P-Band= 25.0 means a P-jump of 100f the deviation Set point to actual value is 25°K
<--- BACnet Object-Name ---> | Suffix of Object Name
Integration time (s) | Integration time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Derivation time (s) | Derivation time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Dead range | Dead range (signal jump, before it is relayed at output Y
Scan time (s) | Scan time of the controller, should be taken into consideration with integration time
Manual override | Manual override of the control value
... Manual value | Manual value of control value
(unused) | Unused, provision for other functionalities.
Minimum value | Minimum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
Maximum value | Maximum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
[ --- DDC Suite V 2.5 --- ] |

Functional

Preheater controller, normally influencing the supply air temperature. The interlinking of the controllers takes place by designation in the enabling flags (constants). These are to be clearly specified. See example of interlinking of controllers in the controller family overview .

The set point of the control variable can be present at input "SepPt" (... preset value is carried out = FBox input) or optionally be switched constant (... preset value is carried out = internally).

Function of a normal preheater controller. This switches on as the only temperature controller in ACTIVE mode and then issues enabling according to demand from the preceding or subsequent controller. Minimum and maximum values are active only with attached controller enabling (also if the controller is inactive)

In the start phase of the ventilation (see also FBox "Start RLT"), the preheater behaves as follows:

- Enabling of pre-flushing: The signal to the valve is issued 100o achieve a quick flushing of the preheater.

- Valve enabling (= End of pre-flushing): The signal at input "YCldStrt" is issued to the valve and this value is initialised as cold start.

- Enabling of control : Controller actively works and if need be, passes on the enabling to other controllers.

In case of upcoming danger of frost or frost warning, the controller issues 100o the valve. This function also overrides a manual operation and/or the maximum limit.

In case of dehumidification, the controller turns off and waits till it is activated, if need be, by other controllers.

System function Offline Trending

The signal of the heater valve can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Y | AV | - | Signal
Y | TR | optional | Signal
Y/SetPt | AV | - | Set point of control variable
Y/SetPt | TR | optional | Set point of control variable
Y/SetPt/Param | AV | - | Proportional band
Y/SetPt/Param | AV | - | Reset time
Y/SetPt/Param | AV | - | Differential time
Y/SetPt/Param | AV | - | Min. value of signal
Y/SetPt/Param | AV | - | Max. value of signal

Predefined

Controlled value | ContrVal | R |
... Value specification done | SetPtMode | F | 0 = Internal
 |  |  | 1 = FBox-Input
Set point | SetPt | R |
Signal Valve | Signal | R |
(unused) | Message4 | F | 0 = unused
 |  |  | 1 = unused
(unused) | Message5 | F | 0 = unused
 |  |  | 1 = unused
Proportional band | PRange | R | 1..500000
Integration time (s) | IntTime | R | 0..360000
Derivation time (s) | DerTime | R | 0..36000
Dead range | DeadRange | R | 0..100
Scan time (s) | ScanTime | R | 1..36000
Manual override | SignalMode | F | 0 = automatic
 |  |  | 1 = Manual
... Manual value | SignalMan | R | 0..1000
(unused) | MinMaxMode | F | 0 = Internal:
 |  |  | 1 = Internal:
Minimum value | SignalMin | R | 0..1000
Maximum value | SignalMax | R | 0..1000


Re-heater

Family: | DDC 2.5 Controller
Name: | Re-heater
Macro: | _DDC_LOREHTEAT250
Version: | 2.5.000

Description

Re-heater controller

Input |
EnContr | Enable contoller
SetPt | Set point controlled value
Temp | Controlled value, supply air temperatur

Output |
Y | Signal Reheater valve
Act | Active, High if controller is working
SetPt | Set point - same as input SetPt or internal set point

Const |
- | Activation flag of controller before, e.g. pre-heater, mixed air, cooler
RH | Activation flag of the re-heater controller (this FBox)
Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Current values--- ] |
Controlled value | Current controlled value, supply air temperature
... Value specification done | Selection whether Set point is used by Input or internally in FBox
Set point | Set point of input SetPt or direct Set point if specification internal
Unit | Unit controlled value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Signal Valve | Control signal, re-heater valve
Unit | Unit manipulated value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
(unused) | Unused, provision for other functionalities.
(unused) | Unused, provision for other functionalities.
[ --- Parameter --- ] |
<--- BACnet common ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Proportional range | P-Range in °C, e.g. P-Band= 25.0 means a P-jump of 100f the deviation Set point to actual value is 25°K
<--- BACnet Object-Name ---> | Suffix of Object Name
Integration time (s) | Integration time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Derivation time (s) | Derivation time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Dead range | Dead range (signal jump, before it is relayed at output Y
Scan time (s) | Scan time of the controller, should be taken into consideration with integration time
Manual override | Manual override of the control value
... Manual value | Manual value of control value
(unused) | Unused, provision for other functionalities.
Minimum value | Minimum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
Maximum value | Maximum value of the control value
<--- BACnet Object-Name ---> | Suffix of Object Name
[ --- DDC Suite V 2.5 --- ] |

Functional

Re-heater controller, normally influencing the supply air temperature. The interlinking of the controllers takes place by designation in the enabling flags (constants). These are to be clearly specified. See example of interlinking of controllers in the controller family overview .

The set point of the control variable can be present at input "SetPt" (... preset value is carried out = FBox input) or optionally be switched constant (... preset value is carried out = internally).

Function of a normal re-heater controller. This does NOT switch to active mode, but is activated by a preceding controller if need be (e.g. preheater). Minimum and maximum values are active only with attached controller enabling (also if the controller is inactive)

During dehumidification, the controller turns to active mode and adjusts the temperature. If the dehumidification controller turns off the dehumidification (control signal dehumidify lower than 5 the re-heater deactivates as well and the cooler controller assumes the temperature control. See also Dehumidification controller.

System function Offline Trending

The signal of the heater valve can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Y | AV | - | Signal
Y | TR | optional | Signal
Y/SetPt | AV | - | Set point of control variable
Y/SetPt | TR | optional | Set point of control variable
Y/SetPt/Param | AV | - | Proportional band
Y/SetPt/Param | AV | - | Reset time
Y/SetPt/Param | AV | - | Differential time
Y/SetPt/Param | AV | - | Min. value of signal
Y/SetPt/Param | AV | - | Max. value of signal

Predefined

Controlled value | ContrVal | R |
... Value specification done | SetPtMode | F | 0 = Internal
 |  |  | 1 = FBox-Input
Set point | SetPt | R |
Signal Valve | Signal | R |
(unused) | Message4 | F | 0 = unused
 |  |  | 1 = unused
(unused) | Message5 | F | 0 = unused
 |  |  | 1 = unused
Proportional range | PRange | R | 1..500000
Integration time (s) | IntTime | R | 0..360000
Derivation time (s) | DerTime | R | 0..36000
Dead range | DeadRange | R | 0..100
Scan time (s) | ScanTime | R | 1..36000
Manual override | SignalMode | F | 0 = automatic
 |  |  | 1 = Manual
... Manual value | SignalMan | R | 0..1000
(unused) | MinMaxMode | F | 0 = Internal
 |  |  | 1 = Internal
Minimum value | SignalMin | R | 0..1000
Maximum value | SignalMax | R | 0..1000


Master Cascade

Family: | DDC 2.5 Controller
Name: | Master Cascade
Macro: | _DDC_LOMASTER250
Version: | 2.5.000

Description

Master controller for a cascade sequence control.

Input |
EnContr | Enable contoller
Temp | Controlled value, e.g. Room or exhaust temperature
SetPt | Set point controlled value
SeqMin | Minimum value of sequence set point
SeqMax | Maximum value of sequence set point

Output |
SetPtSeq | Set point sequence, e.g. supply air temperatur
SetPt | Set point - same as input SetPt or internal set point

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Current values--- ] |
Controlled value | Current controlled value, e.g. room or exhaust air temperature
... Value specification done | Selection whether Set point is used by Input or internally in FBox
Set point | Set point of input SetPt or direct Set point if specification internal
Unit | Unit controlled value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Set point sequence | Control signal, sequence set point
Unit | Unit manipulated value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Frost protection | Frost protection function active (sequence set point = Max)
Forced cooling | Forced cooling active (sequence set point = Min)
[ --- Parameter --- ] |
<--- BACnet common ---> | Group information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) + This text + Suffix.
- Description | Group information for Description. It consists of the PCS (BACnet - D / Level 1-10) + This text.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Proportional range | P-Range in °C, e.g. P-Band= 25.0 means a P-jump of 100f the deviation Set point to actual value is 25°K
<--- BACnet Object-Name ---> | Suffix of Object Name
Integration time (s) | Integration time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Derivation time (s) | Derivation time (if > than 1.0 seconds, otherwise inactive)
<--- BACnet Object-Name ---> | Suffix of Object Name
Dead range | Dead range (°C) signal jump, before it is relayed at output SeqSetPt
Scan time (s) | Scan time of the controller, should be taken into consideration with integration time
Manual override | Manual override of the sequence Set point
... Manual value | Manual value of the sequence Set point
Min/Max value specification done | Selection whether Min/Max over Input of the FBox or internal
... Minimum value | Minimum value of the sequence set point
<--- BACnet Object-Name ---> | Suffix of Object Name
... Maximum value | Maximum value of the sequence set point
<--- BACnet Object-Name ---> | Suffix of Object Name
[ --- DDC Suite V 2.5 --- ] |

Functional

Master controller for a cascade sequence control, e.g. for application as master controller of outlet air temperature.

The controller has to be referenced to the FBox Start Ventilation, as this has all the necessary information on the status of the system (e.g. free cooling, dehumidification active, etc.)

The set point of the reference variable can be present at input "SetPt" (... preset value is carried out = FBox input) or optionally be switched to constant (... preset value is carried out = internally). The same applies to the minimum and maximum of the set point of the dependent variable.

If there is no enabling of the control (input "EnContr"), the set point of the dependent variable is initialised with the set point of the reference variable. After enabling of the control, the master controller works from this point.

If the cooling protection is active, the maximum dependent set point is displayed. With active over-heat protection, the minimum dependent set point is displayed.

System function Offline Trending

The set point of the dependent variable can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Y | AV | - | Set point of sequence (signal)
Y | TR | optional | Set point of sequence (signal)
Y/SetPt | AV | - | Set point of reference variable
Y/SetPt | TR | optional | Set point of reference variable
Y/SetPt/Param | AV | - | Proportional band
Y/SetPt/Param | AV | - | Reset time
Y/SetPt/Param | AV | - | Differential time
Y/SetPt/Param | AV | - | Min. value of set point of sequence
Y/SetPt/Param | AV | - | Max. value of set point of sequence

Predefined

Controlled value | ContrVal | R |
... Value specification done | SetPtMode | F | 0 = Internal:
 |  |  | 1 = FBox-Input
Set point | SetPt | R | 0..1000
Set point sequence | Signal | R |
Frost protection | Message4 | F | 0 = Off
 |  |  | 1 = Active
Forced cooling | Message5 | F | 0 = Off
 |  |  | 1 = Active
Proportional range | PRange | R | 1..500000
Integration time (s) | IntTime | R | 0..360000
Derivation time (s) | DerTime | R | 0..36000
Dead range | DeadRange | R | 0..100
Scan time (s) | ScanTime | R | 1..36000
Manual override | SignalMode | F | 0 = automatic
 |  |  | 1 = Manual
... Manual value | SignalMan | R | 0..1000
Min/Max value specification done | MinMaxMode | F | 0 = Internal
 |  |  | 1 = FBox-Input
... Minimum value | SignalMin | R | 0..1000
... Maximum value | SignalMax | R | 0..1000


Enable zone

Family: | DDC 2.5 Controller
Name: | Enable zone
Macro: | _DDC_LOZone250
Version: | 2.5.000

Description

Enabling module for controller sequences without preheater

Input |
EnContr | Enable controller sequence
NghtCool | Night cooling during summertime

Output |
EnContr | Forward enable sequence controller

Const |
 | Flag of the 1st zone controller e.g. cooler
 | Flag of the 2nd zone controller e.g. re-heater

Functional

For zone after-treatments, a cooler and a re-heater are generally used.

As both controllers should wait for an activation of their enabling flags, this sequence should be additionally activated. This module is meant for this purpose. The internal enabling flags (cooler and re-heater) of both controllers should be specified.

Both the enabling flags of the zone controllers should be specified. This FBox makes sure that one of the two controllers is enabled with high signal at input "EnContr".

Moreover, the name/ref mechanism has to match, which means the reference of the sequence controllers should be adapted to the name of the FBox zone.


DDC 2.5 Systems

Version: 2.5.000

System 1 speed

System 1 speed Manual

System 2 speed

System 2 speed Manual

System 3 speed

System 3 speed Manual

System Heating circuit

System Heating circuit Man

System boiler

System boiler Manual

System Hot water

System Hot water Manual

Fan Start

Fan Special func.

Fan speed

Redundant

System status

Weekly clock Ton/Toff

Weekly clock Manual

Weekly clock Option

Weekly clock Selection

Time Interval

Time Holiday

Time Special days


System 1 speed

Family: | DDC 2.5 Systems
Name: | System 1 speed
Macro: | _DDC_SYSWITCH1SP250
Version: | 2.5.000

Description

Enabling of switch for 1-stage systems.

Input |
Clock | Requirement of clock programs
Special | Requirement of special functions, e.g. summer night cooling
Channel | Binary coded information calendar channels 1 to 10

Output |
En | Required mode for system
Demand | Demand through switches and clocks (without input Special)

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
BACnet > Man. switch priority | Assignment of the physical hand switch in the Priority Array
HMI Higher prio | Mode HMI higher priority
HMI Low prio | Mode HMI lower priority
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Priority | Assignment of the virtual switch in the Priority Array
... Clock accessed by | Selection whether the input contact clock is to be used or the SCADA accessing the clock flag
... calendar channel | Selection of the calendar channel 1 to 10
... Requirement of clock | Clock flag, either status of the input clock or accessed by SCADA
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Demand by operator | Demand system through clock or switches, without input Special
Requirement through special | Status of the input Special, e.g. summer night cooling
System mode | Required mode for system, displayed on output En
[ --- Definitionen --- ] |
State-text Auto | State-text Automatic
State-text Off | State-text Off
State-text On | State-text On
[ --- DDC Suite V 2.5 --- ] |

Functional

Enabling of switch for 1-stage systems. The enabling of switch has 3 levels:

1. Level : Manual switch, Parameter HMI high prior

As it is rarely available, this is not connected here (it means no FBox inputs available), but can be manually linked with the 1-stage FBox system. This switch has the positions Off - Auto - On. If there is no manual switch linked (Name/Ref), the "Auto" position is mandatorily set.

If there is no manual switch available, this parameter can be used for instance for a higher level virtual operation.

If BACnet is activated, the FBox manual 1-stage system cannot be used. This parameter then shows Auto, if the resulting system enabling of BACnet is identical with the requirement (regardless of whether the system should be Off or On). If a different operating mode is enforced through BACnet, the corresponding status is displayed (e.g. On or Off)

2. Level : BC switch, Parameter HMI low prior

Effective only if the manual control switch is on Auto. This switch has the positions Off - Auto - On.

This parameter is normally used in the virtual operation in a SCADA (ViSi.PLus) or WebPanel.

3. Level : Automatic requirements

Active only if the manual control switch and the building control switch are in auto mode. There are two types of automatic requirements: "Clock" and "Special" (=special function outside the normal operating times).

At the input "Clock", a weekly clock timer, for instance, is connected, which is included in the normal operation of the system, e.g. weekly timer programme, interval, etc.

Alternatively, a switching information can be connected at the input "Channel" (see FBox "Calendar selection 1.5" for coding) and the switching channel to be used is defined in the FBox. The input "Clock" and the function "Channel" have an equal right, that is a logical OR.

If the parameter "Clock accessed by" is set to the building control (BC) system, these functions are deactivated and the FBox anticipates that a visualisation actively describes the parameter "Requirement of Clock".

However, if the BACnet is activated with HMI/Clock, all time functions are inactive and the switching function is to be implemented via a scheduler.

3. Enabling and requirement

The output "En" is always high if the system should be asked for a requirement, e.g. switch, time or special function.

The output "Demand" displays a conscious demand of the system, which was parameterised by the user, e.g.

- Manual switch On

- Manual switch Auto, but building control system switch On

- Manual switch and building control system switch Auto, but requirement of a time/switching function

This information can be used to disable special functions, e.g. to forestall a cooling protection.

System function BACnet

If BACnet is enabled, the switch position of FBox System 1 speed manual will be mapped to the defined priority, but not indicated in the FBox. The parameter HMI higher prio will then display Auto if the resulting system enable from BACnet is identical to the request (regardless of whether the system is OFF or ON). If a different operating mode is forced by BACnet, the corresponding state will be displayed (e.g. OFF or ON).

Option | Object | Note | Description
HMI | MV | Commandable | Switching function Auto/Off/On
HMI/clock | BV | - | Clock object for use in a scheduler
HMI/clock | SC | - | Scheduler with reference to clock object

Predefined

HMI Higher prio | ModeHiPri | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = On
HMI Low prio | ModeLoPri | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = On
... Clock accessed by | ClockMode | F | 0 = Input
 |  |  | 1 = SCADA
... calendar channel | Channel | R | 1 = channel 1
 |  |  | 2 = channel 2
 |  |  | 3 = channel 3
 |  |  | 4 = channel 4
 |  |  | 5 = channel 5
 |  |  | 6 = channel 6
 |  |  | 7 = channel 7
 |  |  | 8 = channel 8
 |  |  | 9 = channel 9
 |  |  | 10 = channel 10
 |  |  | 11 = Not used
... Requirement of clock | Clock | F | 0 = Off
 |  |  | 1 = On
Demand by operator | Demand | F | 0 = Off
 |  |  | 1 = On
Requirement through special | Special | F | 0 = Off
 |  |  | 1 = On
System mode | Required | F | 0 = Off
 |  |  | 1 = On


System 1 speed Manual

Family: | DDC 2.5 Systems
Name: | System 1 speed Manual
Macro: | _DDC_SYSWITCH1SPMAN250
Version: | 2.5.000

Description

Connection of a manual switch to the FBox System 1 speed.

Input |
Auto | Switch position Automatic
On | Switch position On

Functional

The switch position will be transferred to the referenced Fbox, parameter HMI higher prio if BACnet is disabled there. If BACnet is enabled, the manual switch will be mapped to the defined priority, but the switch position will not be indicated in the FBox.


System 2 speed

Family: | DDC 2.5 Systems
Name: | System 2 speed
Macro: | _DDC_SYSWITCH2SP250
Version: | 2.5.000

Description

Enabling of switch for 2-stage systems.

Input |
ClkSp1 | Requirement of clock programs speed 1
ClkSp2 | Requirement of clock programs speed 2
SpcSp1 | Requirement of special functions, e.g. summer night cooling speed 1
SpcSp2 | Requirement of special functions, e.g. summer night cooling speed 2
Channel | Binary coded information calendar channels 1 to 10

Output |
EnSp1 | Required mode for system speed 1
EnSp2 | Required mode for system speed 2
Demand | Demand through switches and clocks (without input Special)

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
BACnet > Man. switch priority | Assignment of the physical hand switch in the Priority Array
HMI higher prio | Mode HMI higher priority
HMI lower prio | Mode HMI lower priority
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Priority | Assignment of the virtual switch in the Priority Array
... calendar channel | Selection of the calendar channel 1 to 10
... Clock accessed by | Selection whether the input contact ClkSp1..2 is to be used or the SCADA accessing the clock data
... Requirement of clock | Clock data, either status of the input ClkSp1..2 or accessed by SCADA
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Demand by operator | Demand system through clock or switches, without input Special
Requirement through special | Status of the input SpcSp1..2, e.g. summer night cooling
System mode | Required mode for system, displayed on output EnSp1..2
[ --- Definitionen --- ] |
State-text Auto | State-text Automatic
State-text Off | State-text Off
State-text Speed 1 | State-text Speed 1
State-text Speed 2 | State-text Speed 2
[ --- DDC Suite V 2.5 --- ] |

Functional

Enabling of switch for 2-stage systems. The enabling of switch has 3 levels:

1. Level : Manual switch, Parameter HMI high prior

As it is rarely available, this is not connected here (it means no FBox inputs available), but can be manually linked with the FBox System 2 speed Manual. This switch has the positions Off - Auto - speed 1 - speed 2. If no manual switch is linked (Name/Ref), the "Auto" position is mandatorily set.

If there is no manual switch available, this parameter can be used for instance for a higher level virtual operation.

If BACnet is activated, the FBox System 2 speed Manual cannot be used. This parameter then shows Auto, if the resulting system enabling of BACnet is identical with the requirement (regardless of whether the system should be Off, stage 1 or stage 2). If a different operating mode is enforced through BACnet, the corresponding status is displayed (e.g. Off, stage 1 or stage 2)

2. Level : BC switch, Parameter HMI low prior

Effective only if the manual control switch is on Auto. This switch has the positions Off - Auto - stage 11 - stage 2.

This parameter is normally used in the virtual operation in a SCADA (ViSi.PLus) or WebPanel.

3. Level : Automatic requirements

Effective only if the manual control switch and the building control switch are in auto mode. There are two types of automatic requirements: "Clock" and "Special" (=special function outside the normal operating times).

At the input "Clock", a weekly clock timer, for instance, is connected, which is included in the normal operation of the system, e.g. weekly timer programme, interval, etc.

Alternatively, a switching information can be connected at the input "Channel" (see FBox "Calendar selection 1.5" for coding) and the switching channel to be used is defined in the FBox. The input "Clock" and the function "Channel" have an equal right, that means a logical OR.

If the parameter "Clock accessed by" is set to the building control system, these functions are deactivated and the FBox anticipates that a visualisation actively describes the parameter "Requirement of Clock".

However, if the BACnet is activated with HMI/hr, all time functions are inactive and the switching function is to be implemented via a scheduler.

3. Enabling and requirement

The output "En" is always high if the system should be asked for a requirement, e.g. switch, time or special function.

The output "Demand" displays a conscious demand of the system, which was parameterised by the user, e.g.

- Manual switch On

- Manual switch Auto, but building control system switch On

- Manual switch and building control system switch Auto, but requirement of a time/switching function

This information can be used to disable special functions, e.g. to forestall a cooling protection.

System function BACnet

If BACnet is enabled, the switch position of FBox System 2 speed Manual will be mapped to the defined priority, but not indicated in the FBox. The parameter HMI higher prio will then display Auto if the resulting system enable from BACnet is identical to the request (regardless of whether the system is OFF or ON). If a different operating mode is forced by BACnet, the corresponding state will be displayed (e.g. OFF or ON).

Option | Object | Note | Description
HMI | MV | Commandable | Switching function Auto/Off/Speed1/Speed2
HMI/clock | MV | - | Clock object for use in a scheduler
HMI/clock | SC | - | Scheduler with reference to clock object

Predefined

HMI higher prio | ModeHiPri | R | 1 = Auromatic
 |  |  | 2 = Off
 |  |  | 3 = Speed 1
 |  |  | 4 = Speed 2
HMI lower prio | ModeLoPri | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = Speed 1
 |  |  | 4 = Speed 2
... calendar channel | Channel | R | 1 = channel 1
 |  |  | 2 = channel 2
 |  |  | 3 = channel 3
 |  |  | 4 = channel 4
 |  |  | 5 = channel 5
 |  |  | 6 = channel 6
 |  |  | 7 = channel 7
 |  |  | 8 = channel 8
 |  |  | 9 = channel 9
 |  |  | 10 = channel 10
 |  |  | 11 = Not used
... Clock accessed by | ClockMode | F | 0 = Input
 |  |  | 1 = SCADA
... Requirement of clock | Clock | R | 1 = Off
 |  |  | 2 = Speed 1
 |  |  | 3 = Speed 2
Demand by operator | Demand | F | 0 = Off
 |  |  | 1 = On
Requirement through special | Special | R | 1 = Off
 |  |  | 2 = Speed 1
 |  |  | 3 = Speed 2
System mode | Required | R | 1 = Off
 |  |  | 2 = Speed 1
 |  |  | 3 = Speed 2


System 2 speed Manual

Family: | DDC 2.5 Systems
Name: | System 2 speed Manual
Macro: | _DDC_SYSWITCH2SPMAN250
Version: | 2.5.000

Description

Connection of a manual switch to the FBox System 2 speed.

Input |
Auto | Switch position Automatic
Sp1 | Switch position speed 1
Sp2 | Switch position speed 2

Functional

The switch position will be transferred to the referenced Fbox, parameter HMI higher prio if BACnet is disabled there. If BACnet is enabled, the manual switch will be mapped to the defined priority, but the switch position will not be indicated in the FBox.


System 3 speed

Family: | DDC 2.5 Systems
Name: | System 3 speed
Macro: | _DDC_SYSWITCH3SP250
Version: | 2.5.000

Description

Enabling of switch for 3-stage systems.

Input |
ClkSp1 | Requirement of clock programs speed 1
ClkSp2 | Requirement of clock programs speed 2
ClkSp3 | Requirement of clock programs speed 3
SpcSp1 | Requirement of special functions, e.g. summer night cooling speed 1
SpcSp2 | Requirement of special functions, e.g. summer night cooling speed 2
SpcSp3 | Requirement of special functions, e.g. summer night cooling speed 3
Channel | Binary coded information calendar channels 1 to 10

Output |
EnSp1 | Required mode for system speed 1
EnSp2 | Required mode for system speed 2
EnSp3 | Required mode for system speed 3
Demand | Demand through switches and clocks (without input Special)

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Settings --- ] |
BACnet > Man. switch priority | Assignment of the physical hand switch in the Priority Array
HMI higher prio | Mode HMI higher priority
HMI lower prio | Mode HMI lower priority
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Priority | Assignment of the virtual switch in the Priority Array
... calendar channel | Selection of the calendar channel 1 to 10
... Clock accessed by | Selection whether the input contact ClkSp1..3 is to be used or the SCADA accessing the clock data
... Requirement of clock | Clock data, either status of the input ClkSp1..3 or accessed by SCADA
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Demand by operator | Demand system through clock or switches, without input Special
Requirement through special | Status of the input SpcSp1..3, e.g. summer night cooling
System mode | Required mode for system, displayed on output EnSp1..3
[ --- Definitionen --- ] |
State-text Auto | State-text Automatic
State-text Off | State-text Off
State-text Speed 1 | State-text Speed 1
State-text Speed 2 | State-text Speed 2
State-text Speed 3 | State-text Speed 3
[ --- DDC Suite V 2.5 --- ] |

Functional

Enabling of switch for 3-stage systems. The enabling of switch has 3 levels:

1. Level : Manual switch, Parameter HMI high prior

As it is rarely available, this is not connected here (it means no FBox inputs available), but can be manually linked with the FBox 3-stage system. This switch has the positions Off - Auto - stage 1 - stage 2 - stage 3. If no manual switch is linked (Name/Ref), the "Auto" position is mandatorily set.

If there is no manual switch available, this parameter can be used for instance for a higher level virtual operation.

If BACnet is activated, the FBox System 2 speed Manual cannot be used. This parameter then shows Auto, if the resulting system enabling of BACnet is identical with the requirement (regardless of whether the system should be Off, stage 1 or stage 2). If a different operating mode is enforced through BACnet, the corresponding status is displayed (e.g. Off, stage 1, stage 2 or stage 3))

2. Level : BC switch, Parameter HMI low prior

Effective only if the manual control switch is on Auto. This switch has the positions Off - Auto - stage 1 - stage 2 - stage 3.

This parameter is normally used in the virtual operation in a SCADA (ViSi.PLus) or WebPanel.

3. Level : Automatic requirements

Effective only if the manual control switch and the building control switch are in auto mode. There are two types of automatic requirements: "Clock" and "Special" (=special function outside the normal operating times).

At the input "Clock", a weekly clock timer, for instance, is connected, which is included in the normal operation of the system, e.g. weekly timer programme, interval, etc.

Alternatively, a switching information can be connected at the input "Channel" (see FBox "Calendar selection 1.5" for coding) and the switching channel to be used is defined in the FBox. The input "Clock" and the function "Channel" have equal rights, that means a logical OR.

If the parameter "Clock accessed by" is set to the building control system, these functions are deactivated and the FBox anticipates that a visualisation actively describes the parameter "Requirement of Clock".

However, if the BACnet is activated with HMI/hr, all time functions are inactive and the switching function is to be implemented via a scheduler.

3. Enabling and requirement

The output "En" is always high if the system should be asked for a requirement, e.g. switch, time or special function.

The output "Demand" displays a conscious demand of the system, which was parameterised by the user, e.g.

- Manual switch On

- Manual switch Auto, but building control system switch On

- Manual switch and building control system switch Auto, but requirement of a time/switching function

This information can be used to disable special functions, e.g. to forestall a cooling protection.

System function BACnet

If BACnet is enabled, the switch position of FBox System 3 speed Manual will be mapped to the defined priority, but not indicated in the FBox. The parameter HMI higher prio will then display Auto if the resulting system enable from BACnet is identical to the request (regardless of whether the system is OFF or ON). If a different operating mode is forced by BACnet, the corresponding state will be displayed (e.g. OFF or ON).

Option | Object | Note | Description
HMI | MV | Commandable | Switching function Auto/Off/Speed1/Speed2/Speed3
HMI/Clock | MV | - | Clock object for use in a scheduler
HMI/Clock | SC | - | Scheduler with reference to clock object

Predefined

HMI higher prio | ModeHiPri | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = Speed 1
 |  |  | 4 = Speed 2
 |  |  | 5 = Speed 3
HMI lower prio | ModeLoPri | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = Speed 1
 |  |  | 4 = Speed 2
 |  |  | 5 = Speed 3
... calendar channel | Channel | R | 1 = channel 1
 |  |  | 2 = channel 2
 |  |  | 3 = channel 3
 |  |  | 4 = channel 4
 |  |  | 5 = channel 5
 |  |  | 6 = channel 6
 |  |  | 7 = channel 7
 |  |  | 8 = channel 8
 |  |  | 9 = channel 9
 |  |  | 10 = channel 10
 |  |  | 11 = Not used
... Clock accessed by | ClockMode | F | 0 = Input
 |  |  | 1 = SCADA
... Requirement of clock | Clock | R | 1 = Off
 |  |  | 2 = Speed 1
 |  |  | 3 = Speed 2
 |  |  | 4 = Speed 3
Demand by operator | Demand | F | 0 = Off
 |  |  | 1 = On
Requirement through special | Special | R | 1 = Off
 |  |  | 2 = Speed 1
 |  |  | 3 = Speed 2
 |  |  | 4 = Speed 3
System mode | Required | R | 1 = Off
 |  |  | 2 = Speed 1
 |  |  | 3 = Speed 2
 |  |  | 4 = Speed 3


System 3 speed Manual

Family: | DDC 2.5 Systems
Name: | System 3 speed Manual
Macro: | _DDC_SYSWITCH3SPMAN250
Version: | 2.5.000

Description

Connection of a manual switch to the FBox System 3 speed.

Input |
Auto | Switch position Automatic
Sp1 | Switch position speed 1
Sp2 | Switch position speed 2
Sp3 | Switch position speed 3

Functional

The switch position will be transferred to the referenced Fbox, parameter HMI higher prio if BACnet is disabled there. If BACnet is enabled, the manual switch will be mapped to the defined priority, but the switch position will not be indicated in the FBox.


System Heating circuit

Family: | DDC 2.5 Systems
Name: | System Heating circuit
Macro: | _DDC_SYSHEATCIRC250
Version: | 2.5.000

Description

Set point calculation and enabling for a static heater circuit.

Input |
Winter | Enable heating circuit during winter time
Day | Day mode
OutTemp | Outdoor air temperature
FrostTmp | Frost-protection temperature
Off | e,g, priority circuit water heater, stop heating circuit
Channel | Binary coded information calendar channels 1 to 10

Output |
En | Reccomended state
Day | Heating circuit day operation
SetPt | Set point inflow temperature

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Switching --- ] |
BACnet > Man. switch priority | Assignment of the physical hand switch in the Priority Array
HMI higher prio | Mode HMI higher priority
HMI lower prio | Mode HMI lower priority
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Priority | Assignment of the virtual switch in the Priority Array
... Clock accessed by | Selection whether the input Day is to be used or the SCADA accessing the Day flag
... calendar channel | Selection of the calendar channel 1 to 10
... Requirement of clock | Day flag, either status of the input Day or accessed by SCADA
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Night reduction set point | Reduction set point inflow temperature in night mode
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
Limit outdoor temp. Day | Outdoor air temperatur limit during day mode
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
Limit outdoor temp. Night | Outdoor air temperatur limit during night mode
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
Outdoor temp. limit hysteresis | Outdoor air temperatur limit hysteresis
Frost limit value On | Heating circuit on in frost mode below the limit value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
Frost limit value Off | Heating circuit off in frost mode above the limit value
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
HeatUp Floor / Chimney (hrs) | Duratioin of the floor heating or chimney sweep mode
Required mode | Requirement status Heating circuit
Operation mode | Operating status Heating circuit
Set point heating circuit | Current Set point inflow temperature
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
[ --- Heat curve --- ] |
Calculated set point | Resultant Set point from the heat curve
(X1) Outdoor air temperature | Outside temperature curve point 1
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
(Y1) associated Set point | Set point for outside temperature curve point 1
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
(X2) Outdoor air temperature | Outside temperature curve point 2
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
(Y2) associated Set point | Set point for outside temperature curve point 2
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
(X3) Outdoor air temperature | Outside temperature curve point 3
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
(Y3) associated Set point | Set point for outside temperature curve point 3
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
(X4) Outdoor air temperature | Outside temperature curve point 4
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
(Y4) associated Set point | Set point for outside temperature curve point 4
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
[ --- DDC Suite V 2.5 --- ] |

Functional

Set point calculation and enabling for a static heater circuit. The enabling has 3 levels:

1. Level : Manual switch, Parameter HMI high prior

As it is rarely available, this is not connected here (it means no FBox inputs available), but can be manually linked with the heater circuit system FBox. This switch has the positions Auto - Frost - Night - Day. If there is no manual switch linked (Name/Ref), the "Auto" position is mandatorily set.

If there is no manual switch available, this parameter can be used for instance for a higher level virtual operation.

If BACnet is activated, the FBox manual heater circuit system cannot be used. This parameter then shows Auto, if the resulting system enabling of BACnet is identical with the requirement (regardless of whether the system should be Off or On). If a different operating mode is enforced through BACnet, the corresponding status is displayed (e.g. On or Off)

2. Level : BC switch, Parameter HMI low prior

Effective only if the manual control switch is on Auto. This switch has the positions Off - Auto - Frost - Night - Day - IB flooring - Chimney sweep.

This parameter is normally used in the virtual operation in a SCADA (ViSi.PLus) or WebPanel.

3. Level : Automatic requirements

Effective only if the manual control switch and the building control switch are in auto mode.

If enabling is absent at input "Winter", the heater circuit is locked for the automatic function.

At the input "Day", a weekly clock timer, for instance, is connected, which is included in the normal operation of the system, e.g. weekly timer programme, interval, etc.

Alternatively, a switching information can be connected at the input "Channel" (see FBox "Calendar selection 1.5" for coding) and the switching channel to be used is defined in the FBox. The input "Clock" and the function "Channel" have equal rights, that means a logical OR.

If the parameter "Clock accessed by" is set to the building control system, these functions are deactivated and the FBox anticipates that a visualisation actively describes the parameter "Requirement of Clock".

However, if the BACnet is activated with HMI/Clock, all time functions are inactive and the switching function is to be implemented via a scheduler.

The heat limit of the outside air temperature determine the set point of the heater circuit at 20°C, if the outside air temperature exceeds this limit value, even if a calculated set point greater than 21°C is present from the heat curve.

The individual operating modes are as follows:

- Off : The heater circuit remains turned off, the outputs "En" and "Day" are low, the set point "SetPt" at 20 °C

- Frost : The heater circuit remains turned off till the frost temperature (input "FrostTmp", outside temperature or ambient temperature) falls below the turn-on limit value. The output "En" is high, output "Day" is low, and the set point is calculated from the computed set point of the heat curve. The heater circuit is turned-off again if the frost protection temperature rises above the turn-off limit value. The priority circuit doesn't turn off the heater circuit if it was turned on.

- Night: The heater circuit is enabled, the output "En" is high, "Day" is low, and the set point is calculated from the computed set point of the heat curve minus the night setback. The priority circuit turns off the heater circuit.

- Day: The heater circuit is enabled, the output "En" and "Day" is high, and the set point is calculated from the computed set point of the heat curve. The priority circuit turns off the heater circuit.

- Chimney sweep: The heater circuit is driven for the duration of the parameter FB heating/chimney sweep (hr) at the set point of the heat curve Y1. After the time runs out, the heater circuit automatically switches back to the operating mode set before.

- Start up of floor heating : The heater circuit is driven for the duration of the parameter FB heating/chimney sweep (hr) of 21°C at the set point of the heat curve Y1. After the time runs out, the heater circuit automatically switches to the automatic mode.

System function Offline Trending

The set point of the heater circuit can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function BACnet

If BACnet is enabled, the switch position of FBox System Heating circuit Man will be mapped to the defined priority, but not indicated in the FBox. The parameter HMI higher prio will then display Auto if the resulting system enable from BACnet is identical to the request (regardless of whether the system is OFF or ON). If a different operating mode is forced by BACnet, the corresponding state will be displayed (e.g. OFF or ON).

Option | Object | Note | Description
HMI | MV | Commandable | Switching function Auto/Off/Frost/Night/Day
HMI/Clk | BV | - | Clock object for use in a scheduler
HMI/ Clk | SC | - | Scheduler with reference on Clock object
HMI/Clk/Par | AV | - | Set point heater circuit
HMI/Clk/Par | TR | optional | Set point heater circuit
HMI/Clk/Par | AV | - | Night setback
HMI/Clk/Par | AV | - | Heat limit outside temperature Night
HMI/Clk/Par | AV | - | Heat limit outside temperature Day
HMI/Clk/Par | AV | - | Frost function limit value Off
HMI/Clk/Par | AV | - | Frost function limit value On
HMI/Clk/Par/Y | AV | - | Set point curve Y1
HMI/Clk/Par/Y | AV | - | Set point curve Y2
HMI/Clk/Par/Y | AV | - | Set point curve Y3
HMI/Clk/Par/Y | AV | - | Set point curve Y4
HMI/Clk/Par/Y/X | AV | - | Outside temperature curve X1
HMI/Clk/Par/Y/X | AV | - | Outside temperature curve X2
HMI/Clk/Par/Y/X | AV | - | Outside temperature curve X3
HMI/Clk/Par/Y/X | AV | - | Outside temperature curve X4

Predefined

HMI higher prio | ModeHiPri | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = Frost
 |  |  | 4 = Night
 |  |  | 5 = Day
 |  |  | 6 = HeatUp Floor
 |  |  | 7 = Chimney sweep
HMI lower prio | ModeLoPri | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = Frost
 |  |  | 4 = Night
 |  |  | 5 = Day
 |  |  | 6 = HeatUp Floor
 |  |  | 7 = Chimney sweep
... Clock accessed by | ClockMode | F | 0 = Input
 |  |  | 1 = SCADA
... calendar channel | Channel | R | 1 = channel 1
 |  |  | 2 = channel 2
 |  |  | 3 = channel 3
 |  |  | 4 = channel 4
 |  |  | 5 = channel 5
 |  |  | 6 = channel 6
 |  |  | 7 = channel 7
 |  |  | 8 = channel 8
 |  |  | 9 = channel 9
 |  |  | 10 = channel 10
 |  |  | 11 = Not used
... Requirement of clock | Clock | F | 0 = Night
 |  |  | 1 = Day
Night reduction set point | NightReduct | R | 0..300
Limit outdoor temp. Day | ToLimDay | R | 0..300
Limit outdoor temp. Night | ToLimNight | R | 0..300
Outdoor temp. limit hysteresis | ToHyst | R | 0..100
Frost limit value On | FrostLimOn | R | 0..300
Frost limit value Off | FrostLimOff | R | 0..300
HeatUp Floor / Chimney (hrs) | FloorHeatDur | R | 0..240
Required mode | Demand | R | 1 = Off
 |  |  | 2 = Night
 |  |  | 3 = Day
 |  |  | 4 = Priority Off act.
Operation mode | Status | R | 1 = Off
 |  |  | 2 = Night
 |  |  | 3 = Day
Set point heating circuit | SetPt | R |
Calculated set point | SetPtCurve | R |
(X1) Outdoor air temperature | CurveX1 | R | -300..300
(Y1) associated Set point | CurveY1 | R | 150..1000
(X2) Outdoor air temperature | CurveX2 | R | -300..300
(Y2) associated Set point | CurveY2 | R | 150..1000
(X3) Outdoor air temperature | CurveX3 | R | -300..300
(Y3) associated Set point | CurveY3 | R | 150..1000
(X4) Outdoor air temperature | CurveX4 | R | -300..300
(Y4) associated Set point | CurveY4 | R | 150..1000


System Heating circuit Man

Family: | DDC 2.5 Systems
Name: | System Heating circuit Man
Macro: | _DDC_SYSHEATCIRCMAN250
Version: | 2.5.000

Description

Connection of a manual switch to the FBox heater circuit system.

Input |
Auto | Switch position Automatic
Frost | Switch position Frost protection
Night | Switch position Night mode
Day | Switch position Day mode

Functional

The switch position will be transferred to the referenced Fbox, parameter HMI higher prio if BACnet is disabled there. If BACnet is enabled, the manual switch will be mapped to the defined priority, but the switch position will not be indicated in the FBox.


System boiler

Family: | DDC 2.5 Systems
Name: | System boiler
Macro: | _DDC_SYBOILER250
Version: | 2.5.000

Description

Enabling of a boiler plant according to outside temperature or according to consumer load

Input |
Winter | Enable heating circuit during winter time
OutTemp | Outdoor air temperature
SetPtCon | Set point demand of consumer

Output |
En | Reccomended state
SetPt | Set point boiler temperature

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Switching --- ] |
BACnet > Man. switch priority | Assignment of the physical hand switch in the Priority Array
HMI higher prio | HMI higher priority
HMI lower prio | HMI lower priority
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Priority | Assignment of the virtual switch in the Priority Array
Limit Outdoor temp.. | Outdoor air temperatur limit
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
Set point of consumer | Set point of input SetPtCon (demand on consumer)
Set point from curve | Calculated Set point acc. to outdoor temperature curve
Increase requestet set point | Additional hysteresis to required set point
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
Boiler system set point | Resultant set point of the boiler system
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Winter period | Status of input Winter
Boiler system | Enable boiler system
[ --- Heat curve --- ] |
(X1) Outdoor air temperature. | Outdoor air temperature curve point 1
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
(Y1) associated Set point | Boiler set point curve point 1
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
(X2) Outdoor air temperature. | Outdoor air temperature curve point 2
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
(Y2) associated Set point | Boiler set point curve point 2
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
(X3) Outdoor air temperature. | Outdoor air temperature curve point 3
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
(Y3) associated Set point | Boiler set point curve point 3
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
(X4) Outdoor air temperature. | Outdoor air temperature curve point 4
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
(Y4) associated Set point | Boiler set point curve point 4
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
[ --- DDC Suite 2.5 --- ] |

Functional

Enabling of a boiler plant depending on consumer load or outside temperature. The enabling has 3 levels:

1. Level : Manual switch, Parameter HMI high prior

As it is rarely available, this is not connected here (it means no FBox inputs available), but can be linked with the FBox boiler manual system. This switch has the positions Auto requirement - Auto OutTemp - On. If there is no manual switch linked (Name/Ref), the "Auto requirement" position is mandatorily set.

If there is no manual switch available, this parameter can be used for instance for a higher level virtual operation.

If BACnet is activated, the FBox boiler manual system cannot be used. This parameter then shows Auto, if the resulting system enabling of BACnet is identical with the requirement (regardless of whether the system should be Off or On). If a different operating mode is enforced through BACnet, the corresponding status is displayed (e.g. On or Off)

2. Level : BC switch, Parameter HMI low prior

Effective only if the manual control switch is on Auto requirement. This switch has the positions Off - Auto requirement - Auto OutTemp - On.

This parameter is normally used in the virtual operation in a SCADA (ViSi.PLus) or WebPanel.

3. Level : Automatic requirements

Effective only if the manual control switch and the building control switch are in auto mode.

- Requirement: The boiler plant is enabled if a high is present at input "Winter" (heating period), the outside air temperature is below the limit value "Heat limit OutdoorTemp." , and the set point "SetPt" at the input plus the "Increase requested set point" is greater than or equal to the minimum set point of the curve (Y4).

- curve: The boiler plant is enabled if a high is present at input "Winter" (heating period), the outside air temperature is below the limit value "Heat limit OutdoorTemp", and the calculated set point according to outside curve is greater than or equal to the minimum set point of the curve (Y4).

- Duration: The set point Y1 is issued independent of the outside temperature or the input "Winter".

System function Offline Trending

The set point of storage unit (mean value from turn-on/off limit value) can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function BACnet

If BACnet is enabled, the switch position of FBox System Boiler Manual will be mapped to the defined priority, but not indicated in the FBox. The parameter HMI higher prio will then display Auto if the resulting system enable from BACnet is identical to the request (regardless of whether the system is OFF or ON). If a different operating mode is forced by BACnet, the corresponding state will be displayed (e.g. OFF or ON).

Option | Object | Note | Description
HMI | MV | Commandable | Switching function Auto requirement/Auto AT/Off/On
HMI | AV | - | Set point boiler system
HMI | TR | optional | Set point boiler system
HMI/Par | AV | - | Heat limit value outside air temp.
HMI/Par | AV | - | Raising of set point load
HMI/Par/Y-Values | AV | - | Set point curve Y1
HMI/Par/Y-Values | AV | - | Set point curve Y2
HMI/Par/Y-Values | AV | - | Set point curve Y3
HMI/Par/Y-Values | AV | - | Set point curve Y4
HMI/Par/X/Y-Values | AV | - | Outside temperature curve X1
HMI/Par/X/Y-Values | AV | - | Outside temperature curve X2
HMI/Par/X/Y-Values | AV | - | Outside temperature curve X3
HMI/Par/X/Y-Values | AV | - | Outside temperature curve X4

Predefined

HMI higher prio | ModeHiPri | R | 1 = Auto (consumer)
 |  |  | 2 = Auto (Curve)
 |  |  | 3 = Off
 |  |  | 4 = On
HMI lower prio | ModeLoPri | R | 1 = Auto (consumer)
 |  |  | 2 = Auto (curve)
 |  |  | 3 = Off
 |  |  | 4 = On
Limit Outdoor temp.. | ToLimit | R | 0..300
Set point of consumer | SetPtDemand | R |
Set point from curve | SetPtCurve | R |
Increase requestet set point | SetPtAdd | R | 0..300
Boiler system set point | SetPt | R |
Winter period | Winter | F | 0 = Off
 |  |  | 1 = On
Boiler system | Required | F | 0 = Off
 |  |  | 1 = On
(X1) Outdoor air temperature. | CurveX1 | R | -300..300
(Y1) associated Set point | CurveY1 | R | 150..900
(X2) Outdoor air temperature. | CurveX2 | R | -300..300
(Y2) associated Set point | CurveY2 | R | 150..900
(X3) Outdoor air temperature. | CurveX3 | R | -300..300
(Y3) associated Set point | CurveY3 | R | 150..900
(X4) Outdoor air temperature. | CurveX4 | R | -300..300
(Y4) associated Set point | CurveY4 | R | 150..900


System boiler Manual

Family: | DDC 2.5 Systems
Name: | System boiler Manual
Macro: | _DDC_SYBOILERMAN250
Version: | 2.5.000

Description

Connection of a manual switch to the FBox boiler system.

Input |
AutoCons | Switch position Automatic (consumer demand)
AutoOutT | Switch position Automatic (outdoor temp.)
On | Switch position On

Functional

The switch position will be transferred to the referenced Fbox, parameter HMI higher prio if BACnet is disabled there. If BACnet is enabled, the manual switch will be mapped to the defined priority, but the switch position will not be indicated in the FBox.


System Hot water

Family: | DDC 2.5 Systems
Name: | System Hot water
Macro: | _DDC_SYHOTWATER250
Version: | 2.5.000

Description

Enabling of a water heater with anti-legionella switching.

Input |
Clock | Requirement of water heater from weekly timer
Ttop | Hot water tank temperature on top
Tbot | Hot water tank temperature on bottom
Ala | General alarm to stop hot water system
Channel | Binary coded information calendar channels 1 to 10

Output |
En | Reccomended state
Disinfec | Disinfection (legionella) prevention active
SetPtInf | Set point inflow temperature charging circuit
SetPtHw | Mean set point = average of swtich on limit and switch off limit
TempHw | Mean temperature = average of top and bottom tempeature
Priority | Priority circuit active

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
PCD Offline Trending (KB) | If value > 0, enables and reserves (number of KBs) historical record of value in data blocks (FBox HDLog Init required).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Switching --- ] |
BACnet > Man. switch priority | Assignment of the physical hand switch in the Priority Array
HMI higher prio | HMI higher priority
HMI lower prio | HMI lower priority
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- Priority | Assignment of the virtual switch in the Priority Array
... calendar channel | Selection of the calendar channel 1 to 10
... Clock accessed by | Selection whether the input Clock is to be used or the SCADA accessing the Day flag
... Requirement of clock | Clock flag, either status of the input Clock or accessed by SCADA
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Switch on below °C | Switch on limit hot water tank temperature (Ttop)
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
Switch off higher than °C | Switch off limit hot water tank temperature (Tbot)
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
<--- BACnet Trendlog ---> | Select whether and how a Trendlog Object should be created with reference to the previously listed BACnet Object.
- Object-Name | Detailed information for Trendlog Object Name. It consists of the AKS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Trendlog Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Buffer size | Size of Trendlog Buffer in the File System. Indicate the number of records.
- Log Interval (s) | Interval for a record. Cyclic recording is disabled with a value of 0; recording will then occur after COV (recommended).
Hystersis charging temp. °C | Hystersis to be added for the set point charging circuit
Set point charging temp. °C | Set point inflow temperature charging circuit
Hot water tank | Status of the hot water system
System status | Group alarm to block the hot water system
[ --- Disinfection --- ] |
Mode | Selection disinfection (legionella) prevention
Day (Mode:Automatic) | Weekday of the disinfection (legionella) prevention
Clock time (Mode:Automatic) | Clock time of the disinfection (legionella) prevention
Heat up to °C | Heat up hot water to this limit during disinfection
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
Max disinf. duration (minutes) | Maximum operating time of the disinfection (legionella) prevention
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
Disinfection prevention | Status of the disinfection (Legionella) prevention
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- Priority --- ] |
Mode | Selection to stop heating circuit of hot water system acitve
Max. priority duration (min.) | Maximum operating time of the priority circuit
Priority status | Status of the priority circuit
[ --- DDC Suite V 2.5 --- ] |

Functional

Water heating with anti-legionella switching. The enabling has 3 levels:

1. Level : Manual switch, Parameter HMI high prior

As it is rarely available, this is not connected here (it means no FBox inputs available), but can be linked with the FBox Hot Water system Manual. This switch has the positions Auto - On. If there is no manual switch linked (Name/Ref), the "Auto" position is mandatorily set.

If there is no manual switch available, this parameter can be used for instance for a higher level virtual operation.

If BACnet is activated, the FBox Hot Water system Manual cannot be used. This parameter then shows Auto, if the resulting system enabling of BACnet is identical with the requirement (regardless of whether the system should be Off or On). If a different operating mode is enforced through BACnet, the corresponding status is displayed (e.g. On or Off)

2. Level : BC switch, Parameter HMI low prior

Effective only if the manual control switch is on Auto. This switch has the positions Off - Auto - On.

This parameter is normally used in the virtual operation in a SCADA (ViSi.PLus) or WebPanel.

3. Level : Automatic requirements

Effective only if the manual control switch and the building control switch are in auto mode. In the Auto position, water is heated according to the input "Clock". In the On position, the heater is in continuous operation. In the Off position, the anti-legionella switching is also inactive.

If the measurement reading at "Ttop" (storage temperature above) falls below the parameter turn-on below °C, the water heater is turned on (output "En"). If the measurement reading at "Tbot" (storage temperature below) exceeds the parameter turn-off above °C, the water heater is turned off. If there is only one storage temperature available, it is to be linked to "Ttop" and "Tbot".

Alternatively, a switching information can be connected at the input "Channel" (see FBox "Calendar selection 1.5" for coding) and the switching channel to be used is defined in the FBox. The input "Clock" and the function "Channel" have equal rights, that means a logical OR.

If the parameter "Clock accessed by" is set to the building control system, these functions are deactivated and the FBox anticipates that a visualisation actively describes the parameter "Requirement of clock".

However, if the BACnet is activated with HMI/Clock, all time functions are inactive and the switching function is to be implemented via a scheduler.

Anti-legionella switching

The anti-legionella switching can be preset via a building control system switch. There is no anti-legionella operation in the Off position. In the position Auto, it is undertaken once a week or daily, on a fixed day at a certain time. If the anti-legionella mode is active, the output "Disinfec" is set. The water heater is heated up to the heating temperature of °C. If this temperature is not attained, the anti-legionella mode is completed after the maximum heating duration.

Priority circuit

The priority circuit can be activated via a building control system switch. If this is on Auto, the output "Priority" is set for each turn-on of the water heater, with which, if need be, static heater loops are turned off to favour the storage charge. A maximum duration of the priority circuit can be set to prevent a long shut down by the heater loops influenced by the priority circuit. If the required tap water temperature is not reached after expiry of this time, the output "Priority" is reset, but the water heater continues to operate.

Charging circuit

If the enabling of the water heater (normal mode or legionella mode) takes place, a required charging temperature for a potentially available primary control loop is determined. This is calculated in

- Normal mode from turn-off above °C hysteresis charging temperature °C

- Legionella mode from heating at °C hysteresis charging temperature °C

If the water heater is inactive, the set point amounts to 20°C.

System function Offline Trending

The set point of storage unit (mean value from turn-on/off limit value) can be parameterised for the historic data logging. A value more than 0 activates the recording. In the symbol editor, a symbol is created with the name of the FBox in the "Tab" "System" in the group "A.HDLog", which is provided for application in the SWeb Trendmacro.

System function BACnet

f BACnet is enabled, the switch position of FBox System Hot water Manual will be mapped to the defined priority, but not indicated in the FBox. The parameter HMI higher prio will then display Auto if the resulting system enable from BACnet is identical to the request (regardless of whether the system is OFF or ON). If a different operating mode is forced by BACnet, the corresponding state will be displayed (e.g. OFF or ON).

Option | Object | Note | Description
HMI | MV | Commandable | Switching function Auto/Off/On
HMI/Clk | BV | - | Clock object for use in a scheduler
HMI/Clk | SC | - | Scheduler with reference on clock object
HMI/Clk/Par | AV | - | Set point hot water (average limit value On/Off)
HMI/ClkPar | TR | optional | Set point hot water (average limit value On/Off)
HMI/Clk/Par | AV | - | Limit value Off
HMI/Clk/Par | AV | - | Limit value On
HMI/Clk/Par/DisClk | BV | - | Clock object for use in an anti-legionella scheduler
HMI/Clk/Par/DisClk | SC | - | Scheduler with reference on clock object
HMI/Clk/Par/DisAll | AV | - | Heating-up LV of anti-legionella switching
HMI/Clk/Par/DisAll | AV | - | Max. operating time of anti-legionella switching

Predefined

HMI higher prio | ModeHiPri | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = On
HMI lower prio | ModeLoPri | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = On
... calendar channel | Channel | R | 1 = channel 1
 |  |  | 2 = channel 2
 |  |  | 3 = channel 3
 |  |  | 4 = channel 4
 |  |  | 5 = channel 5
 |  |  | 6 = channel 6
 |  |  | 7 = channel 7
 |  |  | 8 = channel 8
 |  |  | 9 = channel 9
 |  |  | 10 = channel 10
 |  |  | 11 = Not used
... Clock accessed by | ClockMode | F | 0 = Input
 |  |  | 1 = SCADA¨
... Requirement of clock | Clock | F | 0 = Off
 |  |  | 1 = On
Switch on below °C | LimOn | R | 0..1000
Switch off higher than °C | LimOff | R | 0..1000
Hystersis charging temp. °C | OffsetInflow | R | 0..1000
Set point charging temp. °C | SetPtInflow | R |
Hot water tank | Required | F | 0 = Off
 |  |  | 1 = On
System status | GrpAla | F | 0 = ok
 |  |  | 1 = BLOCKED
Mode | DisMode | R | 1 = Automatic
 |  |  | 2 = Off
 |  |  | 3 = SCADA
Day (Mode:Automatic) | DisDay | R | 1 = Monday
 |  |  | 2 = Tuesday
 |  |  | 3 = Wednesday
 |  |  | 4 = Thursday
 |  |  | 5 = Friday
 |  |  | 6 = Saturday
 |  |  | 7 = Sunday
 |  |  | 8 = Daily
Clock time (Mode:Automatic) | DisTime | R | 0..2359
Heat up to °C | DisLimOff | R | 0..1000
Max disinf. duration (minutes) | DisMaxTime | R | 0..1000
Disinfection prevention | DisRequired | F | 0 = Off
 |  |  | 1 = On
Mode | PriMode | F | 0 = Off
 |  |  | 1 = Automatic
Max. priority duration (min.) | PriTime | R | 0..1440
Priority status | PriRequired | F | 0 = Off
 |  |  | 1 = On


System Hot water Manual

Family: | DDC 2.5 Systems
Name: | System Hot water Manual
Macro: | _DDC_SYHOTWATERMAN250
Version: | 2.5.000

Description

Connection of a manual switch to the FBox System Hot Water.

Input |
Auto | Switch position Automatic
On | Switch position On

Functional

The switch position will be transferred to the referenced Fbox, parameter HMI higher prio if BACnet is disabled there. If BACnet is enabled, the manual switch will be mapped to the defined priority, but the switch position will not be indicated in the FBox.


Fan Start

Family: | DDC 2.5 Systems
Name: | Fan Start
Macro: | _DDC_SYAHUSTART250
Version: | 2.5.002

Description

Sequential start operation for ventilation systems.

Input |
Start | Start sequence (air condition)
fbDamper | Feedback damper Open
Ala | General alarm to stop and clear all outputs
PreHReT | Preheater return flow temperature
AlaFrost | Alarm frost ptotection active
Dehumid | Dehumidification active (dehumidify from controller)
SNCool | summer night cooling
FrstProt | Frost protection (e.g. room temp. monitoring)
FrcdCool | Forced cooling
SplyTemp | Supply air temperature

Output |
WarmUp | Preheater warm up
Damper | Open damper
SplyFan | Turn on supply air motor
ExhstFan | Turn on exhaust air motor
Contr | Start controller, e.g. preheater, cooler
SplyRamp | Ramp function supply air terminated active
SetPtMon | Start set point monitoring
SplyStPt | Set point of supply air temperature during ramp time

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Delays --- ] |
Warm up preheater (s) | Maximum duration warm up preheater
Delay Supply/Exhaust fan (s) | Delay between supply/exhaust air fan start
Delay Fan/Controller (s) | Delay between fan/controller start
Ramp SetPt supply air temp (s) | Ramp time for the et point supply air temperature
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
Delay SetPt monitoring (s) | Delay between controller/limit monitoring
Remaining delay time (s) | Current remaining delay time
[ --- Limit values --- ] |
No warm up at Outdoor > °C | Outdoor temp. limit warm up preheater
Warm up ends PreHRetTemp. > °C | Min. return flow temperature to stop warm up
Min SetPt supply air temp. | Minimum supply air set point for ramp
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
- COV increment | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
[ --- Status --- ] |
Warm up | Preheater warm up
Damper | Open damper
Supply air fan | Turn on supply air motor
Exhaust air fan | Turn on exhaust air motor
Controller | Start controller, e.g. preheater, cooler
Supply air SetPt ramp | Ramp function supply air terminated active
Set point supply air temeprature | Current supply air temperature set point
Set point monitoring | Start set point monitoring
[ --- DDC Suite V 2.5 --- ] |

Functional

This FBox collects all important plant conditions (dehumidification, cooling protection, etc.) and provides the other FBoxes by the Name/Ref mechanism, particularly for the ventilation-specific FBoxes of the controller family.

It enables in sequence the system components of a ventilation plant. If the input "Start" low or input "Ala" high, all outputs are immediately switched off. The start sequence is activated with the enabling (input "Start").

Pre-flushing of preheater

The pre-flushing of the preheater (output "WarmUp", shouldn't be connected further) is activated (see also FBox controller preheater). The pre-flushing heats the preheater through pumped hot water to prevent a frost signal when starting the fans in winter.

The pre-flushing is completed if:

- The outside temperature is greater than the limit value at the end of pre-flushing when the outside temperature is °C

- Or the return temperature is greater than the limit value of pre-flushing till return temperature of preheater is °C

- But the maximum would be the duration of the heater's pre-flushing

Open flap

After the termination of the pre-flushing, the enabling of the flap drives takes place (output "Damper"). The start sequence is continued only after the Open feedback of the flap drives (input "fbDamper"). In case of mixed air, a binary "H" can be connected here for example as there is always an air way open.

Supply air blower

If the Open feedback of the flaps is available, the supply air motor is enabled (output "SplyFan")

Exhaust air blower

After enabling of the supply air motor, a delay is actuated which prevents a peak in demand with simultaneous starting of large motors. After the completion of this delay, the exhaust air motor is enabled (output "ExhstFan")

Exhaust air blower

After the exhaust motor is enabled, a delay is actuated to facilitate the fans in building up a stable quantity of air and to release potentially existing surplus heat through the pre-flushing phase. After the delay is over, the control is enabled (output "Contr", to connect to the input "EnContr" of the controller FBoxes)

Set point ramp of supply air temperature

With the enabling of the control, the set point ramp of the supply air temperature also starts. By the delayed enabling of the control, any potentially existing excess heat would have been already removed. Anyhow, the supply air temperature can be clearly too high, for example by a badly set cold start value of the preheater. To prevent an excessive control jump with surges and danger of a frost signal with control enabling, the set point ramp can be utilised.

With the enabling of the control, the actual value of the supply air temperature (input "SplyTemp") is stated as set point at the output "SplyStPt". Subsequently, this set point decreases over the set duration to the ramp end value (a ramp up also functions).

In the process, the preheater controller (as a rule it is this) starts with a zero deviation and then slowly follows the set point.

This set point of the supply air temperature should only be combined with, as the case maybe, the set point of the supply air temperature of a master controller. Normally, the "bigger" selection is used here.

Limit value monitoring

After the course of the set point ramp, a delay is actuated. After the completion of this delay, the limit value monitoring is enabled (output "SetPtMon"). This output can then for example be connected to the FBoxes limit value sliding of the family alarming.

In the process, the control can be given sufficient time to reach the working point before a monitoring of the set point is activated.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option Object | Note | Description |
SetPt Ramp | AV | - | Final value setpoint
SetPr Ramp | AV | - | Ramp duration (seconds)

Predefined

Warm up preheater (s) | WarmUpTime | R | 0..6000
Delay Supply/Exhaust fan (s) | ExhFanTime | R | 0..6000
Delay Fan/Controller (s) | ContrTime | R | 0..6000
Ramp SetPt supply air temp (s) | RampTime | R | 0..360000
Delay SetPt monitoring (s) | MenTime | R | 0..6000
Delay SetPt monitoring (s) | MenTime | R | 0..6000
No warm up at Outdoor > °C | ToLim | R | 0..500
Warm up ends PreHRetTemp. > °C | RetFlowLim | R | 0..500
Min SetPt supply air temp. | SetPtMin | R | 0..1000
Warm up | WarmUp | F | 0 = -
 |  |  | 1 = OK
Damper | Damper | F | 0 = -
 |  |  | 1 = Open
Supply air fan | SupplyFan | F | 0 = -
 |  |  | 1 = Run
Exhaust air fan | ExhaustFan | F | 0 = -
 |  |  | 1 = Run
Controller | Controller | F | 0 = -
 |  |  | 1 = Active
Supply air SetPt ramp | SetPtRamp | F | 0 = -
 |  |  | 1 = Done
Set point supply air temeprature | SetPt | R |
Set point monitoring | Monitoring | F | 0 = -
 |  |  | 1 = Enable


Fan Special func.

Family: | DDC 2.5 Systems
Name: | Fan Special func.
Macro: | _DDC_SYAHUPRESERVE250
Version: | 2.5.000

Description

Free cooling (summer night cooling), cooling protection and enforced cooling (machine cooling) for ventilation systems.

Input |
Demand | Demand through switches and clocks from System 1/2/3 speed FBox
EnSNCool | Activate summer night cooling monitoring
Value | Actual value, e.g.room or exhaust air temperature
SetPoint | Set point of room or exhaust air temperature

Output |
SNCool | Request summer night cooling
FrstProt | Request frost protection
FrcdCool | Request forced cooling
SpcSp1 | Requirement fan speed 1
SpcSp2 | Requirement fan speed 2
SpcSp3 | Requirement fan speed 3

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Summer night cooling --- ] |
HMI | Mode summer night cooling
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Functionality active | Activate summer night cooling monitoring (input EnSNCool)
Summer night cooling | Display demand summer night cooling
(1) Outdoor air temperature |
Minimum temperature | Min. outdoor air temperature summer night cooling
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
Hysteresis room/outdoor (On) | Hysteresis between room temperature and outdoor air temperature as criterion for switching on
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
Hysteresis room/outdoor (Off) | Hysteresis between room temperature and outdoor air temperature as criterion for switching off
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
State | Display Requirement for outdoor temperature comparisons
(2) Room temperature |
Hysteresis room temp./SetPt | Hysteresis between room temperature and Set point outdoor air temperature as criterion for switching on
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
State | Display Requirement for room temperature comparisons
[ --- Frost protection --- ] |
HMI | Mode frost protection
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
State | Display demand frost protection
On at room temp lower than | Switch on limit frost protection
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
Off at room temp higher than | Switch off limit frost protection
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
[ --- Forced cooling --- ] |
HMI | Mode forced cooling
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
State | Display demand forced cooling
Switch on hysteresis | Hysteresis of Set point room temp to room temp for switching on
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
Switch off hysteresis | Hysteresis of Set point room temp to room temp for switching off
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
[ --- DDC Suite V 2.5 --- ] |

Functional

All 3 following functions are only active if the input "Demand" is low. This information comes normally from the FBoxes x-stage system and prevents the activation of one of the following functions by adverse setting.

The outputs "SNCool", "FrstProt" and "FrcdCool" are connected to the FBox start ventilation, the outputs "Sp.." are linked as a rule to the inputs "Special.." of the FBoxes x-stage system.

Cooling/Frost protection

This function prevents a too strong cooling of rooms during long downtimes of ventilation systems (e.g. in winter holidays). The cooling protection has the highest priority of all 3 functions.

Starting conditions:

- Preselection Auto (Sp1/Sp2/Sp3)

- And room temperature of smaller starting limit value

Switch-off conditions:

- Preselection Off

- Or preselection Auto

- And ambient temperature of larger switch-off limit value

Free cooling/Summer night cooling

In balmy summer nights, the ventilation can cool the rooms in favourable weather conditions, in which the cool outside air is blown in without after-treatment (preheater, cooler, etc., remain turned off). This saves costs as machine cooling is not required.

Starting conditions:

- Preselection Auto (Sp1/Sp2/Sp3)

- And outside air temperature greater than minimum temperature

- And actual value of ambient temperature is greater than outside air temperature hysteresis On

- And actual value of ambient temperature is greater than set point of room set point hysteresis On

Switch-off conditions:

- Preselection Off

- Or outside air temperature of lower minimum temperature

- Or actual value of ambient temperature is lower than outside air temperature hysteresis Off

- Or actual value of ambient temperature = Set point of ambient temperature

Enforced cooling/Machine cooling

This function comes into action if the ambient temperature is too high and a summer night cooling is not possible by a too high outside air temperature.

Starting conditions:

- Preselection Auto (Sp1/Sp2/Sp3)

- And actual value of ambient temperature is greater than set point of ambient temperature starting hysteresis

Switch-off conditions:

- Preselection Off

- Or preselection Auto

- And ambient temperature is lower than the set point of ambient temperature switch-off hysteresis

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
SNC | MV | Commandable | Switching function Off/Auto Stage 1..3
SNC | AV | - | Minimum outside air temperature
SNC | AV | - | Hysteresis of outside temperature/ambient temperature On
SNC | AV | - | Hysteresis of outside temperature/ambient temperature Off
SNC | AV | - | Hysteresis of set point/actual value ambient temperature
SNC/FrstProt | MV | Commandable | Switching function Off/Auto Stage 1..3
SNC/FrstProt | AV | - | Turn-on limit value
SNC/FrstProt | AV | - | Turn-off limit value
SNC/FrstProt/FrcdC | MV | Commandable | Switching function Off/Auto Stage 1..3
SNC/FrstProt/FrcdC | AV | - | Turn-on hysteresis
SNC/FrstProt/FrcdC | AV | - | Turn-off hysteresis

Predefined

HMI | SncMode | R | 1 = Off
 |  |  | 2 = Auto speed 1
 |  |  | 3 = Auto speed 2
 |  |  | 4 = Auto speed 3
Functionality active | SncClock | F | 0 = Blocked
 |  |  | 1 = Enabled
Summer night cooling | SncRequired | F | 0 = Off
 |  |  | 1 = On
Minimum temperature | SncToMin | R | 0..1000
Hysteresis room/outdoor (On) | SncToHystRtOn | R | 0..200
Hysteresis room/outdoor (Off) | SncToHystRtOff | R | 0..200
State | SncToDemand | F | 0 = Off
 |  |  | 1 = On
Hysteresis room temp./SetPt | SncHystRt | R | 0..100
State | SncRtDemand | F | 0 = Off
 |  |  | 1 = On
HMI | FpMode | R | 1 = Off
 |  |  | 2 = Auto speed 1
 |  |  | 3 = Auto speed 2
 |  |  | 4 = Auto speed 3
State | FpRequired | F | 0 = Off
 |  |  | 1 = On
On at room temp lower than | FpLimOn | R | 0..1000
Off at room temp higher than | FpLimOff | R | 0..1000
HMI | FcMode | R | 1 = Off
 |  |  | 2 = Auto speed 1
 |  |  | 3 = Auto speed 2
 |  |  | 4 = Auto speed 3
State | FcRequired | F | 0 = Off
 |  |  | 1 = On
Switch on hysteresis | FcHystOn | R | 0..1000
Switch off hysteresis | FcHystOff | R | 0..1000


Fan speed

Family: | DDC 2.5 Systems
Name: | Fan speed
Macro: | _DDC_SYAHUSPEED250
Version: | 2.5.000

Description

Load-dependent requirement request of the 2nd (or another) level for a ventilation system.

Input |
En | Enable set point monitoring for 2nd speed
ClkSp2 | Clock contact for 2nd speed (parallel to monitoring)
SetPt | Set point to be monitored
Value | Value to be monitored

Output |
Sp2 | Requirement 2nd speed through clock or monitoreing

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Parameter --- ] |
Monitoring mode | Monitoring mode
Switch on hysteresis | Switching hysteresis, will be added or subtracted to/from Set point
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Switching on delay in seconds | Interval, through which the actual value must leave the tolerance range
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Switch off hysteresis | Switching hysteresis, will be added or subtracted to/from Set point
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Switch off delay in seconds | Interval, through which the actual value must reach the tolerance range
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Requirement clock | Requirement 2nd speed from input ClkSp2
Requirement monitoring | Requirement 2nd speed through monitoring condition
Requirement 2nd speed | Requirement 2nd speed for the fan
[ --- Definitions --- ] |
Hysteresis Unit | Unit
COV Hysteresis | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
COV Hysteresis delay | Hysteresis value change. If the value is changed via this hysteresis, it will be sent to registered recipients as COV and/or saved to the Trendlog.
[ --- DDC Suite V 2.5 --- ] |

Functional

Determination of a load-dependent enabling for the 2nd (or another) level of a ventilation system. The 2nd level can be requested whenever there is a shortfall or exceedance or both.

If there is a high signal at input "En", a monitoring of the load-dependent requirement takes place.

If the actual value of the parameter to be monitored (input "Value") for the period of the switch-on delay is outside the starting hysteresis (set point from input "SepPt" plus/minus the set hysteresis) , the 2nd level is enabled.

If the actual value for the period of the switch-off delay lies within the switch-off hysteresis, the enabling of the 2nd level is cancelled.

In shortfalls

The enabling of the 2nd level takes place if the actual value lies below the set point minus switch-on hysteresis for the period of the switch-on delay. If the actual value is greater than the set point minus switch-off hysteresis for the period of the switch-off delay, the enabling of the 2nd level is cancelled.

Select this setting if the 2nd level should be switched on in case of low actual values.

In exceedance

The enabling of the 2nd level takes place if the actual value lies above the set point plus switch-on hysteresis for the period of the switch-on delay. If the actual value is smaller than the set point plus switch-off hysteresis for the period of the switch-off delay, the enabling of the 2nd level is cancelled.

Select this setting if the 2nd level should be switched on in case of high actual values.

In exceedance and shortfall

Both aforesaid functions are active. Select this setting if the 2nd level should be switched on if leaving a range of tolerance.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description
Yes | AV | - | Turn-on hysteresis
Yes | AV | - | Turn-on delay
Yes | AV | - | Turn-off hysteresis
Yes | AV | - | Turn-off delay

Predefined

Monitoring mode | DemandMode | R | 0 = Off
 |  |  | 1 = below
 |  |  | 2 = above
 |  |  | 3 = Both
Switch on hysteresis | HystOn | R | 0..1000
Switching on delay in seconds | DelayOn | R | 0..36000
Switch off hysteresis | HystOff | R | 0..1000
Switch off delay in seconds | DelayOff | R | 0..36000
Requirement clock | Clock | F | 0 = Off
 |  |  | 1 = On
Requirement monitoring | Demand | F | 0 = Off
 |  |  | 1 = On
Requirement 2nd speed | Speed2 | F | 0 = Off
 |  |  | 1 = On


Redundant

Family: | DDC 2.5 Systems
Name: | Redundant
Macro: | _DDC_SYREDUNDANT250
Version: | 2.5.002

Description

Control of 2 drives with automatic change of priority according to operation time counter, fixed time point or failure of a drive.

Input |
En1 | Requirement of the priority motor
En2 | Requirement of the subsequent motor
Ala1 | Alarm of the 1st motor
Ala2 | Alarm of the 2nd motor
CntH1 | Operating hours of the 1st motor
CntH2 | Operating hours of the 2nd motor

Output |
Run1 | Activation 1st motor
Run2 | Activation 2nd motor

Adjust |
[ --- System functions --- ] |
Description | Name of function. Used with data points that have been configured for SWeb Alarming (AlmHeader + Alarming level 1-10 + This text + Alarmtext).
BACnet | Select if and what kind of BACnet objects should be generated automatically
[ --- Parameter --- ] |
Switching mode | Activation function mode
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Switchover according to | Type of switchover
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
... operating hours difference | Difference operating hours for the switchover
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
... Weekday | Weekday on which the switchover should be done
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
... Clock time | Time of the selected day for the switchover
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
Switchover the sequence | Manual inversion of the current sequence
Current sequence | Current sequence of the switching
<--- BACnet Object-Name ---> | Detailed information for Object Name. It consists of the PCS (BACnet - ON / Level 1-10) and this suffix.
- Description | Detailed information for Description. It consists of the PCS (BACnet - D / Level 1-10) and this suffix.
- Optional text | Optional Text, provision, not currently used. If needed, offers the opportunity of indicating additional information, which can be further used in the AddOn Files.
[ --- DDC Suite V 2.5 --- ] |

Functional

Redundant control of 2 drives, typically double pumps.

As a rule, only one drive runs at a time. A switching takes place, for instance, in case of failure of the active drive. To achieve a uniform utilisation of the , a switching can be set in case of difference in the operating hours. Thereby it is ensured that the two pumps equally achieve approximately (this very difference) the same load.

Alternatively, a fixed switching of the relevant drive can also be parameterised, e.g. every Monday at 08:00hrs. This can however lead, according to demand and requirement, to significant operating differences.

Furthermore, there is the possibility to define a pump as fixed master pump. The second drive is then always switched on as the secondary pump.

System function BACnet

This FBox can automatically generate BACnet objects. The corresponding options in the parameter "BACnet" create the following BACnet objects:

Option | Object | Note | Description |
Yes | MV | - | Sequential setting (Auto/Pump 1/Pump 2/Pump 1 2 | )
Yes | BV | - | Type of switching (hour difference/time)
Yes | AV | - | Hour difference
Yes | MV | - | Weekday (Mo .. Su)
Yes | AV | - | Time
Yes | BV | - | Trigger inversion
Yes | BI | - | Current sequence (1-2/2-1) |

Predefined

Switching mode | Mode | R | 0 = Off
 |  |  | 1 = Auto
 |  |  | 2 = Motor 1
 |  |  | 3 = Motor 2
 |  |  | 4 = Motor 1 2
Switchover according to | Funkcion | F | 0 = CntH-Difference
 |  |  | 1 = Day/Clock time
... operating hours difference | Difference | R | 1..65535
... Weekday | Day | R | 0 = daily
 |  |  | 1 = Monday
 |  |  | 2 = Tuesday
 |  |  | 3 = Wednesday
 |  |  | 4 = Thursday
 |  |  | 5 = Friday
 |  |  | 6 = Saturday
 |  |  | 7 = Sunday
 |  |  | 8 = täglich
... Clock time | Time | R | 0..2359
Switchover the sequence | Invert | F | 0 = ...
 |  |  | 1 = invert
Current sequence | Sequence | F | 0 = Motor 1/2
 |  |  | 1 = Motor 2/1


System status

Family: | DDC 2.5 Systems
Name: | System status
Macro: | _DDC_SYSTATE250
Version: | 2.5.000

Description

Display of a system status for the visualisation.

Input |
Run | Indicator system running
Ala | General alarm forcing system stop
Msg | Message not forcing system stop
SetPt | Main set point
Val | Actual value corresponding to set point

Adjust |
Systerm running | Indicator system running
Alarm forcing system stop | General alarm forcing system stop
Message e.g. maintenance | Message not forcing system stop
SetPt/Value in use | Selection if SetPoint/Value is in use
Set point | Main set point
Actual value | Actual value corresponding to set point
[ --- DDC Suite V 2.5 --- ] |

Functional

Displays the system status of a facility for the GLT (e.g. ViSi.Plus or SWeb Application). The display is undertaken like a set of traffic lights - red/yellow/green.

"Run"= Green, the operating status of the relevant equipment of the facility (e.g. air supply motor)

"Ala"= Red, the collective error which mandatorily shuts down the facility

"Msg"Yellow, signals that are not critical (e.g. filter signal)

Via the parameter set point/actual value available, the object to be displayed is informed if the system has a relevant control variable which is important for the system operation, e.g. the outlet air temperature in a ventilation, the inlet temperature in a heater circuit or the ambient temperature in a lift machine room.

"SetPt"set point and/or limit value of the system

"Val"actual value of the system

Predefined

Systerm running | Running | F | 0 = No
 |  |  | 1 = Yes
Alarm forcing system stop | Alarm | F | 0 = Off
 |  |  | 1 = On
Message e.g. maintenance | Message | F | 0 = Off
 |  |  | 1 = On
SetPt/Value in use | Controlled | F | 0 = No
 |  |  | 1 = Yes
Set point | SetPt | R |
Actual value | ContrVal | R |


Weekly clock Ton/Toff

Family: | DDC 2.5 Systems
Name: | Weekly clock Ton/Toff
Macro: | _DDC_SYCLK250
Version: | 2.5.000

Description

Weekly clock timer 1-channel. A 3-stage function can be preset. The respective current turn-on and turn-off switching times (Ton/Toff) are issued.

Input |
En | Enable week clock functionality.

Output |
ChSp1 | Requirement of weekly clock channel speed 1
ChSp2 | Requirement of weekly clock channel speed 2
ChSp3 | Requirement of weekly clock channel speed 3
Ton | Switch on time of today
Toff | Switch off time of today

Adjust |
Monday On | Monday switch on time
... Off | Monday switch off time
Tuesday On | Tuesday switch on time
... Off | Tuesday switch off time
Wednesday On | Wednesday switch on time
... Off | Wednesday switch off time
Thursday On | Thursday switch on time
... Off | Thursday switch off time
Friday On | Friday switch on time
... Off | Friday switch off time
Saturday On | Saturday switch on time
... Off | Saturday switch off time
Sunday On | Sunday switch on time
... Off | Sunday switch off time
Speed selection | Selection of the speed which represents the weekly clock
Today's channel | Status of clock channel
Output Channel (only ChSp1) | Recomended status of clock channel , displayed on output ChSp1/2/3
[ --- DDC Suite V 2.5 --- ] |

Functional

Weekly clock timer 1-channel. If there is no high signal in input "En", no switching function is active.

The stage (1-3) to be displayed by the clock timer can be set, the outputs are in the process engaged, and so all outputs of stages 1, 2 and 3 are simultaneously active in stage 3.

The On and Off times of the present day is issued at the outputs "Ton" and "Toff".

A cycle of operation can be set per weekday. The time 00:00 is in the process not interpreted as switching point. Thereby switching functions that go beyond a day can be parameterised, e.g.

E.g.: Monday from 14:00 hrs till Tuesday 19:00 hrs is to be set as follows:

Day | On | Off
Monday | 14:00 | 00:00 (No switching point)
Tuesday | 00:00 (No switching point) | 19:00

E.g. daily from 20:00 hrs till next day 08:00 hrs is to be set as follows:

Day | On | Off
Monday | 20:00 | 08:00
Tuesday | 20:00 | 08:00
... | ... | ...
Sunday |  | 20:00 | 08:00

If the switch-on and switch-off time on a day is given as 00:00 hrs, there will be no switching on this day. The clock remains off.

Predefined

Monday On | MondayOn | R | 0..2359
... Off | MondayOff | R | 0..2359
Tuesday On | TuesdayOn | R | 0..2359
... Off | TuesdayOff | R | 0..2359
Wednesday On | WednesdayOn | R | 0..2359
... Off | WednesdayOff | R | 0..2359
Thursday On | ThursdayOn | R | 0..2359
... Off | ThursdayOff | R | 0..2359
Friday On | FridayOn | R | 0..2359
... Off | FridayOff | R | 0..2359
Saturday On | SaturdayOn | R | 0..2359
... Off | SaturdayOff | R | 0..2359
Sunday On | SundayOn | R | 0..2359
... Off | SundayOff | R | 0..2359
Speed selection | Speed | R | 2 = Speed 1
 |  |  | 3 = Speed 2
 |  |  | 4 = Speed 3
Today's channel | Channel | F | 0 = Off
 |  |  | 1 = On
Output Channel (only ChSp1) | Enabled | F | 0 = Off
 |  |  | 1 = On


Weekly clock Manual

Family: | DDC 2.5 Systems
Name: | Weekly clock Manual
Macro: | _DDC_SYCLKMAN250
Version: | 2.5.000

Description

Weekly clock timer 1-channel with day override. If there is no high signal in input "En", no switching function is active.

Input |
En | Enable week clock functionality.

Output |
Channel | Requirement of weekly clock channel

Adjust |
Monday channel | Monday mode selection
... On | Monday switch on time
... Off | Monday switch off time
Tuesday channel | Tuesday mode selection
... On | Tuesday switch on time
... Off | Tuesday switch off time
Wednesday channel | Wednesday mode selection
... On | Wednesday switch on time
... Off | Wednesday switch off time
Thursday channel | Thursday mode selection
... On | Thursday switch on time
... Off | Thursday switch off time
Friday channel | Friday mode selection
... On | Friday switch on time
... Off | Friday switch off time
Saturday channel | Saturday mode selection
... On | Saturday switch on time
... Off | Saturday switch off time
Sunday channel | Sunday mode selection
... On | Sunday switch on time
... Off | Sunday switch off time
Today's channel | Status of clock channel
Output Channel | Recomended status of clock channel , displayed on output Channel
[ --- DDC Suite V 2.5 --- ] |

Functional

Weekly clock timer 1-channel. If there is no high signal in input "En", no switching function is active.

A forced override can be set per weekday. Thereby the switching points need not be changed, if for instance they should be permanently enabled for an event on Tuesday.

A cycle of operation can be set per weekday. The time 00:00 is in the process not interpreted as switching point, if it is about a switching point overlapping a day. Thereby switching functions that go beyond a day can be parameterised, e.g. Monday from 14:00 hrs till Tuesday 19:00 hrs is to be set as follows:

Day | On | Off
Monday | 14:00 | 00:00 (No switching point)
Tuesday | 00:00 (No switching point) | 12:00

This however cannot be repeated each day in this way, because as soon as a turn-on instant is determined (e.g. Tuesday turn-on again at 14:00) it is turned off till 14:00 hrs.

If this is however required, the FBox "Wochenuhr Ton/Toff" must be used.

Predefined

Monday channel | MondayMode | R | 0 = whole day Off
 |  |  | 1 = Clock time
 |  |  | 2 = whole day On
... On | MondayOn | R | 0..2359
... Off | MondayOff | R | 0..2359
Tuesday channel | TuesdayMode | R | 0 = whole day Off
 |  |  | 1 = Clock time
 |  |  | 2 = whole day On
... On | TuesdayOn | R | 0..2359
... Off | TuesdayOff | R | 0..2359
Wednesday channel | WednesdayMode | R | 0 = whole day Off
 |  |  | 1 = Clock time
 |  |  | 2 = whole day On
... On | WednesdayOn | R | 0..2359
... Off | WednesdayOff | R | 0..2359
Thursday channel | ThursdayMode | R | 0 = whole day Off
 |  |  | 1 = Clock time
 |  |  | 2 = whole day On
... On | ThursdayOn | R | 0..2359
... Off | ThursdayOff | R | 0..2359
Friday channel | FridayMode | R | 0 = whole day Off
 |  |  | 1 = Clock time
 |  |  | 2 = whole day On
... On | FridayOn | R | 0..2359
... Off | FridayOff | R | 0..2359
Saturday channel | SaturdayMode | R | 0 = whole day Off
 |  |  | 1 = Clock time
 |  |  | 2 = whole day On
... On | SaturdayOn | R | 0..2359
... Off | SaturdayOff | R | 0..2359
Sunday channel | SundayMode | R | 0 = whole day Off
 |  |  | 1 = Clock time
 |  |  | 2 = whole day On
... On | SundayOn | R | 0..2359
... Off | SundayOff | R | 0..2359
Today's channel | Channel | F | 0 = Off
 |  |  | 1 = On
Output Channel | Enabled | F | 0 = Off
 |  |  | 1 = On


Weekly clock Option

Family: | DDC 2.5 Systems
Name: | Weekly clock Option
Macro: | _DDC_SYCLKOPT250
Version: | 2.5.000

Description

Switching functions for clocks for up to 3-stage systems. If there is no High signal in input "En", no switching function is active.

Input |
En | Enable week clock functionality - if En is low all outputs are reset
Sp1 | Speed 1 required
Sp2 | Speed 2 required
Sp3 | Speed 3 required

Output |
ChSp1 | Speed 1 reccomended
ChSp2 | Speed 2 reccomended
ChSp3 | Speed 3 reccomended

Adjust |
Monday channel | Mode on Monday
Tuesday channel | Mode on Tuesday
Wednesday channel | Mode on Wednesday
Thursday channel | Mode on Thursday
Friday channel | Mode on Friday
Saturday channel | Mode on Saturday
Sunday channel | Mode on Sunday
Input speed 1 | Input status clock channel for speed 1
Input speed 2 | Input status clock channel for speed 2
Input speed 3 | Input status clock channel for speed 3
Output Channel speed 1 | Recomended status of clock channel , displayed on output ChSp1
Output Channel speed 2 | Recomended status of clock channel , displayed on output ChSp2
Output Channel speed 3 | Recomended status of clock channel , displayed on output ChSp3
[ --- DDC Suite V 2.5 --- ] |

Functional

Weekly switching function 3-stage. It can be specified per weekday if the requirement should be on permanent Off, stage 1, stage 2 or stage 3 or according to the connected time channels at the inputs.

For instance, a holiday programme can be connected at the input "En", which if need be deactivates this FBox.

Predefined

Monday channel | MondayMode | R | 0 = Off
 |  |  | 1 = Clock time
 |  |  | 2 = Speed 1
 |  |  | 3 = Speed 2
 |  |  | 4 = Speed 3
Tuesday channel | TuesdayMode | R | 0 = Off
 |  |  | 1 = Clock time
 |  |  | 2 = Speed 1
 |  |  | 3 = Speed 2
 |  |  | 4 = Speed 3
Wednesday channel | WednesdayMode | R | 0 = Off
 |  |  | 1 = Clock time
 |  |  | 2 = Speed 1
 |  |  | 3 = Speed 2
 |  |  | 4 = Speed 3
Thursday channel | ThursdayMode | R | 0 = Off
 |  |  | 1 = Clock time
 |  |  | 2 = Speed 1
 |  |  | 3 = Speed 2
 |  |  | 4 = Speed 3
Friday channel | FridayMode | R | 0 = Off
 |  |  | 1 = Clock time
 |  |  | 2 = Speed 1
 |  |  | 3 = Speed 2
 |  |  | 4 = Speed 3
Saturday channel | SaturdayMode | R | 0 = Off
 |  |  | 1 = Clock time
 |  |  | 2 = Speed 1
 |  |  | 3 = Speed 2
 |  |  | 4 = Speed 3
Sunday channel | SundayMode | R | 0 = Off
 |  |  | 1 = Clock time
 |  |  | 2 = Speed 1
 |  |  | 3 = Speed 2
 |  |  | 4 = Speed 3
Input speed 1 | InSpeed1 | F | 0 = Off
 |  |  | 1 = On
Input speed 2 | InSpeed2 | F | 0 = Off
 |  |  | 1 = On
Input speed 3 | InSpeed3 | F | 0 = Off
 |  |  | 1 = On
Output Channel speed 1 | OutSpeed1 | F | 0 = Off
 |  |  | 1 = On
Output Channel speed 2 | OutSpeed2 | F | 0 = Off
 |  |  | 1 = On
Output Channel speed 3 | OutSpeed3 | F | 0 = Off
 |  |  | 1 = On


Weekly clock Selection

Family: | DDC 2.5 Systems
Name: | Weekly clock Selection
Macro: | _DDC_SYCLKSEL250
Version: | 2.5.000

Description

Selection of 10 timings

Input |
Channel | Statusis of the 10 clock channels, binary (Bit 0=Clock1, Bit 1=Clock2 .. Bit 9=Clock10)
# | Selection used channel for coresponding output

Output |
En | Recommended mode

Functional

Mainly used for control of light. An index for 10 switching channels and up to 10 light bands is supported.

- At the input "Channel", 10 switching channels (or other requirements) are present in an index on the Bits 0-9.

- For the outputs "En0" to "En9", the Bit (=switching channel) that should control the output at the inputs "#0" to "#9" can be preselected. The functions Off (0), Time1 (1) to Time10 (10) and On (11) are available.


Time Interval

Family: | DDC 2.5 Systems
Name: | Time Interval
Macro: | _DDC_SYINTERVALL250
Version: | 2.5.000

Description

Interval timer for a cyclical operation.

Input |
En | Enable interval functionality.

Output |
Int | Recommended interval mode

Adjust |
Interval | HMI or SCADA access to control the interval
Start with | Interval start type according to input En
Switching on duration | Switching on duration in minutes
Switchng off duration | Switching off duration in minutes
Recommended mode | Recommended interval mode, displayed on output Int
Current interval status | Current interval status
[ --- DDC Suite V 2.5 --- ] |

Functional

Interval timer to cyclically turn on and turn off, for example, a toilet exhaust after switch-off of the day timer.

With the input "En", the function can be enabled or disabled. Moreover, this function can be executed again in the FBox, e.g. to control this via a visualisation.

The turn-on/turn-off duration is to be stated in minutes It can be preset whether the interval schedule should begin first of all with the turn-off duration or the turn-on duration. Consequently, it is possible to enable this FBox, for example, with the ending of the day schedule in order to begin first with the turn-off cycle.

Predefined

Interval | Mode | F | 0 = Locked
 |  |  | 1 = Active
Start with | StartType | F | 0 = Off time
 |  |  | 1 = On time
Switching on duration | OnTime | R | 0..1440
Switchng off duration | OffTime | R | 0..1440
Recommended mode | Enabled | F | 0 = Off
 |  |  | 1 = On
Current interval status | Interval | F | 0 = Off
 |  |  | 1 = On


Time Holiday

Family: | DDC 2.5 Systems
Name: | Time Holiday
Macro: | _DDC_SYHOLIDAY250
Version: | 2.5.000

Description

Processing of a switching cycle for a specified duration.

Input |
Frg | Enable Holiday functionality.

Output |
Hol | Holiday active

Adjust |
Period active | Method of functioning, annual or only once
Switch on time | Switch on time
Switch on date | Switch on date
Switch off time | Switch off time
Switch off date | Switch off date
Function active | Status Holiday functionality enabled
Holiday active | Recommended interval mode, displayed on output Hol
[ --- DDC Suite V 2.5 --- ] |

Functional

A switching cycle with specification of a start date/time and an end date/time can be defined. The switching cycle is processed only when both date entries make sense (not 00.00).

Predefined

Period active | Annual | F | 0 = once
 |  |  | 1 = yearly
Switch on time | OnTime | R | 0..2359
Switch on date | OnDate | R | 0..1231
Switch off time | OffTime | R | 0..2359
Switch off date | OffDate | R | 0..1231
Function active | Enabled | F | 0 = No
 |  |  | 1 = Yes
Holiday active | Holiday | F | 0 = No
 |  |  | 1 = Yes


Time Special days

Family: | DDC 2.5 Systems
Name: | Time Special days
Macro: | _DDC_SYSPECDAY250
Version: | 2.5.000

Description

Processing up to 12 holidays with annual repetition or a one-time execution.

Input |
En | Enable special day functionality.

Output |
Day | Special day active

Adjust |
Switch on time | Switch on time - all special days
Switch off time | Switch off time - all special days
Special day events active | Method of functioning, annual or only once
Special day 1 | Special day event 1
Special day 2 | Special day event 2
Special day 3 | Special day event 3
Special day 4 | Special day event 4
Special day 5 | Special day event 5
Special day 6 | Special day event 6
Special day 7 | Special day event 7
Special day 8 | Special day event 8
Special day 9 | Special day event 9
Special day 10 | Special day event 10
Special day 11 | Special day event 11
Special day 12 | Special day event 12
Special day functinality activ | Status special day functionality enabled
Special day active | Recommended mode, displayed on output Day
[ --- DDC Suite V 2.5 --- ] |

Functional

Up to 12 holidays can be programmed. The turn-on/turn-off times are applicable for all 12 holidays. To turn off the holidays, the month 00 with the day 00 can be used.

Predefined

Switch on time | OnTime | R | 0..2359
Switch off time | OffTime | R | 0..2359
Special day events active | Annual | F | 0 = once
 |  |  | 1 = annual
Special day 1 | Day1 | R | 0..1231
Special day 2 | Day2 | R | 0..1231
Special day 3 | Day3 | R | 0..1231
Special day 4 | Day4 | R | 0..1231
Special day 5 | Day5 | R | 0..1231
Special day 6 | Day6 | R | 0..1231
Special day 7 | Day7 | R | 0..1231
Special day 8 | Day8 | R | 0..1231
Special day 9 | Day9 | R | 0..1231
Special day 10 | Day10 | R | 0..1231
Special day 11 | Day11 | R | 0..1231
Special day 12 | Day12 | R | 0..1231
Special day functinality activ | Enabled | F | 0 = No
 |  |  | 1 = Yes
Special day active | SpecialDay | F | 0 = No
 |  |  | 1 = Yes