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ScommDll non funziona a causa di software firewall

FAQ #100323

Non è possibile connettersi tramite qualsiasi canale a un PCD usando il SCommDll. Il software firewall software "Zona allarme sicurezza", "Windows Defender" o "Bitdefender" blocco la SComm funktionality su PC con MS XP.

 

Sintomo
Se il ScommDll è lanciato, il PC non reagiscono su scioperi chiavi per più di 40 sec. Dopo questo tempo, viene visualizzato un messaggio di errore dicendo "errore SCommDll, presa numero IP di server non installata o sbagliato".

Motivo
Il firewall software "Zona allarme sicurezza" blocca il ScommDll (SCommDll il comunicato per il SCommDrv attraverso un flusso IP sulla porta 7000 bloccato).

Soluzione
Allarme di zona deve essere disinstallato; solo disattivando non funziona nella maggior parte dei casi. Questo fenomeno è stato osservato solo su Windows XP. Su W2k sembra che il ScommDll funziona anche con ZoneAlarm attivato.
Nel caso in cui viene utilizzato il Bitdefender o disabilitazione o configurando opportunamente dovrebbe aiutare.

Suggerimenti

  • Il comportamento descritto sopra si applicano anche a molti altri firewall personali (aka Desktop Firewall, Internet Security Suite ecc.). Così se la comunicazione di presa non funziona, questi strumenti di sicurezza devono essere controllati.
  • Maggior parte dei Personal Firewall può essere configurato da così chiamato "regole", che consentono di aprire determinate porte per una o più applicazioni. Così invece di totalmente disattivare o disinstallare il software firewall der, può essere una soluzione migliore per definire regole di firewall apropriate che permettono SCommDrv di comunicare comunque.
    Per le parti pertinenti di PG5 SCommDll.dll e SCommDrv.exe a lavorare la porta TCP 7000 deve essere abilitata nell'host locale!

Categories

Software (except PG5) / SCOMM

Communication / Ether-S-Bus

PG5 2.0 / Profi-S-Bus

PG5 2.0 / Serial-S-Bus

PG5 2.0 / Modem

Last update: 28.05.2015 02:54

First release: 18.02.2005 11:24

Views: 12849

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